Soporte » Guías – Resolución de problemas » No puedo crear un producto nuevo para woocommerce

  • Resuelto jmanuel182

    (@jmanuel182)


    hola, tengo un gran problema ya que no puedo agregar un producto nuevo ya que la casilla donde debería estar para publicar el producto me sale el siguiente mensaje: Warning: call_user_func() expects parameter 1 to be a valid callback, function ‘post_submit_meta_box’ not found or invalid function name in /home/customer/www/amazonaslatinmarket.com/public_html/wp-admin/includes/template.php on line 1389

    imagen de la linea 1389

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Hola @jmanuel182

    Por lo que comentas algun plugin o el theme esta dando problemas.
    En estos casos deberas desactivar todos los plugins, theme y comprobar que funciona para saber cual esta dando problemas.

    Iniciador del debate jmanuel182

    (@jmanuel182)

    hola @kallookoo

    gracias por tu respuesta, no me funcionó lo de desactivar los plugins y el tema. Sigue estando el error que no me deja publicar los productos ni editarlos.

    Alguna otra solución?

    Hola @jmanuel182

    Si despues de desactivar todos los plugins y el theme no se solucion, solo se me ocurre que los archivos del WordPress estan corruptos o incompletos.
    Una posible solucion seria reinstalar el WordPress, te diriges al apartado de actualizaciones y veras que te pondra reinstalar o lo puedes hacer manualmente descargandote los archivos y remplazarlos y en teoria deberia funcionar ya que la funcion que comentas es del propio WordPress.

    Ya diras como fue!

    Edit: Otra opcion que me olvide seria reinstalar el WooCommerce, pero dudo que sea el causante

    • Esta respuesta fue modificada hace 2 meses, 1 semana por kallookoo.
    Iniciador del debate jmanuel182

    (@jmanuel182)

    hola @kallookoo

    Bueno por los momentos reinstalé el wordpress y persiste el error. La verdad ya no se que hacer.

    Hola @jmanuel182

    Lo que sucede no tiene sentido.
    Una consulta, te sucede lo mismo cuando creas una pagina o una entrada?
    Tienes definida esta funcion post_submit_meta_box dentro del archivo wp-admin/includes/meta-boxes.php ya que segun lo que comenta tu error es la culpable y por eso mismo te comente que reinstalases el WordPress al ser una funcion del propio WordPress.

    Iniciador del debate jmanuel182

    (@jmanuel182)

    Hola @kallookoo

    hice un entorno de prueba en mi servidor, y mágicamente en el entorno aparece el campo que me da el error en la pagina original, que podría hacer que en este caso el error desaparezca? la respuesta a tu pregunta es si, la función está definida en el archivo.

    Ahora lo que no entiendo es este comportamiento en el entorno de pruebas. Gracias de antemano por toda la colaboración que me brindas en este problema

    Iniciador del debate jmanuel182

    (@jmanuel182)

    Al darme cuenta de lo que sucedió hablé directamente con el soporte de mi hosting, ellos de alguna manera restablecieron el wordpress comparando la copia que había hecho y la original observando que ésta ultima estaba corrupta. Al parecer entonces si era el wordpress, pero con restablecer desde el escritorio no era suficiente para eliminar el error.

    Muchas gracias por toda la ayuda

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.