Soporte » Instalación – Actualizaciones » No puedo entrar en wp-admin “wp-admin/upgrade.php?”

Viendo 15 respuestas - 16 de 30 (de 32 total)
  • Moderador almendron

    (@almendron)

    Después de hacer todo lo que te indicado, debes editar el archivo wp-config.php (haz antes una copia de seguridad):
    1) Comprueba que al principio, antes de <?php, no hay ningún espacio o línea. El archivo debe comenzar con esos caracteres.
    2) Busca la línea define (WP_CACHE’, true); y la eliminas.
    3) El archivo debe acabar en

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    No debe haber nada después de esas líneas.

    • Esta respuesta fue modificada hace 10 meses, 1 semana por  almendron.
    • Esta respuesta fue modificada hace 10 meses, 1 semana por  almendron.
    • Esta respuesta fue modificada hace 10 meses, 1 semana por  almendron.
    Moderador almendron

    (@almendron)

    1) ¿Has borrado el htaccess del servidor?
    2) ¿has cambiado el nombre a la carpeta plugins?
    3) ¿Has eliminado los archivos que te he dicho?
    4) ¿Has modificado y comprobado lo del wp-config.php?
    5) ¿Estás intentando entrar por http://activofinanciero.com/wp-login.php?

    Primero contesta a estas preguntas y luego seguimos.

    Borrado: define(‘WP_CACHE’, true); // Added by W3 Total Cache

    Y esto estaba así:

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);
    add_filter( ‘auto_update_plugin’, ‘__return_true’ );
    add_filter( ‘auto_update_theme’, ‘__return_true’ );

    lo he borrado y he podido entrar.

    Me pide actualizar la base de datos, doy OK?

    Moderador almendron

    (@almendron)

    Dale a OK. y dime si te deja entrar en la adminsitración.
    Una vez te deje, hay que hacer un par de cosas para dejarlo todo bien.

    He dado Ok, no ha tardado ni 3 segundos.

    Estoy dentro del escritorio. Que hago ahora?

    Moderador almendron

    (@almendron)

    Vamos a revertir algunos cambios:
    1) Ve a Ajustes > Enlaces permanentes y dale a guardar. Con eso reconstruimos el htaccess.
    2) Sal de la administración.
    3) Vía FTP cambia el nombre de la carpeta “plugins-des” a “plugins”.
    4) Vuelve a entrar a la administración. Todos los plugins estarán desactivados.
    5) Ahora, plugin a plugin, haces lo siguiente: activa-sal de la adminsitración-vuelve a entrar. DEJA PARA EL FINAL el W3TC. Creo que era el responsable. O eso o era el wp-config.php

    Ok,

    He seguido todos los pasos y he activado los plugins uno por uno.

    En algunos aparecen errores en la parte superior del escritorio:

    “on un argumento que está obsoleto desde la versión 2.0.0! El uso de niveles de usuarios por plugins y temas está obsoleto. Usa los perfiles y capacidades en su lugar. in /home1/xxx/public_html/wp-includes/functions.php on line 4020”

    Supongo que será borrar y volver a instalar.

    El w3tc no ha dado problemas para volver a iniciar. ¿Me recomiendas borrar y volver a instalar?

    Todo funciona correctamente.

    Te voy a enviar un email, la dirección la he sacado de tu web.

    Te doy las gracias de todo corazón. No sabes como me has ayudado.

    • Esta respuesta fue modificada hace 10 meses, 1 semana por  aiponero.
    Moderador almendron

    (@almendron)

    Te contesto en cuanto pueda.
    No borres nada

    • Esta respuesta fue modificada hace 10 meses, 1 semana por  almendron.
    Moderador almendron

    (@almendron)

    1) w3tc: desactiva, borra y vuelve a instalar.
    2) Pon aquí el error completo que te da.
    3) Edita wp-config.php y cambia la línea define('WP_DEBUG', true); por define('WP_DEBUG', false);. La próxima vez que tengas un problema cambia false por true.
    4) El error que te da será por algún plugin o por el tema que tendrá caducada alguna función. Es muy probable que ya no te salga una vez hayas hecho lo del punto 3.

    Y oye, de nada. Un placer haber podido ayudarte. Luego te contesto al email que me has mandado.
    Un saludo.

    Sustituido el modo debug.

    Borrado W3TC y reinstalación.

    Al instalarlo de nuevo error!:

    Notice: has_cap fue llamado con un argumento que está obsoleto desde la versión 2.0.0! El uso de niveles de usuarios por plugins y temas está obsoleto. Usa los perfiles y capacidades en su lugar. in /home1/xxx/public_html/wp-includes/functions.php on line 4020

    Warning: Cannot modify header information – headers already sent by (output started at /home1/xxx/public_html/wp-includes/functions.php:4020) in /home1/xxx/public_html/wp-includes/pluggable.php on line 1179

    Warning: Cannot modify header information – headers already sent by (output started at /home1/xxx/public_html/wp-includes/functions.php:4020) in /home1/xxx/public_html/wp-includes/pluggable.php on line 1179

    Afortunadamente he recargado la página y el error se ha ido y puedo entrar con normalidad al escritorio.

    ¿Hago algo más?

    • Esta respuesta fue modificada hace 10 meses, 1 semana por  aiponero.
    Moderador almendron

    (@almendron)

    “Notice” y “Warning” no son avisos graves pero está indicando que algún plugin utiliza códigos obsoletos.
    No estoy seguro de que sea el W3TC sea el responsable. Podría ser también el Facebook Like Box que hace siete años que no se actualiza.
    Haz lo siguiente:
    1) Edita el wp-config.php y cambia a true el debug.
    2) Entra en la administración y navega por la adminsitración a ver qué errores te salen. Toma nota de ellos y los pones aquí.
    3) Desactiva el plugin Facebook Like Box y mira a ver si así desaparecen esos errores.
    4) Finalmente, vuelve a poner false al debug

    Moderador almendron

    (@almendron)

    Y otra cosa en el wp-config.php:
    Te ha vuelto a aparecer lo de

    add_filter( ‘auto_update_plugin’, ‘__return_true’ );
    add_filter( ‘auto_update_theme’, ‘__return_true’ );

    al final o en otra parte.

    Muy buenas a ver si me podéis echar una mano. Tengo el mismo error que se describe en el inicio de este hilo. Atendiendo a lo que se explica he activado el (‘WP_DEBUG’, true); y he eliminado el archivo .htacces pero con estas dos cosas no consigo acceder a la consola de WordPress. El mensaje de error que me da cuando intento acceder es:

    Notice: ¡El método de llamada al constructor WP_Widget en ads125_widget está obsoleto desde la versión 4.3.0! Utiliza
    __construct()

    ¿Sabes que es lo que tendría que hacer para solucionar el problema?

    Moderador almendron

    (@almendron)

    @jsans: abre un nuevo hilo para que podamos ayudarte.

    Muchas gracias. Tal y como me indicas he creado un nuevo hilo en

    No puedo entrar en wp-admin “HTTP ERROR 500”

Viendo 15 respuestas - 16 de 30 (de 32 total)
  • El debate ‘No puedo entrar en wp-admin “wp-admin/upgrade.php?”’ está cerrado a nuevas respuestas.