• Resuelto jroigama

    (@jroigama)


    He intentado instalar la última versión de worspress y me sale el siguiente mensaje:

    «Descargando paquete de instalación desde http://es.wordpress.org/wordpress-3.7.1-es_ES.zip…

    Descomprimiendo actualización…

    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php

    Instalación fallida«

    ¿Alguien me puede ayudar?

    Muchas gracias

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • Meiji

    (@meiji_lythtis)

    Es cosa de permisos en tu servidor, tienes acceso a éste vía FTP? Qué servidor utilizas, Linux Server o Windows Server? Si estás en Linux sólo ve a la carpeta wp-admin/includes, dale click derecho y selecciona permisos de archivo. En el campo de ‘Valor Numérico’ escribe 777 y aceptar. Espera a que termine y trata volver a actualizar.

    Después de esto, regresa nuevamente esa carpeta a los permisos que tenía anteriormente.

    Iniciador del debate jroigama

    (@jroigama)

    Hola!

    Gracias por intentar echarme una mano!

    Creo que si tengo acceso a éste vía FTP y creo que el servidor es Linux Server. He intentado cambiar los permisos tal y como me has indicado y me da error. Simplemente me dice «Se ha producido un error».

    ¿Qué puedo ser? ¿Qué puedo hacer?

    Muchas gracias

    Iniciador del debate jroigama

    (@jroigama)

    Hola,

    ya he conseguido cambiar los permisos del archivo que me has indicado. He intentado actualizar de nuevo y me aparece un nuevo mensaje de error

    «Descargando paquete de instalación desde http://es.wordpress.org/wordpress-3.7.1-es_ES.zip…

    Descomprimiendo actualización…

    Warning: copy(/homepages/37/d500223998/htdocs/clickandbuilds/WordPress/MyBlog/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /homepages/37/d500223998/htdocs/clickandbuilds/WordPress/MyBlog/wp-admin/includes/class-wp-filesystem-direct.php on line 217
    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php

    Instalación fallida»

    ¿Me puedes ayudar?

    Iniciador del debate jroigama

    (@jroigama)

    Hola de nuevo, problema solucionado. He cambiado los permisos de los archivos que salen en el mensaje de error a 777 también (wp-admin/includes/class-wp-filesystem-direct.php y wp-admin/includes/update-core.php) y ha funcionado.

    Gracias

    Meiji

    (@meiji_lythtis)

    Hola! Disculpa la tardanza! Pero qué bien que has podido solucionarlo! Sólo una cosa más, una vez que ya has podido actualizar todo, NO dejes las carpetas y archivos con los permisos 777, ya que es muy vulnerable. Regrésalos a la configuración que tenían anteriormente. Si tienes que actualizar de nuevo y sigue sin dejarte, repite el procedimiento.

    Salu2!!

    Iniciador del debate jroigama

    (@jroigama)

    Justo lo acabo de hacer… pero dudaba de si hacerlo o no… que bien que me has venido ahora mismo :)))

    Ok, gracias!!

    Hola,
    tengo el mismo problema al actualizar a la version 3.7.1, pero yo no quiero descargar el paquete en mi servidor. Por qué no funciona la actualización automatica?
    Tengo de momento dos páginas una es un blog de wordpress y la otra pagina esta alojada con un dominio. Estoy pasando la información del blog a la web, pero en la web no tengo todas opciones de menu para la configuracion de la apariencia, widgets, enlaces, etc. como figuran en el blog y el tema es el mismo.
    Espero que me podais ayudar. Gracias!

    Meiji

    (@meiji_lythtis)

    Hola Xavi! En dónde te marca error al actualizar, en ambas instalaciones de WP? Qué es exactamente lo que te dice?

    Qué tema estás utilizando, es uno gratuito o comprado? Por último, cómo estás pasando la información, de manera manual o por medio de algún plugin? Ya que el template es el mismo, lo que podrías hacer para esto último es backupear tu blog (donde quiera que esté) y restaurarlo en tu host para que acceda con tu dominio, y de ahí simplemente crear las páginas extra que necesites.

    Hola meji_lythtis,
    muchas gracias por contestar!

    este el error que me indica, directamente cuando pincho el link de actualización en el escritorio de la web:
    Descargando paquete de instalación desde http://es.wordpress.org/wordpress-3.7.1-es_ES.zip…

    Descomprimiendo actualización…

    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php

    Instalación fallida

    Estoy utilizando un tema gratuito, la informacion ha sido instalada manual. La web tiene ya contenido nuevo que el blog no tiene. No se lo que es un backupear o mejor dicho como se hace, tampoco creo que sea conveniente ya que hay diferencias en el contenido.

    Meiji

    (@meiji_lythtis)

    Hola de nuevo! Necesitas accedes por medio de FTP y desde ahí otorgarle permisos de escritura (777) al folder includes, del mismo modo que jroigama lo hizo.

    Backupear es respaldar, pero ciertamente en este momento ya no es conveniente por toda la información nueva que hay en la nueva página.

    Prueba con los permisos y me dices si funcionó.

    Salu2!!

    Hola Meji,
    gracias de nuevo. Tengo back up copy de la web. No uso Lynux, mi sistema es Windows XP, pero no quiero descargar los permisos en mi servidor, si lo he entendido bien. El alojamiento de la web es de terceros no de wordpress y ya intentaron restaurar hasta donde fue posible pero sigue sin funcionar correctamente.
    Hay alguna otra opción de conseguir que la version funcionen correctamente y se pueda actualizar?

    Meiji

    (@meiji_lythtis)

    Hola! Por Linux o Windows no me refiero al sistema operativo, sino al servidor en donde está alojado el sitio web. Tampoco tienes que descargar nada, simplemente es que el servidor no tiene permisos de escritura en esa área en particular donde quieres actualizar (wp-admin/includes).

    Lo único que hay que hacer es accesar por medio de FTP, ir a la carpera includes, click derecho, permisos de archivo, y en el campo de valor numérico escribir 777, esto nos dará los permisos necesarios para actualizar.

    Después de esto, intenta actualizar nuevamente, si has tenido éxito, vuelve al FTP y regresa la carpeta includes a los permisos que tenía anteriormente. Es importante que no lo dejes en 777.

    Iniciador del debate jroigama

    (@jroigama)

    Hola de nuevo,

    de nuevo con problemas con la actualización de wordpress a la versión 3.9. Aún estoy con 3.7.1 pues después de conseguir actualizar la versión me surgieron otros problemas y tuve que reinstalar el wordpress.

    He cambiado los permisos tal como me indicaste la otra vez pero ahora me sale otro mensaje de error:

    Descargando paquete de instalación desde https://downloads.wordpress.org/release/es_ES/wordpress-3.9.zip…
    Descomprimiendo actualización…
    Verificando los archivos descomprimidos…
    Preparing to install the latest version…
    Activando el modo mantenimiento…
    Copying the required files…
    Desactivando el modo de mantenimiento…
    No ha sido posible crear el directorio: wp-admin/css/colors
    Instalación fallida

    Muchas gracias!!

    Es lo mismo, problemas de permisos de escritura, en este caso en wp-admin/css/colors. Dile a tu hosting que te lo solucione, no te recomiendo que le pongas 777 a todo, no es seguro. Puedes ponerle 777 hacer la actualización y cambia de nuevo a 755.

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • El debate ‘No puedo instalar la versión 3.7.1’ está cerrado a nuevas respuestas.