Soporte » Guías – Resolución de problemas » No puedo modificar el idioma del sitio con el boton de cambio de idioma

  • Resuelto Raul Hermoso

    (@raul-hermoso)


    Hola, estoy cambiando el idioma a español y aunque lo hace en el backend en el sistema queda registrado que sigue en Ingles (en_EN) lo cual al instalar woocomerce todos loa botones me salen en ingles y los necesito en español.. que puedo hacer? he probado a reinstalar y actualizar pero nada de nada.. me podeis ayudar?

    Gracias por adelantado!

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Moderador josearcos

    (@josearcos)

    Hola, @raul-hermoso. Prueba a mirar en el wp-config.php, quizá tengas escrito el idioma inglés ahí, si no fuera el caso, escribe la siguiente línea:

    define ('WPLANG', 'es_ES');

    Espero que te sirva, un saludo.

    Gracias, pero esta opcion creo q ya no es factible desde WP 5.. En el analisis del salud del sitio sigue saliendo en_En y claro woocomerce me sale en ingles, puede tener q ver el theme? Estoy usando Divi..

    Moderador josearcos

    (@josearcos)

    Hola de nuevo, @raul-hermoso. Prueba a hacer la depuración básica, desactivando todos los plugins y activando el tema por defecto, quizá haya alguno que te está forzando el idioma, aunque me suena más a algún problema en el servidor o la caché.

    Un saludo.

    Pues si, es el theme que esta forzando el idioma.. al desactivarlo y poner otro ya permite modificarlo, vaya, gracias voy a ponerme en contacto con soporte de ElegantThemes.. que raro, muchas gracias José por la orientacion, me has ahorrado muchas horas.. 😀

    Hola Raul, tengo el mismo problema que tú con Divi, pero el soporte de Divi me pidió que me contacte con Woocommerce. Pudiste resolver tu problema al final?

    Hola, yo lo solucione desactivando Divi, activando otro theme y despues volviendo a activar Divi pues era este el que estaba forzando a Woocomerce el idioma, (WP estaba en español pero todo lo de woocomerce se me quedo en ingles) creo que esto es lo que hice y funciono, Woocomerce debe hacer lo que el idioma del sitio este configurado en los ajustes de WordPress, pero no se porque al actualizr Woocomerce esto no lo siguio y yo segun recuerdo lo resolvi asi, no era ningun pluging, eso si yo tenia el theme de Divi, no el Divi builder.. ya me dices si se arregla asi, , cuidado con perder el css si has personalizado.. saludos!

    Hola Raul, gracias por tu respuesta! Hice lo que sugeriste arriba, pero seguía con partes en Inglés. Al final descubrí (luego de mucha investigación) que cuando la traducción del idioma no está 100% completada, WP lo redirigía automáticamente al inglés, y por ende Woocommerce también. El idioma que tenía configurado era español-Peru, que no tenía 100% completada la traducción, y lo cambié al español-México que sí estaba 100% traducido. Luego de desactivar todos los plugins y Divi, borrar cache del host, y volver a activar todo, funcionó por fin. Espero que mi experiencia le sirva a alguien más.

    • Esta respuesta fue modificada hace 2 semanas, 2 días por anniliao.

    Genial!, compartir conocimiento es lo que hace grande a una comunidad, suerte con todo!

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.