Soporte » Guías – Resolución de problemas » No puedo subir imágenes a medios desde mi ordenador

  • Resuelto irena

    (@irenaheinz)


    Hola a todos!

    Antes de nada, aparte de decir que este será mi primer post aquí, soy principiante en esto de hacer páginas web y aún más en temas de informática, pero estoy aprendiendo WordPress para crearme una página web con wordpress.org.

    Desde hace unas pocas semanas que tengo un problema muy molesto, que hace que no pueda subir fotos desde mi ordenador.

    El mensaje que recibo es el siguiente:

    “El posproceso de la imagen ha fallado probablemente porque el servidor está ocupado o no tiene suficientes recursos. Puede ayudar el subir una imagen más pequeña. El tamaño máximo sugerido es de 2500 píxeles.”

    Hasta entonces estaba subiendo imágenes sin problema con formato JPG de como máximo 1920×1080 píxeles, pero la mayoría son de menos de 1200 de anchura y de menos de 900 de altura y el peso pues alrededor de unos 500 KB, porque la calidad me importa mucho.
    Pensé que el conflicto pudiese ser de algún plugin o del tema que utilizaba, así que los desactive y me pase a un tema estándar de WordPress, el Twenty Twenty-One, pero de nada sirvió, mi problema seguía allí.

    También cambie algunas características de los tamaños de las imágenes en “Ajustes de medios” sin éxito. Las tengo en:

    Tamaño de la miniatura 300×300 px, con la opción de recortar las miniaturas activadas.
    Tamaño medio de 600×600 px.
    Tamaño grande de 1920×1080 px.

    Al final llamé al servicio técnico del hosting que tengo contratado y ellos probaron de subir una imagen y me quedé sorprendida ya que no tuvieron ningún problema. Me fijé en que subieron una imagen muy pequeña de unos 200×200 píxeles, así que yo probé de hacer lo mismo.

    Cree varias imágenes con varias dimensiones, para probar de subirlas y ver qué pasaba.

    100×100 px / 5 KB OK
    200×200 px / 10 KB OK
    400×400 px / 19 KB OK
    600×600 px / 25 KB OK
    900×900 px / 50 KB OK
    1200×1200 px / 58 KB OK
    1400×1400 px / 48 KB KO
    1600×1600 px / 59 KB KO
    1920×1080 px / 87 KB KO

    Parecía que quizás era un problema de las dimensiones de las imágenes, así que intente de subir las imágenes que ya tenía preparadas con dimensiones inferiores a 1200×1200 px y no subió ninguna. No sabia que hacer, luego pruebo otra vez, con más imágenes con algo más de peso y salen estos resultados:

    1200×1200 px / 205 KB KO
    900×900 px / 360 KB KO
    600×600 px / 118 KB KO
    400×400 px / 141 KB KO
    200×200 px / 60 KB OK
    100×100 px / 20 KB OK

    No entiendo nada y pido ayuda a un amigo, trae su ordenador, le paso mis fotos que quería subir a la página más las que había hecho de prueba, con tamaños diferentes y puede subirlas todas sin problemas, desde mi internet.

    Entonces pensé que podría ser un problema de mi navegador, utilizo Chrome, pues nada, lo reinstalo por si hay algo dañado y pruebo otra vez y no funciona. Pruebo con otros navegadores, con Microsoft Edge, Firefox y Opera y sigo sin poder subir las imágenes.

    He pensado que quizás es un problema de puertos, que no sé como va eso, o de mi antivirus, que utilizo Bitdefender, pero no entiendo cómo puede eso influir.

    Luego, he vuelto a de subir imágenes en la primera página que hice, antes de ésta, que está hecha con WordPress.com, porque antes de pasarme a WordPress.org, quería ver si podía entender como hacer una página web y allí sí puedo subir todas las imágenes sin problema.

    Estoy hecha un lio y lo peor es que no puedo trabajar en mi página con mi ordenador.

    ¿Alguna idea de porque pasa esto?

    Gracias

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenida al foro de soporte. El mensaje que muestras

    El posproceso de la imagen ha fallado probablemente porque el servidor está ocupado o no tiene suficientes recursos.

    Indica que el problema está originado en el servidor, no tiene suficientes recursos para procesar las imágenes.

    Te recomiendo procesar tú misma las imágenes para adaptarlas a los tamaños y calidades necesarias, por ejemplo:

    • Sube las imágenes con los tamaños que vas a usar en la web, si el tamaño máximo va a ser 1920×1080, pues súbela en ese tamaño
    • Usa un optimizador para ajustar la resolución usando un programa de edición o una opción online, por ejemplo:

      https://imagecompressor.com/es/
      https://tinypng.com/

    Si las imágenes ya están optimizadas liberas a tu servidor del trabajo de optimizarlas, aparte de que puedes definir exactamente cómo quieres que se visualicen.

    Prueba las opciones que te indico, comenta los resultados que te da y, por favor, recuerda marcar el debate como resuelto cuando así lo consideres, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate irena

    (@irenaheinz)

    Hola Jose Luis y gracias por tu respuesta!

    Sí, con el mensaje de error entendí que podía ser problema del tamaño o el peso de las imágenes.

    Yo parto de fotos que son por lo general de 3000×3000 o 4000×4000 px con varios megas de peso, entre 4 y 10 es normal que tengan, luego, antes de subirlas, les reduzco el tamaño y el peso usando reducirfotos.com o squoosh.app con las características que comento en el primer post.

    No conocía estas opciones online que comentas, te lo agradezco. Las he probado ahora con algunas fotos y, aunque hacen una buena compresión, tampoco he podido subirlas a medios.

    Bueno, cuando vi que probando con otros tamaños tampoco se solucionaba el problema, contacté con el servicio técnico y ellos revisaron la instalación. Me dijeron que ese problema era muy raro y que no era problema del servidor porque la instalación estaba bien y que había espacio.

    No sé qué pensar, quizás el problema puede haber surgido por alguna actualización de Windows 10.

    Moderador Jose Luis

    (@jose64)

    Hola @irenaheinz

    En principio el sistema operativo que estés usando no tiene nada que ver, el problema en todo caso podría ser que tengas alguna limitación de tiempo de procesamiento que interrumpa el procesado de las imágenes, pero si las subes con un tamaño adecuado no debería suceder, por cierto 500 KB en general es demasiado para una imagen de una web, date cuenta de que cuanto más tenga que descargarse más lenta será la presentación de la web.

    Puedes obtener más información usando alguna herramienta de diagnóstico, por ejemplo:

    https://www.webpagetest.org/
    https://tools.pingdom.com/
    https://gtmetrix.com/
    https://pagespeed.web.dev/

    Ahí podrás obtener algún consejo de optimización que te puede ser útil

    Iniciador del debate irena

    (@irenaheinz)

    Hola de nuevo Jose Luis y gracias otra vez!

    Hoy he vuelto a revisar, desde el principio, todo lo que pensaba que podría ser, el tamaño y peso de las imágenes, los plugins, el tema y el antivirus … y al final creo que he encontrado la causa! He quitado la protección de escudo del antivirus y ahora me deja subir las imágenes! Por fin!

    Yo tengo Bitdefender, y éste debía bloquear el acceso al servidor, pero aun no entiendo porque lo hace solo con algunas imágenes, las más grandes en este caso, y en cambio de deja subir las más pequeñas. O bloqueas o no, ¿no? Bien raro.

    Recuerdo que ya había probado de desactivar el programa, pero como no me funcionó creo es probable que desactivase una opción diferente.

    Y si esto antes no me pasaba, me hace pensar que puede ser debido a una actualización del programa, ya que yo no había tocado ninguna opción antes de que me pasase el problema de subir las imágenes.

    Bueno, pues nada, o me busco otro antivirus o me acostumbro a vivir “At risk”, como me dice el programa cuando desactivo la seguridad.

    Ah! y gracias por el consejo con las herramientas de diagnóstico, es muy interesante!

    Por cierto, ya en un tema diferente, me gustaría saber si, tenéis algún foro de ayuda en el que se hable de cómo hacer varias páginas para entradas, es decir, que en cada página salgan las entradas para una categoría diferente, estoy peleándome con esto ahora y necesito algo de ayuda.

    Moderador Jose Luis

    (@jose64)

    Hola @irenaheinz.

    En en foro solo se permite una consulta por debate, esto se hace para mantener el orden ya que las consultas ya que estas sirven de ayuda para otros usuarios. Por favor, plantea la consulta en otro debate nuevo y cualquiera de los voluntarios te lo resolverá.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.