Soporte » Guías – Resolución de problemas » No se abre el menú movil

  • Resuelto medialba

    (@medialba)


    Acabo de instalar el plugin Max mega menu, y todo iba bien hasta que quise probarlo en el móvil, no consigo que se abra. Si desactivo el plugin si que funciona, es decir, el problema lo causa el plugin, pero teniendo un apartado en el mismo para configurar el menú-móvil me extraña… No se si es que he configurado algo mal… Si alguien tiene alguna idea de que puedo hacer… Aún no tengo terminada la página y por eso aun no la he indexado en Google ni nada. Gracias!

    • Este debate fue modificado hace 3 meses, 3 semanas por medialba.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Acabo de hacer la prueba y con la configuración por defecto funciona correctamente en móvil, actualiza Max Mega Menu a su última versión, estás usando una versión obsoleta, y desactiva cualquier plugin de optimización o caché que tengas instalado.

    Quedamos pendientes de los resultados

    Iniciador del debate medialba

    (@medialba)

    Buenas, he comprobado la versión, está actualizado, lo instalé hace poco del directorio de wordpress y he comprobado, es la Versión: 2.9.4, y no me aparece otra más actual… en wordpress.
    He desactivado y vuelto a activar todos los plugins y nada. He probado a cambiar de tema y si me funciona correctamente el menú móvil. Estoy utilizando un tema-hijo del tema Astra. Nose si es que tengo que incluir alguna cosa en mi tema hijo… Desde la documentación del plugin me dicen lo siguiente:
    +Falta wp_footer ()
    Vea la fuente de la página y busque ‘maxmegamenu.js’. Si no lo encuentra, en la mayoría de los casos es porque su archivo de temas footer.php ha sido editado manualmente. Asegúrese de que el archivo footer.php de su tema tenga una llamada a wp_footer () justo antes de la etiqueta de cierre </body>.

    +Errores de JavaScript
    Los errores de JavaScript impedirán que el menú móvil funcione correctamente. Consulte nuestra guía sobre cómo encontrar y corregir errores de JavaScript en su tema.

    Al abrir la consola tampoco me aparecen errores… y en mi tema padre si está la funcion wp_footer(), en mi tema hijo no tengo footer.php… ¿puede ser por esto último? o coge la funcion del padre y debería de ir…?

    Moderador Jose Luis

    (@jose64)

    Hola.

    La versión 2.9.4 del plugin indica en su archivo readme.txt que es la 2.9.3, por eso te decía que no estaba actualizada.

    Con respecto a tu tema hijo, no tienes que incluir nada, los archivos están en el padre. Tampoco veo errores en el inspector, por lo que no te puedo comentar nada más, es posible que sea algún problema con la configuración de los menús en Astra, como te indiqué antes, usando la configuración por defecto a mi me funciona correctamente.

    Iniciador del debate medialba

    (@medialba)

    Vale, voy a revisar el readme.txt o a ver si toquiteando el menú consigo algo… Gracias!

    Moderador Jose Luis

    (@jose64)

    En el archivo readme.txt no vas a encontrar nada, me refiero a que el autor no modificó el número de versión cuando hizo la actualización, prueba cambiando el tema por uno de los que te instala WordPress por defecto (uno de los Twenty) y ahí verás si se trata de algún problema de configuración con Astra

    Iniciador del debate medialba

    (@medialba)

    Vale vale, tienes razón ahora que lo pienso XD no se debe de ser el tema de Astra, porque si cambio de tema va bien… Pero no se si puedo solucionarlo, ¿tal vez tenga que cambiar de tema o plugin?

    Moderador Jose Luis

    (@jose64)

    Hola.

    Yo lo probé con Astra y funciona bien, debe ser alguna configuración de Astra que entra en conflicto. Si modificando la configuración no lo solucionas yo probaría cambiando el plugin por otro.

    Iniciador del debate medialba

    (@medialba)

    Después de darle muchas vueltas lo logré. Desde personalizar, en la sección de el menú (vista móvil) había una opción predeterminada, la quite y puse un menú secundario en su lugar y ya funciona correctamente. Cierro el debate, gracias!

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.