Soporte » Guías – Resolución de problemas » No se envían e-mails

  • Resuelto nidittopiu

    (@nidittopiu)


    Buenas, primero de todo agradecer de corazón a la persona que tome su tiempo en responder.

    Desde siempre que WordPress enviaba automáticamente (sin yo haber configurado nada explícitamente) los e-mails. Ya fuera algo relacionado con WooComerce, con ContactForm7, o las notificaciones cuando alguien deja un cometario para aprobarlo o no… Pero hará cosa de un mes (o menos) que ha dejado de enviar mails, ninguno, de ningun tipo.

    He probado todas las soluciones que he encontrado en este y en otros foros:
    – He contactado con mi hosting, y después de hacer pruebas con las DNS, con la sobrecarga del servidor, incluso crear un .php que sí enviava un mail de prueba de prueba; han concluido que el problema no es suyo.
    – He cambiado el «theme» de la web, y el problema persiste.
    – He desinstalado todos los pluggins y nada.
    – Incluso he reinstalado varias veces la última versión de Worpress (ya que hace no mucho tuve otro problema que se solució así).
    – He instalado un plugin para enviar los mails a través de otra SMTP, y aunque el mail de prueba marca como enviado correctamente, no llega nada.
    – Por supuesto he mirado en spam y no llegan allí.

    Sinceramente estoy desesperada, no se me ocurre cual puede ser el problema ni que más probar… Tengo la sensación de que es algo del propio WordPress… así que quizás con la siguiente versión se arregle «solo». Pero hasta entonces no se como «parchearlo».

    Muchísimas gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 16 a la 22 (de un total de 22)
  • buenas
    si no leo mal estás enviando desde
    CLIENT -> SERVER: MAIL FROM:<hola@nidittopiu.com>
    a una cuenta en gmail
    CLIENT -> SERVER: RCPT TO:<mimail@gmail.com>

    recientemente he tenido problemas parecidos a los que describes,
    en mi caso
    enviaba desde un mail yo@miweb.com que tengo redirigido a gmail (gmail account)
    a una cuenta persona@gmail.com

    el problema estaba del lado del servidor diría que tenía relación con los registros dns de seguridad dkim, spf y dmarc (si no sabes lo mejor es que contactes con el servidor sobre este tema)

    En mi caso incluso haciendo cambios no fue suficiente así que opté por configurar
    https://es.wordpress.org/plugins/wp-mail-smtp/
    para que enviara por una de las plataformas de terceros (en mi caso sendinblue)

    un saludo

    Iniciador del debate nidittopiu

    (@nidittopiu)

    @oldlastman mil gracias por tu ayuda.

    He probado lo que comentas de los registros dns de seguridad dkim, spf y dmarc, pero mi hosting tampoco pudo ayudar.

    Así que he instalado el pluggin y elegido la misma plataforma que tu, pero el mail de prueba no sale… da error. No se si es que tengo algo mal configurado… Pero he seguido todos los pasos que indican para configurar Sendinblue y ya me han verificado y todo…

    Te comento la configuración del pluggin, a ver si estoy haciendo algo mal:

    Clave de licencia = nada, entiendo que estoy utilizando la versión lite, la que se ha descargado cuando he puesto el nombre del plugin en el buscador de wordpress.

    Correo electrónico remitente = hola@nidittopiu.com

    Forzar remitente del mensaje = Activado

    Nombre remitente = Niditto.Piu

    Forzar el nombre del remitente = desactivado

    Servicio de correo electrónico = Sendinblue

    Clave de la API = la que aparece en mi configuracion de Sendinblue

    Dominio de envío = nidittopiu.com

    Puede tener algo que ver que lo haya hecho directamente con el dominio y no con un subdominio ??

    Gracias.

    Iniciador del debate nidittopiu

    (@nidittopiu)

    @oldlastman
    Por cierto, el registro de errores marca:

    Versions:
    WordPress: 5.7
    WordPress MS: No
    PHP: 7.4.11
    WP Mail SMTP: 2.6.0
    
    Params:
    Mailer: sendinblue
    Constants: No
    API Key: Yes

    Buenas,

    la única configuración obligatoria sería la clave de api (si ya has confirmado que está bien..es el único punto de duda)
    yo por ejemplo tampoco le indiqué dominio de envío, ya que es una configuración avanzada en sendinblue que debe estar relacionada con tus dns (si no lo has hecho de esa forma, tal vez lo mejor sería quitarlo)
    respecto a forzar remitente pues tampoco lo uso ya que dejo que sea el formulario el que ponga lo que necesita.

    si estas usando la opción que trae el plugin wp-mail-smtp para enviar la prueba, muy posiblemente también te de algo de información sobre los registros que mencioné antes (dkim, spf y dmarc) al darte el error para mi dkim y spf no están ok pero dmarc sí , aunque el mail que me llega de prueba da aviso de intento de suplantación de identidad (se debe a no configurar el dominio ni las dns)

    Leyendo lo que indicas no se ve nada mal..pero los detalles suele ser donde estas cosas fallan (como he mencionado prueba dejando sólamente el clave de api, revisado, y no obligues )

    Si después de esta prueba no funciona, lo siento pero al igual que otros compañeros/as del foro, llegados a este punto necesitas a un/a profesional que mire exactamente como lo tienes configurado y averigüe porqué no sale el mail de prueba

    un saludo

    Iniciador del debate nidittopiu

    (@nidittopiu)

    Nada @oldlastman , dejo solo la clave API y salta el mismo error…

    Estoy ya en busqueda de un profesional que se lo mire, pero se deben esconder bajo las piedras… porque no hay manera de encontrar a nadie que sepa solucionarlo.

    Gracias de nuevo.

    Hola @nidittopiu

    Pudiste encontrar solución al problema? he leido todo los comentarios y estoy teniendo este mismo problema.

    Me sería de mucha ayuda tu respuesta.

    Gracias

    • Esta respuesta fue modificada hace 5 días, 6 horas por jorgesanabria.
    Iniciador del debate nidittopiu

    (@nidittopiu)

    Hola @jorgesanabria, finalmente compré la versión pro del pluing «WP Mail SMTP» para que me lo mirasen ellos, y encontraron lo siguiente:

    Upon investigating your issue further, I found that your hosting provider has disabled your wp_mail() function on your site by adding the following line into your wp-config.php file, so that’s why you cannot send emails.
    I have enabled it again for you by disabling that function.

    Ns si te será de ayuda, porque me enviaron fotos que no puedo adjunarte, pero sin duda fueron los 50€ más bien invetidos del año.

Viendo 7 respuestas - de la 16 a la 22 (de un total de 22)
  • Debes estar registrado para responder a este debate.