Soporte » WordPress Avanzado » No se muestran mis categorías provenientes de custom posts

  • Hola comunidad, tengo una duda:

    Hice un custom post que funciona bastante bien, pero al momento de entrar a las categorías de esas publicaciones la pagina de categorías aparece vacía, es decir, no muestra las publicaciones dentro de «esa» categoría.

    A modo de pruebas he usado este loop en una pagina de categoría personalizada:

    <?php $loop = new WP_Query( array( 
    'category_name' => 'magias', 
    'posts_per_page' => 300 ) ); 
    while ( $loop->have_posts() ) : $loop->the_post(); ?>
    ...
    <?php  endwhile; ?>

    Lo curioso es que con la categoría ‘cipsoft’ funciona correctamente, se muestran las 7 publicaciones que hay en esa categoría, pero cuando cambio a la categoría ‘magias’ simplemente no aparece nada, es como si de alguna manera las publicaciones «no se registraron» en dicha categoría (aún cuando hay varias publicaciones en esa categoría). Lo mismo ocurre con otras categorías provenientes de custom posts que tuve que crear.

    Dato curioso:

    Para el custom post he usado ACF y CPT. Dentro de las publicaciones de este custom post estoy usando la categoría ‘magias’ y he registrado 2 entradas correctamente (estoy mostrando esas publicaciones en otra página inclusive) pero al momento de entrar a sus categorías simplemente no muestra ninguna publicación.

    Caso contrario ocurre con el campo de entradas que viene por defecto en WordPress, en el cual agrego publicaciones y les añado la categoría ‘cipsoft’, que a su vez abre perfectamente mostrando las 7 publicaciones registradas en esa categoría.

    Esto me hace pensar que el problema está relacionado de alguna manera con CPT UI y ACF y algún tema con las categorías que no configuré adecuadamente o algo por el estilo.

    • Este debate fue modificado hace 1 mes, 3 semanas por nickcamastra.
Viendo 1 respuesta (de un total de 1)
Viendo 1 respuesta (de un total de 1)
  • Debes estar registrado para responder a este debate.