Soporte » WordPress Avanzado » No se puede cambiar entre Visual/HTML y editor se congela

  • Resuelto Manstrak

    (@manstrak)


    Hola a todos:
    Acudo a ustedes porque ya agoté todas las opciones que habia visto en internet y diversos foros:
    Cuando intento editar o crear una nueva entrada, al hacer click en solapa HTML el sistema no hace el cambio. Luego descubrí que cuando estoy en visual, boton de hipervínculo hace que la página no funcione correctamente (les dejo un video de la situación).
    https://youtu.be/Udhax9Uv46Q

    Ya probé los pasos clásicos:
    *Desactivé todos los plugins, borré caché, probé y no se arregló.
    *Probé cambiando de theme al que viene por default con wordpress, no se arregló.
    *Tengo un tema Child, dejé vacío el archivo functions.php, no se arregló.
    *Reinstalé los archivos de mi sitio con archivos originales desde una descarga limpia: reemplacé post.php y new-post.php con archivos originales, no se arregló.
    *Hice lo mismo pero con los archivos en js/tynimice, no se arregló.
    Probé con lo que decían estos temas:
    1.- https://wordpress.org/support/topic/page-editor-stucks-in-text-modevisual-mode/ [agregar define('SCRIPT_DEBUG', true); en config.php], no se arregló.
    2.- https://wordpress.org/support/topic/visual-editor-tab-not-working-5/ [agregar define('CONCATENATE_SCRIPTS', false); en config.php], no se arregló. No había archivo .htaccess en wp-includes por lo que no probé esa opción.

    Lo curioso: El problema solo ocurre cuando quiero agregar una nueva entrada. El editor funciona bien cuando quiero agregar texto para una página nueva.

    Honestamente ya no sé que más hacer.
    ¿Me pueden ayudar? ¿Qué otra información necesitan? Gracias

    • Este debate fue modificado hace 4 años, 11 meses por Manstrak. Razón: Mejor redacción para mejor lectura
Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Iniciador del debate Manstrak

    (@manstrak)

    No pude editar a tiempo un dato que acabo de observar:
    Si cambio el modo de escritura entre HTML y Visual en «crear página», el sistema recuerda mi elección al momento de crear una nueva entrada. Cuando la opción queda en visual, puedo utilizar a mayoría de las cajas, pero si queda en HTML no se puede lograr. Nuevamente les dejo un video que lo explica mejor.
    https://youtu.be/B5Ns3G_aPU8
    Gracias!

    Moderador LGrusin

    (@lgrusin)

    Yo te aconsejaría que hicieras una instalación limpia. Elimina todos los restos de WordPress anterior.

    Lo más fácil es descomprimir el zip de WordPress en tu PC. De ahí eliminas la carpeta wp-content y el archivo wp-config-sample.php. El resto lo subes al servidor habiendo borrado previamente lo que tenías. Sólo deja la carpeta wp-content y el archivo wp-config.php viejos.

    De todas formas aquí tienes una guía para hacerlo de la forma más rápida posible:

    Actualizar WordPress por FTP en segundos

    Un saludo

    • Esta respuesta fue modificada hace 4 años, 11 meses por LGrusin.
    • Esta respuesta fue modificada hace 4 años, 11 meses por LGrusin.
    Iniciador del debate Manstrak

    (@manstrak)

    Hola:
    Realicé lo soliticado.
    No se arregló el problema.

    En los foros en inglés me dijeron que buscara el problema con mi navegador para saber que parte del javascript me estaba fallando (porque obviamente ya traté con 3 navegadores diferentes), pero por lo que estoy leyendo se necesita harto conocimiento para reparar el error manualmente, ya que no sé nada de java.

    ¿Qué más podría ser?

    Iniciador del debate Manstrak

    (@manstrak)

    Hola:
    Seguí las instrucciones del tutorial: https://codex.wordpress.org/Debugging_in_WordPress#SCRIPT_DEBUG

    En el pase dos hay que poner la siguiente línea de comando en config.php define('SCRIPT_DEBUG', true);

    Al hacerlo el problema se solucionó, por lo que lo apagué ( define('SCRIPT_DEBUG',false); ) y puedo utilizar correctamente el editor desde el navegador en pestaña privada y desde otro navegador diferente al que utilizo regularmente, porque este último, mientras el debug está en true funciona muy bien y en false no.

    Por lo pronto el problema se resolvió. Esperaré algunas horas para utilizar bien el sitio y si no vuelve a haber problemas, pondré el tema como resuelto 🙂

    Iniciador del debate Manstrak

    (@manstrak)

    Bueno, han pasado 7 horas. Quizás mozilla está con problemas. Puedo utilizar bien el sitio en chrome y mozilla sesión privada, así que utilizaré esos navegadores. Antes ninguno me funcionó.

    Declaro esto un misterio de la humanidad jaja

    Gracias y ojalá este tema sirva a otros.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • El debate ‘No se puede cambiar entre Visual/HTML y editor se congela’ está cerrado a nuevas respuestas.