Soporte » Guías – Resolución de problemas » no se puede seleccionar la base de datos

  • Resuelto cexfox

    (@cexfox)


    Saludos.
    Estoy intentando instalar wordpress em localhost.
    lo que hago es:
    1. descargo la version 5.4.2-es del sitio wordpress.org
    2. decomprimo wordpress en www de WAMP y lo renombro como «mi-sitio»
    2. como ya tengo wamp, lo ejecuto y selecciono phpmyadmin
    4. creo la base de datos con el nombre «mi-sitio»
    5. voy http://localhost/mi-sitio
    6.sale la pantalla de bienvenida, donde aparece que debo saber nombre de la bd, usuario de la bd, contraseña y servidor de la bd
    7. escribo «mi-sitio» como nombre de la bd
    8. escribo «root» como usuario y pass en blanco (como viene por defecto mysql)
    9. dejo los ultimos dos espcios como se muestran (localhost,etc)-

    Al hacer clic en el boton enviar, me aparece un mensaje que dice «no se puede seleccionar la base de datos»
    alli se acalara que el usuario y clave son correctos, pero no ha sido ppsible seleccionar la bd «mi-sitio»

Viendo 11 respuestas - de la 1 a la 11 (de un total de 11)
  • Moderador almendron

    (@almendron)

    Una pregunta. Cuando dices en el punto 2 que renombras, ¿a qué carpetas te refieres? ¿has renombrado la carpeta «www»?

    • Esta respuesta fue modificada hace 1 mes por almendron.
    cexfox

    (@cexfox)

    Hola.
    Al decir que renombro, me refiero a la carpeta wordpress, la renombro con el nombre del proyecto y elegi el nombre «mi-proyecto»

    Moderador almendron

    (@almendron)

    Lo primero de todo vamos a comprobar que dispones de todas las librerías necesarias:

    1) http://wampserver.aviatechno.net/?lang=en

    2) Sección TOOLS y descargas «Checks VC++ packages»

    3) Comprueba y en su caso instala las librerías que te falten.

    cexfox

    (@cexfox)

    Hola.

    2 Cosas:

    1. Efectivamente, faltaban unas librerias de vc
    2. Sigue botando el mismo error

    Moderador almendron

    (@almendron)

    Dado que haces referencia a «mi-proyecto» y a «mi-sitio», ¿has comprobado cuál es el nombre de la base de datos?

    cexfox

    (@cexfox)

    He vuelto a hacer el proceso desde el principio no se cuantas veces, he buscado tutoriales y he buscado en internet con el titulo del error.
    No se que puede estar pasando, ademas, hoy me sucedio que intente con una version anterior de wordpress, la 4.5.22 y me salio una ventana con los siguientes errores
    arning: Use of undefined constant DB_HOST – assumed ‘DB_HOST’ (this will throw an Error in a future version of PHP) in C:\wamp64\www\mi-sitio\wp-includes\load.php on line 371

    require( ‘C:\wamp64\www\mi-sitio \wp-settings.php’ ) setup-config.php:33

    require_wp_db( ) …\wp-settings.php:88

    Warning: Cannot modify header information – headers already sent by (output started at C:\wamp64\www\mi-sitio\wp-includes\load.php:371) in C:\wamp64\www\mi-sitio\wp-admin\setup-config.php on line 90

    setup_config_display_header( ) …\setup-config.php:116
    3 5.1895 2913184 header ( ) …\setup-config.php:90

    Sin embargo, a pesar de estos warnings, me muestra la pantalla de configuracion de wordpress (la que empieza por elegir el idioma)

    Sin embargo, con la version 5.4.3-es, me sale el error de la conexion con la b.d.

    Em ambos casos, el proceso es el mismo:

    Pongo la carpeta de wordpres en c:/wamp64/www
    la renombro, creo la b.d con el mismo nombre que use al renombrar y voy a localhost/mi-sitio (que es el nombre de la carpeta del wp y tambien el de la b.d)

    Moderador almendron

    (@almendron)

    1) ¿Qué sistema operativo tienes instalado en el ordenador?

    2) ¿Utilizas algún programa que use el puerto 80? ¿skype, por ejemplo?

    3) ¿Has comprobado que tienes todos los servicios de wampserver activos?

    4) Prueba en el paso 5 a teclear http://localhost/mi-sitio/wp-admin/install.php

    cexfox

    (@cexfox)

    Tengo w10.
    Solamente apache esta escuchando por el puerto 80
    Como se si tengo todos los servicios de wampserver activos ? el icono esta verde
    CUando tratao de ir al paso 4. me sale lo siguiente:

    Vaya… no se puede acceder a esta páginalocalhost rechazó la conexión.
    Busca localhost en Bing
    ERR_CONNECTION_REFUSED

    Moderador almendron

    (@almendron)

    Prueba a desactivar el servidor IIS de Windows que normalmente viene activado por defecto y da problemas con WampServer.

    Pulsa la tecla con el símbolo de Windows + X, y vete hasta “Administración de equipos”. En el desplegable de la izquierda verás la opción “Servicios y aplicaciones”: Pulsa sobre ella y haz doble clic sobre “Servicios” para que se cargue el listado de servicios.

    Busca el «Servicio de publicación World Wide Web»: Si aparece en «En ejecución» y con el «Tipo de inicio» como «Automático», detén el servicio y luego doble clic sobre él para ponerle el tipo de inicio en «Manual».

    Reinicia el equipo para asegurarte que los cambios se aplican.

    • Esta respuesta fue modificada hace 1 mes por almendron.
    cexfox

    (@cexfox)

    Hola.
    Hice la revision, del IIS, pero en servicios solo aparece «servicio de publicacion de nombres de equipo»
    Asi que supongo el IIS esta sdesactivado.
    De hecho, pensando que era un error, y que el w10 tenia algunas fallas, decidi reinstalar desde cero, con la herramienta «creacion de medios». Sin mebargo, sigo con el mismo problema

    cexfox

    (@cexfox)

    Hola.
    Ya lo resolvi.
    Simplemente cambie el gestor de B.D. y elegi «mariadb» en vez de «mysql»

Viendo 11 respuestas - de la 1 a la 11 (de un total de 11)
  • Debes estar registrado para responder a este debate.