• Hola.

    He tenido problemas para que se vean reflejadas mis actualizaciones de las entradas en la ventana principal de mi página web.

    Al principio me decía que había un problema con el caché. Busqué soluciones en el foro y me encontré que solo con vaciar la caché de las entradas se empezarían a ver mis actualizaciones. Había algunos otros que decían que debía modificar la cantidad de entradas visibles en la página, o que revisara que el nombre del URL no estuviera duplicado con otro (que no fue el caso) o que la fecha de publicación no estuviera incorrecta (tampoco fue el caso).

    Borré la caché incluso de toda la página.

    También probé con desinstalar y volver a instalar los pluggins para ver si alguno me daba algún error (nada pasó).

    Cambié de pluggin de caché de WP Fastest Cache por LiteSpeed Cache que parecía ofrecer más opciones detalladas de limpieza y control de caché.

    Tengo dos sitios exactamente iguales, la versión español y la versión inglés y este problema solo afecta a la versión español, la versión inglés está funcionando correctamente.

    No sé que otra cosa más hacer para que las actualizaciones de entradas de mi sitio vuelvan a aparecer correctamente en el inicio; ojalá alguien pueda ayudarme. Gracias.

    • Este debate fue modificado hace 7 meses, 3 semanas por Canromex.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 27)
  • Hola, @canromex01:

    No me quedó claro si al desactivar el plugin de caché las entradas se actualizaron. ¿Probaste a actualizar una entrada, teniendo el plugin de caché desactivado (¡deberías tener uno solo!) y ver si los cambios se reflejan en la vista pública?

    Iniciador del debate Canromex

    (@canromex01)

    Si intenté desactivando el plugin y publicando una nueva entrada pero no se refleja, tanto con el primer plugin que tenía como con el segundo (activo y desactivo, incluso desisntalado) llevo 2 semanas intentando varias cosas y sin resultados favorables.

    Si tengo solo un plugin de caché, cambié WP Fastest Cache por LiteSpeed Cache.

    Los revisé en vista pública desde otro dispositivo en cada intento.

    ¿Podrías indicarme cómo estás manejando ambas versiones del sitio?

    ¿Estás usando un plugin multilingüe o es una red multisitios?

    Iniciador del debate Canromex

    (@canromex01)

    Son páginas independientes, tienen el mismo contenido en cuanto a información del sitio en general, solo que en diferente idioma. Cualquier cambio que realice en el sitio en español, debo cambiarlo manualmente en la versión inglés.

    Lo único diferente son las entradas, a cada página le coloco semanalmente una entrada diferente, pero en la versión inglés si se reflejan las actualizaciones, no he tenido problemas ahí.

    Moderador almendron

    (@almendron)

    A ver si lo entiendo: ¿tienes dos WordPress en sendos subdirectorios? Si no es así, a ver si puedes explicar un poco más como lo tienes montado.

    Iniciador del debate Canromex

    (@canromex01)

    La versión inglés es un ejemplo de comparativa, no es importante. Soy trabajador de una empresa, no sé quién antes que yo haya diseñado la o las páginas de la empresa, no sé como funcionan (enlazadas, o no, lo desconozco).

    Solo requiero ayuda para resolver el problema de las entradas que no se ven en la página de inicio. Es todo.

    • Esta respuesta fue modificada hace 7 meses, 2 semanas por Canromex.
    Moderador almendron

    (@almendron)

    No podremos ayudarte a resolver el problema si no nos explicas como funciona el sitio.

    Para saber si son dos WP o uno basta con que mires en Ajustes > Generales y nos digas lo que pone en Dirección de WordPress (URL) y Dirección del sitio (URL).

    Luego, echa un vistazo al archivo wp-config.php y mira lo que aparece en DB_NAME y $table_prefix. No pongas aquí los datos. Solo dinos si son iguales o distintos.

    Por último, cuando accedes a https://www.canromex.com/es/wp-login.php: ¿tienes todas las entradas o solo las de español?

    Iniciador del debate Canromex

    (@canromex01)

    Son distintos.

    Aunque la URL es muy parecida, la diferencia está en la terminación «/es» y «/en»

    Cuando accedo solo tengo las entradas en español.

    Moderador almendron

    (@almendron)

    En estos momentos, compruebo que la página principal del sitio en español presenta problemas. No así la de inglés.

    Si no estoy equivocado, no hay activo un plugin de cache en la página en inglés. En la de español sí está activado LiteSpeed.

    Por tanto, lo primero de todo sería desactivar dicho plugin en la página en español.

    Iniciador del debate Canromex

    (@canromex01)

    En la página en español, también ya intenté publicar entradas sin un pluggins de caché (ya lo había mencionado con anterioridad)

    En la página de inglés se utiliza el WP Fastest Caché, que es el mismo que tenía la versión en español al inicio, el cual cambié porque me botaba mucho errores; no podía realizar modificaciones al caché por falta es espacio del caché y tampoco me dejaba borrar el caché por el mismo problema disque de espacio de caché, no tenía mucho sentido.

    Moderador almendron

    (@almendron)

    Sitio en inglés: comprueba si está activado el plugin de cache porque no lo detecto.

    Sitio en español: desactiva el plugin de cache para poder ver mejor el código fuente.

    Y tres: dime la URL de una de las entradas en español que no aparece en la página principal.

    Iniciador del debate Canromex

    (@canromex01)

    Sitio en inglés: Si está activado el plugin de caché.

    Sitio en español: Listo, ya quedó desactivado el plugin de caché.

    URL de una entrada no visible: https://www.canromex.com/es/index.php/2023/11/06/se-aproxima-el-frente-frio-numero-9-azotara-con-fuertes-lluvias-temperaturas-de-5-y-tornados/

    Moderador almendron

    (@almendron)

    Inglés: puede que esté activado el plugin, pero creo que todas sus opciones están desactivadas.

    Español: al desactivar el plugin, la página principal ya se ve bien. Es muy probable que el caché propiamente dicho no afectara pero es evidente que algún otro ajuste hacía que la página no se viera bien.

    Ahora deberías editar la página principal y comprobar sus ajustes. La idea es ver cómo está hecho el slider de las noticias y comprobar sus ajustes.

    Una pregunta: ¿todas las entradas que no se ven tienen asignada la categoría «uncategorized». Prueba a quitarles esa categoría.

    Iniciador del debate Canromex

    (@canromex01)

    Inglés: Ya lo revisé, el plugin dice que sí está activo, incluso lo desactivé y lo volví a activar, revisando que en sus opciones esté marcada la casilla de «activar».

    Español: Sí, de hecho si se buscan las entradas si aparece como si estuvieran dadas de alta, pero en la sección de noticias no se ven.

    También revisé que «quizás» no se veía porque tenía algún límite de entradas que se pueden visualizar, pero no fue el caso. Tenía activo que solo se vieran las 6 últimas, cuando ocurrió ese error, le subí como a 30, y se veían las más antiguas (ni siquiera alcanzaba a llevar 30 noticias, tenía como 26 en ese momento que empezó el fallo) y aún así no se veía la más reciente. Lo volví a bajar, dejando visible las primeras 9 entradas.

    Respuesta a la pregunta: Solamente una de las entradas recientes tenía activada esa categoría, ya se la quité y sigue sin verse. El resto no tenía activado «uncategorized».

    Moderador almendron

    (@almendron)

    El siguiente paso ahora es ir a Apariencia > Personalizar y comprobar que los ajustes en relación a la página principal son los mismos en español que en inglés.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 27)
  • El debate ‘No se reflejan mis actualizaciones de entradas en la página de inicio’ está cerrado a nuevas respuestas.