Soporte » Guías – Resolución de problemas » No se ven las imagenes en el index – home-

  • lestraw

    (@lestraw)


    En primer lugar eh mudado mis archivos y base de datos de mi blog a otro servidor.

    En este servidor al llegar, wordprees entrego otra upgrade «el 3.3.1» y desde entonces cada vez que publico una nueva noticia, las fotos no se ven en la pagina principal pero si dentro de la publicación.

    pueden visualizar en http://www.mundofull.com/

    Eh buscado en todo el foro la solución y no la encuentro

    Que debo hacer?

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador erchache2000

    (@erchache2000)

    ¿En el nuevo servidor tienes imagemagick?

    Es la librería linux para realizar miniaturas…

    Eso, o que algún plugin/tema casca…

    Iniciador del debate lestraw

    (@lestraw)

    Le instale imagemagick, visite el folder de las imágenes y wordpress esta creando las fotos miniaturas tamaño 150×150… Pero aun así no las publica en la pagina principal

    puede visualizar en http://www.mundofull.com/

    Rocio Valdivia

    (@_dorsvenabili)

    Hola lestraw,

    el problema es que en: /wp-content/themes/comfy-plus/scripts/phpThumb/phpThumb.php en la línea 152 se llama a la función eregi() y esta función ha sido declarada obsoleta desde PHP 5.3.0.

    Así que te recomendaría que si sabes un poco de php, sustituyeras en el index.php las llamadas a esas miniaturas y lo sustituyeras por:

    if(has_post_thumbnail()){
       the_post_thumbnail(array(150,150));
    }

    Y así podrás usar las imágenes destacadas para cada entrada.

    Iniciador del debate lestraw

    (@lestraw)

    Hola _dorsvenabili

    En cual index.php, el de la ruta «/wp-content/themes/comfy-plus/scripts/phpThumb/»

    O esta en otra ruta?

    En caso de ser esa ruta, aquí tienes una copia del código

    <?php
    if (!file_exists('phpThumb.config.php')) {
    	if (file_exists('phpThumb.config.php.default')) {
    		echo 'WARNING! "phpThumb.config.php.default" MUST be renamed to "phpThumb.config.php"';
    	} else {
    		echo 'WARNING! "phpThumb.config.php" should exist but does not';
    	}
    	exit;
    }
    header('Location: ./demo/');
    ?>

    Hola amigos: Yo tengo el mismo problema. Estoy usando el wordpress 3.4.1 con el tema StudioBlue y no consigo que aparezcan las miniaturas en la página principal (bloques de últimas noticias) ni en las noticias cuando pinchas en las categorías.

    He buscado y rebuscado y no encuentro la solución. Os ruego una ayuda. Muchas gracias.

    me pasa lo mismo, cambie de servidor y subi los archivos por ftp, cambie los datos en la base de datos y el sitio se muestra completo, lo unico es que no esta reconociendo las imagenes, no muestra ninguna ni en las páginas, post, multimedia, ni en la administración en general, alguna solución? lestraw como solucionaste en tu página http://www.mundofull.com/
    la mia es gerenciaparatodos.com

    fonko

    (@fonko)

    A lo que nuestra experta se refiere es a que en «home.php» en tu theme editor, saques el codigo del thumb:
    `<div class=»thumbnail-div»>
    <?php // if there’s a thumbnail
    if ($thumb !== ») {
    ?>
    <a href=»<?php the_permalink() ?>» title=»Permanent Link to <?php the_title(); ?>»><img src=»<?php bloginfo(‘stylesheet_directory’); ?>/phpThumb/phpThumb.php?src=<?php echo $thumb; ?>&h=90&w=90&zc=1″ alt=»<?php if ($thumb_alt !== ») {
    echo $thumb_alt;
    } else {
    echo the_title();
    } ?>» style=»border: none;» /></a>
    <?php
    } // end if statement
    // if there’s not a thumbnail
    else {
    echo »;
    }
    ?>
    <!–End display thumbnail if found–>
    </div>`

    por le que ella a comentado, luego si quieres puedes agregar en functions.php del theme (theme functions):

    add_theme_support( 'post-thumbnails' );
    
    set_post_thumbnail_size( 90, 90 );

    y para terminar en style.php cambias el height (si tus imagenes no son cuadradas) o agregas

    add_image_size( 'nombreCualquiera', 90, 90, true );

    en lugar de set post thumbnail size ()

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘No se ven las imagenes en el index – home-’ está cerrado a nuevas respuestas.