Soporte » Plugins y Hacks » No se visualiza mapa OpenLayers – MapBlock

  • Buenas tardes.
    Instalé el plugin Map Block y generé un mapa con una polilínea.
    Cuando estoy logueado visualizo el mapa correctamente cargado en el sitio, pero cuando visualizo el sitio deslogueado sale vacío como podrán observar si entran.

    Sabrán a qué se deberá y cómo podría solucionarlo?

    Desde ya muchas gracias por la ayuda.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 11 respuestas - 1 de 11 (de 11 total)
  • Hola @joaquinprestamo
    Por lo que parece, tienes errores de javascript, del theme que usas y del plugin
    google-analytics-dashboard-for-wp que sino me equivoco evita que se carge el mapa.

    Lo puedes comprobar mirandolo en la consola del navegador.

    Moderador almendron

    (@almendron)

    De momento, añade esto a tu archivo .htaccess:

    Header set Content-Security-Policy "upgrade-insecure-requests"

    1) haz primero una copia de dicho archivo.

    2) Es un archivo oculto. Por defecto, los clientes de FTP o el explorador de tu panel de control en el hosting tal vez no lo muestre.

    Muchas gracias por las respuestas.
    Realizo lo que me acotan y comento lo que sucedió en la web.

    Moderador almendron

    (@almendron)

    Te he dicho que hagas eso porque he visto en la consola que hay varios bloqueos por servir contenido con http. No se si eso es lo que afecta a los mapas pero, en cualquier caso, conviene solucionarlo.

    Pregunta: ¿qué plugin usas exactamente? Indica la URL de dicho plugin para echarle un vistazo.

    Moderador almendron

    (@almendron)

    Me olvida: la línea a añadir deber ir al principio del htaccess

    Ya agregué lo que me comentaste y sigue sin aparecer.
    En mi htaccess tengo este código. Puede que interfiera?

    <IfModule mime_module>
      AddHandler application/x-httpd-ea-php56 .php .php5 .phtml
    </IfModule>

    https://mapblock.io/ Ese es el plugin

    Moderador almendron

    (@almendron)

    1) ¿Tienes el código añadido ahora? Es que me siguen saliendo los mismo errores (Se ha bloqueado la carga del contenido activo mixto…)

    2) En la consola también aparecen errores relacionados con el tema y con el plugin «Google Analytics Dashboard for WP by ExactMetrics (formerly GADWP)»

    3) El plugin que usas no lo encuentro en el almacén de WordPress. Prueba https://es.wordpress.org/plugins/map-block-gutenberg/

    En resumen:
    1) Desaconsejable usar el plugin de mapas
    2) El tema que usas necesita ser actualizado.

    Moderador almendron

    (@almendron)

    En cuanto al código que aparece en tu htaccess es para indicar con qué versión de PHP quieres trabajar.

    Según veo, tienes instalada la 5.6.
    Es una versión muy antigua. Deberías actualizar a la 7.2 o 7.3
    Es sí, deberás comprobar antes que tanto el tema como los plugins son compatibles con dicha versión.

    Buenos días.

    Realicé una theme nueva con base a Twenty Sixteen. Revisé la versión php y es 7.2.
    Aún no se muestra el plugin Map Block.
    Lo que sigo sin comprender es porqué cuando estoy logueado como administrador y previsualizo la página se ven perfecto estas pantallas.

    Corrí el plugin PHP Compatibility Checker y Map Block salió como compatible con la versión de PHP.

    Si alguien entiende cuál es el inconveniente se lo agradecería.

    Moderador almendron

    (@almendron)

    1) Me decías que en htaccess tenías puesto:

    <IfModule mime_module>
      AddHandler application/x-httpd-ea-php56 .php .php5 .phtml
    </IfModule>

    ¿Lo has eliminado? Si no es así, hazlo (haz primero una copia del archivo)

    2) Con el bloc de notas crea un archivo que deberás guardar como info.php
    En él pones:

    <?php
    echo phpinfo();
    ?>

    Después lo subes al directorio raíz de tu servidor.
    Eso te servirá para ver detalles de tu servidor, incluida la versión de PHP que estás usando. Basta con poner:
    https://www.crusa.com.ar/info.php

    2) ¿Has probado el otro plugin que te comenté? https://es.wordpress.org/plugins/map-block-gutenberg/

    3) Usas algún plugin de seguridad?

Viendo 11 respuestas - 1 de 11 (de 11 total)
  • Debes estar registrado para responder a este tema.