Soporte » Diseño – Temas y plantillas » No soporta PHP 7.*

  • Hugo1966

    (@corysan10)


    Saludos, mi tema Avenue de Fabthemes.com Version:1.2 que instale hace unos 8 años ya no soporta la versión de PHP 7.* (y la empresa Fabthemes no tiene actualización) el server (1and1) me está cobrando por mantener el soporte PHP.
    WordPress está actualizado. 1&1 Unlimited Pro

    Creo que ha llegado el momento de cambiar (si no tiene solución), he estado viendo el tema Real Homes – WordPress Real Estate Theme y está bastante bien.
    Pero prefiero, ya que pago, un tema similar con sus desplegables en español, así el dinerillo se queda en casa 

    ¿Me podéis dar algún consejo de algún tema?

    La web de inmobiliaria tiene muchas referencias, ¿alguna idea sencilla de cómo exportar/importar al nuevo tema todas las referencias sin morir en el intento?

    El error que da actualmente al cambiar la versión PHP 7.2 es:

    Warning: Declaration of Walker_Category_RadioList::start_lvl(&$output, $depth, $args) should be compatible with Walker::start_lvl(&$output, $depth = 0, $args = Array) in /homepages/0/d448705710/htdocs/inmobiliaria/wp-content/themes/Avenue/lib/walker.php on line 3
    Por si a alguien se le ocurre alguna idea y/o solución.
    Agradecido de antemano.

    Hugo – corysan10

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 1 respuesta (de 1 total)
  • Moderador Fernando Tellado

    (@fernandot)

    Hola, sobre Avenue no te podemos ayudar pues es un tema que no está en WordPress.org, uno de los requisitos de estos foros.

    Sobre lo del hosting, te recomiendo que cambies de hosting si te cobra por actualizar a PHP, por ahí no hay duda

    Pero con el cambio de tema tienes un problema, si has usado funcionalidades internas de otro tema, que serán incompatibles con el resto. El tema debe ofrecer la apariencia, las funcionalidades deben darlas plugins, que son transversales a los temas. Tiene mal apaño, muy malo. Habría que migrar la información tabla a tabla, desde el tema hasta un plugin de inmobiliarias, y eso es trabajo a medida, lento, caro.

Viendo 1 respuesta (de 1 total)
  • El debate ‘No soporta PHP 7.*’ está cerrado a nuevas respuestas.