Soporte » Guías – Resolución de problemas » Página de entradas desaparecida

  • Resuelto Antonio

    (@antoniosm85)


    Hola, me ha desaparecido de la noche a la mañana la página de entradas y no muestra ninguna. Anteriormente me sucedía cuando por error no categorizaba una de las entradas, entonces dejaban de mostrarse todas. Pero en esta ocasión han desaparecido sin introducir ninguna entrada nueva ni tocar nada. Alguien me puede dar un poco de luz en este tema?

    Muchas gracias de antemano!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • Moderador almendron

    (@almendron)

    Es muy posible que la consulta que se genere para crear la sección de noticias no esté bien realizada.

    El problema es que usas una plantilla y una configuración que no podemos replicar.

    Antonio

    (@antoniosm85)

    @almendron muchas gracias, eso ya más o menos lo suponía. ¿Y puede haber alguien quizá que conozca un poco el tema o la llamada que está haciendo mal y pueda decírmelo? No le encuentro solución y quizá algún alma caritativa de los developers quiera echarme un cable, porque estoy un poco perdido.

    Muchas gracias!

    Moderador almendron

    (@almendron)

    Pero… ¿qué temas usas? ¿es comercial o gratuito?

    Antonio

    (@antoniosm85)

    Justo ahí viene mi calvario. El tema lo instaló el antiguo informático de la empresa y es un tema comercial pero «pirateado», entonces no tengo soporte por ningún sitio. Y cambiar de tema me va a salir pero que muy caro en SEO y en horas de trabajo porque es una web con más de 1000 artículos y muy posicionada en su sector, así que no me queda más remedio que pedir ayuda por aquí.

    Si puedes ayudarme o me puedes indicar dónde buscar ayuda te lo agradecería infinito.

    Muchas gracias!

    Moderador almendron

    (@almendron)

    A nivel de SEO no tienes porqué tener problemas siempre y cuando conserves la URL.

    Por ejemplo: https://alfagenerators.es/documentos-corporativos/. Da lo mismo que tema o diseño utilices siempre y cuando esa dirección se mantenga idéntica.

    De hecho, solo tienes que probar a cambiar de tema. Podrás comprobar que las URL,s se mantienen. Tienes que indicar como página principal una estática (la misma que utilizas ahora) y que muestre las entradas en la página «Noticias».

    Haz la prueba con alguno de los temas que trae por defecto WordPress.

    Moderador almendron

    (@almendron)

    Lo normal sería que en Apariencia > Personalizar te aparecieran esos valores (página que usas de principal y página que usas para mostrar las entradas)

    Antonio

    (@antoniosm85)

    Como idea está bien pero al tener un CSS ultrapersonalizado la que se va a liar en la forma en que se muestran los productos va a ser muy grande y no tengo tiempo en la empresa para modificar CSS para el tema nuevo. Hay demasiados clases personalizadas, etc.

    Tiene que haber una forma de encontrar por qué no muestr las entradas.

    https://alfagenerators.es/fabrica/grupos-electrogenos/

    https://alfagenerators.es/fabricacion/generador-lombardini-industrial-de-4-kva-4-kw-insonorizado-ldw702/

    Aquí te dejo dos ejemplos par que veas el CSS utilizado y la que se me avecina si cambio de tema

    • Esta respuesta fue modificada hace 1 año, 6 meses por Antonio.
    Moderador LGrusin

    (@lgrusin)

    ¿Has probado vaciar el plugin de caché?… y los temporales del navegador.

    • Esta respuesta fue modificada hace 1 año, 6 meses por LGrusin.
    Antonio

    (@antoniosm85)

    Eso sí está comprobado.

    Con el WP Fastest Cache vacío caché y luego F5 y Ctrl+F5 en el navegador y nada. Es un error interno que desconozco

    Moderador LGrusin

    (@lgrusin)

    Pues va a ser muy complicado ayudarte sin tener acceso al tema.
    ¿Qué se supone que había en la página noticias?
    ¿Es una página?
    ¿Es una categoría?

    Mira el código del archivo que corresponde a esa página a ver si notas algo extraño.

    Moderador almendron

    (@almendron)

    ¿has mirado en Apariencia > Personalizar > Ajustes de Portada? Allí deberías ver la página que tienes asignada para ver las entradas. Debería ser «noticias».

    Antonio

    (@antoniosm85)

    El tema se llama EXPANSIVE y es de CPOthemes.

    Sí, la página asignada es la de siempre, «noticias».

    Como dije al principio del hilo, antes cuando creaba una entrada nueva y no le asignaba categoría, automáticamente dejaban de mostrarse todos las entradas y sucedía lo mismo que ahora. Pero en esta ocasión no he subido ninguna entrada nueva y tampoco hay ninguna sin categorizar. Así que me quedo sin ideas.

    Antonio

    (@antoniosm85)

    Señores lo he solucionado al final por mi cuenta.

    Solo he tenido que meterme en los permalinks y darle a guardar cambios para que hiciera un update y todo solucionado.

    Alguien me puede explicar por qué puede suceder esto?

    Muchas gracias por todo!!

    Moderador almendron

    (@almendron)

    Ni idea. A veces pasa pero suele afectar a todo el sitio y dar un error 404.

    En cualquier caso, no somos adivinos. Sin acceso al tema y sin poder hacer pruebas es casi imposible dar con el problema.

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • El debate ‘Página de entradas desaparecida’ está cerrado a nuevas respuestas.