Soporte » Guías – Resolución de problemas » PHP y Plugin Event Calendar

  • Resuelto Almudenita11

    (@almudenita11)


    Buenos días,

    Tengo un problema porque no puedo Instalar y que funcione el Plugin Event Calendar.
    Me da un aviso de que necesito una versión pHP 5,5 o superior y que consulte con el hosting.

    En el hosting tengo una versión 7.0, así que debería funcionar.

    ¿Qué puede estar pasando? ¿Cómo puedo soluciarnlo?

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador kallookoo

    (@kallookoo)

    Hola @almudenita11

    Acabo de visitar tu web y me dice que usas la version 5.5 de php, por lo que ese plugin deberia funcionar.
    Como hay varios plugins con ese nombre no se exactamente cual es y no puedo mirar su codigo para comprobarlo.

    Aparte aunque no tiene que ver con tu pregunta, te recomiendo encarecidamente que actualices tu version de php a la ultima que tenga tu hosting, tanto por seguridad como por rendimiento, si lo haces tienes que comprobar primero que tanto tu theme como los plugins que uses son compatibles.

    Iniciador del debate Almudenita11

    (@almudenita11)

    Los plugins en cuestión que me da el aviso es:
    https://theeventscalendar.com

    Lo que no entiendo es que si el hosting tiene un PHP de 7.0 porque me dice que yo uso la 5.5. Hay algo que no debe estar bien…

    Moderador kallookoo

    (@kallookoo)

    Hola @almudenita11

    La mayoria de proveedores tienen la opcion de cambiar entre versiones de PHP, yo entiendo que en tu proveedor comentan que tienen esa version pero deduzco que no la tienes activada en tu servidor.
    Lo suyo seria mirar si desde el panel de control puedes cambiarla o sino deberias contactar con ellos para que lo cambien.

    Iniciador del debate Almudenita11

    (@almudenita11)

    Buenos días Kallookoo,

    Aquí no te puedo poner una imagen del servidor, pero a priori parece que está activada.

    Yo me he metido en el panel de control del servidor y la actualicé el otro día cuando me dijeron que la versión no era suficiente, pero estaba ya en 7.0.

    Yo no sé si tengo que activarla, pero no sé cómo se hace eso. Pensé que se activaba por defecto.

    Moderador kallookoo

    (@kallookoo)

    Hola @almudenita11

    Te sugiero para no complicarnos la vida es que hables con el soporte del hosting y que lo comprueben y activen si fuese necesario.

    Si quieres saber que version usas exactamente descartando el header que es como yo lo he sabido, etc… es que crees un archivo llamado phpinfo.php y copies esto <?php phpinfo(); despues lo subes a tu servidor donde esta el archivo wp-config.php y entras tudominio/phpinfo.php y veras toda la informacion referente al PHP. Despues por seguridad borrarlo.

    Iniciador del debate Almudenita11

    (@almudenita11)

    Ok. Voy a ver si me lo solucionan los del hosting, que ya hablé con ellos y me dijeron que estaba bien.

    Mil gracias.

    Iniciador del debate Almudenita11

    (@almudenita11)

    Ok. Parece que había un archivo en mi wp que obligaba a funcionar con una versión antigua de php.

    Ya está modificado y solucionado el tema.

    Muchas gracias por la ayuda.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘PHP y Plugin Event Calendar’ está cerrado a nuevas respuestas.