Soporte » Plugins y Hacks » WooCommerce » Plugin Redsys no finaliza despues de actualizar PHP

  • Hola a todos,

    Tengo una web con plantilla Avada y una pasarela de online con Woocommerce conectado al Plugin Redsys para Woocommerce que hasta una semana funcionaba perfectamente. La semana pasada tuve que actualizar el PHP a la versión 7.2 y el Redsys comenzó a dar error al pasar de la página de confirmación.

    Ahora estoy en el modo de pruebas de Redsys. Al hacer una compra, llego a la página de finalizar, relleno los datos y al pasar a la página de confirmación carga el número de pedido, el monto, la fecha y la forma de pago pero el botón de Pagar con Redsys y Cancelar no los carga (aparece un recuadro que pone «La página sis-t.redsys.es ha rechazado la conexión.»).

    He mirado de volver atrás con el PHP, reinstalarlo todo, actualizarlo todo, desactivar todos los plugins y cambiar de plantilla. He probado modificando el archivo wc-redsys.php para que la comunicación sea HTTP y eliminar posibles incompatibilidades con el certificado Let’s encrypt que usa la web (pero ojo antes no daba problemas).

    El debug me da como error:

    Notice: Undefined variable: ref in /home/oncolliglv/www/web/wp-content/plugins/redsys/wc-redsys.php on line 408

    Estoy muy perdido y ya no sé por dónde más probar
    ¿Alguien tiene alguna idea de qué puede ser o como solucionarlo?
    Muchas gracias

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 1 respuesta (de un total de 1)
  • Hola @edimurtra

    Por lo que yo se, casi todo el mundo recomienda que se use este plugin; https://es.wordpress.org/plugins/woo-redsys-gateway-light/ tambien tienes la version de pago donde obviamente tienes mas caracteristicas.

    Lo que te sucede, no te puedo comentar nada para solucionarlo y es muy raro que sin tocar nada ahora no te funcione.

    Podrias actualizar el plugin si aun no lo hicistes y revisar la configuracion para comprobar que lo tienes todo bien, igualmente por lo que yo se el plugin oficial suele dar problemas y por eso mismo suelen recomendar el plugin que te menciono.

    Saludos

Viendo 1 respuesta (de un total de 1)
  • Debes estar registrado para responder a este debate.