Soporte » WordPress Avanzado » Plugins instalados no se ven en el panel de admin

  • Hola amigos.

    Estoy teniendo problemas con el panel de administración de wordpress. Hace unos días tuve que depurar wp_options porque se había llenado de porquería por un plugin desinstalado a medias y que generó miles de registros de error.

    Tras su eliminación empecé a tener problemas con el panel de administración, a saber:

    -Algunos plugins instalados no aparecen en el cuadro de mandos para editar configuración y no puedo utilizarlos.
    -La biblioteca de medios trabaja a medio gas. Para subir un archivo (fotos, pdf’s,etc.) tarda en cargar muchísimo y en ocasiones devuelve un mensaje de error. Solo se consigue subir tras varios intentos.

    ¿CUál puede ser una solución a esto?

    Ya he reinstalado WordPress y algunos defectos que tenía se han corregido, pero estos que os comento persiste.

    ¿Por dónde podría continuar?

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Moderador almendron

    (@almendron)

    1.- Respecto a los plugins que no aparecen, borra sus correspondientes directorios (accede vía FTP) y vuelve a instalarlos. Una vez lo hayas hecho, busca la ocpión de guardar sus opciones.
    2.- El resto de plugins: desactiva, activa de nuevo y después busca la opción de guardar sus opciones. Eso debería regenerar los datos en wp-options.
    3.- En cuanto a la biblioteca de medios, no se qué decirte. Podrían ser muchas cosas. Primero mira a ver si solucionas lo de los plugins y luego ya veremos.

    Gracias almendron.

    Lo de los plugins ya lo he solucionado, con el método que me has dicho :).
    Me falta lo de la biblioteca de medios, que no paro de hacer reinstalaciones de wordpress y sigue igual.

    También he probado a ver si es alguna incompatibilidad con algún Plugin, pero nada, lo mismo. Los he desactivado todos y el problema persiste.

    Moderador almendron

    (@almendron)

    Biblioteca de medios: ¿te da algún mensaje de error?

    Ninguno.

    Al subir una imagen, o se queda pensando, o al subir una imagen destacada, directamente no la sube.

    Hay que hacerlo varias veces para que, en alguna, consiga subirlo.

    Moderador almendron

    (@almendron)

    Prueba a definir en el wp-config.php el directorio de las imágenes. Para ello, justo antes de la línea require_once(ABSPATH.’wp-settings.php’);, añade lo siguiente: define('UPLOADS', 'wp-content/nombre-carpeta-imagenes');

    Hecho, pero sigue igual…

    Moderador LGrusin

    (@lgrusin)

    ¿Pasa con cualquier tamaño de archivo o sólo con imágenes grandes?

    Un saludo

    Acabo de fijarme, pero da igual el tamaño.

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • El debate ‘Plugins instalados no se ven en el panel de admin’ está cerrado a nuevas respuestas.