Soporte » Plugins y Hacks » Polylang – Problema con el segundo menú

  • Resuelto paulamartinez

    (@paulamartinez)


    Hola, he instalado el plugin Polylang porque quiero traducir la web tanto en inglés como en castellano.
    Para ello he seguido la siguiente ruta -después de duplicar todas las páginas que tenía en castellano-:
    Apariencia > menús > crea un nuevo menú.
    Ahí he seleccionado las páginas en inglés además del conmutador de idioma. En los ajustes de menú he seleccionado top menu English y main menu English.

    Cuando accedo a la página de inicio principal no hay ningún problema, se ve todo perfectamente. Sin embargo cuando le doy a la opción en inglés solamente me aparece la opción de volver al menú en castellano, nada más. ¿Cómo podría resolver el problema?

    Aparte tengo otra duda que tiene que ver con el cambio de idioma. Debajo del nombre de la empresa -que está centrado en la cabecera- tengo un texto que me gustaría que se tradujera en ambos idomas pero no me da la opción ya que no forma parte ni del menú ni de las páginas individuales.

    Estoy trabajando con el tema Savona.

    Gracias de antemano y un saludo,
    Paula Martínez.

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Moderador LGrusin

    (@lgrusin)

    Los plugins de idiomas son complicados de configurar. Debes leer la documentación detenidamente, hay mucho que comprobar y cada instalación es diferente.
    https://polylang.pro/doc/strings-translations/

    Iniciador del debate paulamartinez

    (@paulamartinez)

    Buenos días, muchas gracias por la ayuda, he conseguido resolver el tema de la descripción.
    Sin embargo sigo con el problema del menú, no me aparecen las páginas que tengo agregadas como home o contact y sin embargo si que me aparece el conmutador de idioma.

    Moderador LGrusin

    (@lgrusin)

    ¿El primer menú lo tienes bien? Debes seguir el mismo procedimiento con el otro menú.

    Iniciador del debate paulamartinez

    (@paulamartinez)

    Si, el primero está bien y con el otro he seguido los mismos pasos.
    Igual se soculuciona con algún código css que le obligue a la página a mostrarlo, no lo sé.

    Moderador LGrusin

    (@lgrusin)

    Comprueba que no sea cosa de cachés, tanto de navegador. plugins o el mismo servidor. Vacíalos todos.

    Iniciador del debate paulamartinez

    (@paulamartinez)

    He probado eso y a instalarme otro plugin para ver si era fallo de éste y al cabo de un rato me ocurre lo mismo con el nuevo

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • El debate ‘Polylang – Problema con el segundo menú’ está cerrado a nuevas respuestas.