Soporte » Plugins y Hacks » WooCommerce » Por favor, elige las opciones del producto visitando «el mismo producto»

  • Resuelto dafonk

    (@dafonk)


    Además de tener hace días problemas con el plugin de pago «Mercadopago» ahora Woocommerce hizo una actualización (mayor) y al querer poner un producto en el carrito me sale siempre este error cual enlace me devuelve nuevamente al producto y nuevamente al querer ponerlo en el carrito otra vez ese erro y así sucesivamente…. no entiendo qué es… si tiene que ver con las variantes o qué…. trate con todo pero no doi en el clavo 🙁

    Agradecido por cualquier ayuda…..

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 12 respuestas - de la 1 a la 12 (de un total de 12)
  • Moderador Rafa Poveda

    (@bi0xid)

    Hola @dafonk.

    Por lo que puedo ver, el sistema te está pidiendo que selecciones las opciones del producto. Como bien dices, tiene pinta de que las variaciones están haciendo algo raro y el sistema está esperando una información que el usuario tiene que seleccionar que no le está llegando.

    Tendrías que revisar las variaciones de los productos para asegurarte de que lo que se muestra en pantalla es todo lo que está en las variaciones para poder hacer el pedido.

    También puede ser que tengas algún problema de JavaScript (algún conflicto de algún plugin) porque parece que el selector no hace cambiar el variation_id, que marca el selector de dispositivo. Esto puedes probarlo haciendo que por defecto esté marcado mobi, por ejemplo, y ver si el producto pasa al carrito.

    Si el problema es de JavaScript, probablemente algún plugin esté bloqueando la carga. Prueba también a hacer funcionar la página con Autoptimize desactivado, para descartar también que te esté dando problemas.

    Espero que esto pueda ayudarte. Nos quedamos a la espera de que nos cuentes si pudiste solucionarlo.

    Un saludo.

    Iniciador del debate dafonk

    (@dafonk)

    Muchas gracias por tu ayuda, efectivamente parece que el problema era el plugin Autoptimize. Lo desactive y volvió todo a la normalidad. Creo que lo voy a borrar, tengo otro, el optimizador.io de webempresa que sirve para optimizar las imágenes. Me quedaré solo con ese 😉

    Gracias

    Moderador Rafa Poveda

    (@bi0xid)

    ¡Genial! Me alegro de que hayas podido solucionarlo.

    Si no te importa, marca el tema como resuelto para mejorar la búsqueda de información del foro.

    ¡Gracias!

    Iniciador del debate dafonk

    (@dafonk)

    Resuelto… gracias.

    Hola!!
    Tengo el mismo problema que tenia dafonk hace una semanas » Por favor, elige las opciones del producto visitando» He buscado si yo tenia el plugging Autoptimize pero no lo encontré.
    Este es listado de pluggins que tengo activados:
    -Advanced Custom Fields PRO
    -Contact Form 7
    -Contact Form 7 Extension For Mailchimp
    -Cookie Notice
    -Duplicate Post
    -Flat Rate per State/Country/Region for WooCommerce
    -LayerSlider WP
    -Portfolio Post Type
    -Really Simple SSL
    -Simple Custom Post Order
    -Slider Revolution
    -UpdraftPlus – Backup/Restore
    -WC APG Envío por peso
    -WooCommerce
    -WooCommerce Quantity Increment
    -WooCommerce Stripe Gateway
    -WP Simple Mail Sender
    -WPBakery Page Builder

    Creis que alguno de estos plugins me esta creando el error?
    Os dejo el enlace a uno de los productos que me da error
    https://botondenacar.com/producto/collar-llueve-p/

    Si me podeis ayudar os lo agradeceria mucho!!!

    saludos!!!

    Hola! Me está pasando lo mismo. Las variaciones funcionaban perfectamente en mi web obradorlanena.com, ahora no van y devuelven el bucle del mensaje que comenta el primer correo. Revisando la lista de plugins que hay por aquí, no coincido con ninguno. He probado a desactivar los de caché y el error persiste.
    ¿Ideas?
    ¡Gracias por adelantado!

    Me autorespondo por si a alguien le ayuda. Con la nueva actualización hay que especificar una opción por efecto en las variables. Con este ajuste se arregla el problema.

    @anaicarretero

    ¿Puedes especificar donde? ¡Gracias!

    ¡Claro!
    En la pestaña de variaciones de un artículo variable – valores por defecto del formulario. Ahí debes incluir uno de los valores de las variaciones. Por ejemplo si es un producto que está disponible en naranja y amarillo, debes anotar naranja o amarillo en esa casilla, para que aparezca una opción por defecto.

    Gracias por responder tan rápido. Probé eso pero no me ha funcionado. He reinstalado la template en su última versión y parece que va correctamente. Era un error de Java Script.

    Hola! Tengo el mismo problema. Intenté poniendo el producto por defecto pero no funcionó. Mi duda es ¿cómo se hace reisntala la template? para intentar. Gracias

    Moderador Jose Luis

    (@jose64)

    Hola @celestebucio

    Bienvenido al foro de soporte. Antes de nada haz una copia de seguridad, por si acaso tienes que revertir los cambios. Una vez hecho esto tienes que cambiar el tema por que estás usando por otro y borrar el tema que quieres reinstalar, lo borras en los detalles del tema, verás el botón al pasar el cursor sobre el tema, en la ventana de detalles tienes en la esquina inferior derecha la opción borrar.

    Una vez borrado el tema tienes que volver a instalarlo, pero ten en cuenta que las opciones de personalización se guardan en la base de datos y seguramente se mantendrán.

    Si la web para la que haces la consulta es la que indicas en tu perfil lo instalas desde el repositorio. También tienes un plugin para eliminar todas las opciones de configuración del tema Astra:

    Astra Customizer Reset

    Ese plugin elimina todas las configuraciones personalizadas del tema Astra, dejándolo como en su instalación inicial.

Viendo 12 respuestas - de la 1 a la 12 (de un total de 12)
  • Debes estar registrado para responder a este debate.