• Buenas,

    Quería comentar algo que me lleva pasando en este ultimo mes y antes no me ocurría…

    Cuando programo un post para que salga en una fecha determinada, wp falla a la hora de publicarlo y esto es lo que veo: https://ibb.co/wYvXvB5

    El tema es que todo lo tengo automatizado y la publicación en redes sociales con el enlace … falla con un 404 porque el post no está realmente publicado.

    Sabéis qué puede estar provocando este comportamiento?

    Gracias de antemano.

    Un saludo.

Viendo 10 respuestas - 1 de 10 (de 10 total)
  • Hola @posturseo

    Lo que planteas está relacionado con el cron de WordPress.

    Las posibles causas que se me ocurren son:

    1. Tienes algún plugin o snippet de código para desactivar el cron con el objetivo de mejorar la velocidad de carga de la web y por eso no se publica
    2. Si la web no tiene visitas, tengo entendido que el cron no se activa y por lo tanto no se publica

    Espero te sea de ayuda
    saludos

    Gracias por tu respuesta Danyel,

    La web tiene 200-300 visitas diarias, por lo que entiendo que entonces debe ser el punto 1 la causa.

    No sé a qué te refieres con snippet pero… ¿Cómo puedo llegar a saber qué plugin o snippet es el que está causando el problema para proceder a desactivarlo?

    Muchas gracias de antemano!

    Discúlpame, es la costumbre.

    Un snippet es un fragmento de código de los que normalmente se copian y pegan tal cual de algún tutorial a tu web.

    Si no recuerdas haber hecho esto, lo más probable es que sea algún plugin.
    En caso de ser esto, prueba con algún plugin de velocidad de carga o caché que tengas tipo WP Rocket, Super Cache etc. Lo más probable es que tengas alguna opción que lo esté desactivando.

    De no ser el caso, también puedes echar un ojo a este post:
    https://wordpress.stackexchange.com/questions/81618/how-to-fix-missing-function-in-wp-cron

    Está en inglés, pero es muy breve. Explica cómo desactivar el cron de WP que por algún motivo está fallando y cómo crear uno propio

    saludos

    Muchas gracias de nuevo!

    Justo ayer desactive el wp-rocket, porque estaba causando incompatibilidades con otros sistemas que estaba empezando a usar ahora… probaré si así el siguiente post programado funciona, y de ser así, ahí tenemos el motivo. Será mañana el siguiente post programado, así que no tardaré en saberlo.

    De todos modos tengo presente el enlace que comentas para echarle un ojo en caso de ser necesario.

    Gracias de nuevo!

    Ten en cuenta que aún desactivado e incluso eliminado, es posible que WP Rocket deje algún rastro en tu base de datos por lo que si no funciona, antes de meterte a tocar código, te recomiendo que actives de nuevo WP Rocket, busques la opción que te está causando el problema y la desactives para luego eliminar el plugin de nuevo

    ya nos contarás
    suerte 😛

    Mmmm, gracias por la información. Suponía que una vez desactivado y más aun si se desinstala, los plugin deberían dejar el estado de WP tal y como estaba antes de instalarlos…

    Siendo eso como comentas, la cosa se complica aun más. No se qué opción del WP rocket puede estar causando este problema… y es jugar al prueba y error y con una prueba dificil de testear, porque no publico post todos los días…

    A ver si puedo encontrar ayuda en el soporte de WP rocket… o en mi hostin al respecto.

    Muchas gracias de nuevo.

    Hola

    Si te urge solucionarlo, siempre puedes programar un post de prueba a ver si se publica en unos minutos y estar pendiente y borrarlo para que no te afecte al SEO.

    No tengo la última versión de wp rocket por lo que no te puedo ayudar, y además creo que no está permitido dar soporte a plugins premium.

    Moderador almendron

    (@almendron)

    Es muy probable que el plugin de cache WP rocket sea el causante del problema. Excluye el archivo wp-cron.php de la cache o bien desactiva «Object Cache» si tiene esa opción.

    Moderador almendron

    (@almendron)

    ¿Lo has solucionado?

    Buenas @almendron

    perdon por no responder antes.

    Sí, se solucion siguiendo este enlace de mi hosting: https://www.webempresa.com/blog/desactivar-el-fichero-wp-cron-php-para-evitar-consumo-excesivo-del-servidor.html

    un saludo!

Viendo 10 respuestas - 1 de 10 (de 10 total)
  • Debes estar registrado para responder a este debate.