Soporte » Guías – Resolución de problemas » Problema al actualizar web antigua (versión 2.9.2.) a la última versión (6.0)

  • Resuelto mbarrera9

    (@mbarrera9)


    Buenas,

    De primeras, me gustaría agradecer la ayuda que me puedan o vayan a prestar en este caso.

    Tengo una web que no ha recibido el correcto mantenimiento y se ha dejado de lado desde creo 2010 (no estoy seguro de la fecha pero por la versión de wordpress que tiene la página (2.9.2) lo podrán saber).

    El caso es que la queremos renovar y acutalizarla a la última versión disponible, pero al darle a actualizar automáticamente, me aparece el siguiente error: Parse error: syntax error, unexpected T_STATIC in /web/htdocs/www.doorfantest.es/home/wp/wp-admin/includes/update-core.php on line 1681

    Buscando en vídeos y foros no he podido encontrar nada que me ayude. He probado a realizar la actualización manual pero tampoco ha servido, también a desactivar todos los plugins y nada. Decir que tengo copia de seguridad de la base de datos y del sitio de WP como aconsejan antes de realizar cualquier actualización mayor.

    Espero que alguien me pueda echar una mano con esto.

    Un saludo.

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Moderador almendron

    (@almendron)

    Puede que sea el tema es que ocasione el problema.

    Yo empezaría con activar uno de los temas que trae por defecto WordPress en lugar de la que tengáis ahora y luego desactivar TODOS los plugins.

    Si estáis usando PHP 8.x, también podrías probar a poner la 7.4 o superior (sin llegar a la 8)

    Hola mbarrera9, almendron te ha dado buenos consejos, que por ahí puede ir los tiros, a lo mejor es la versión de PHP,

    hace poco tuve un problema parecido, yo tenia la versón de WP 4.9 y tenia un codigo que copie de ayudawp y era para evitar actualizaciones automaticas, y todo iba bien, pero decidieron actualizar y se instala la última versión y se veia «raro wordpress»,
    Imagen ejemplo

    Me las apañé como pude: subí el theme Divi que tenia actualizado (version 3) y lo sustituí por el que tenía (versión 2.7), asi que tenia el último WP y la versión «actualizada» de Divi, active uno de los tema que viene por defect en WP,

    instalé un plugin que te instala versiones anteriores a WP (yo reinstale la 5.10), se realizó la instalación del nuevo WP (5.10) y en Apariencia active el Divi versión 3, y por ahora va todo bien, mbarrera9 una vez que se instale la version que deseas deberás eliminar ese plugin WPDowngrade. (hasta que no lo borré no aparecía el mensaje de ¿desea actualizar?).
    Espero que se solucione, un saludo

    La imagen que te he mandado con el problema similar fue lo que le envié al cliente.
    A la izquierda lo que se veia, a la derecha lo que deberái verse, yo le pregunté:
    «¿no habeis notado nada raro, no veíais nada «raro»?.
    Lo dicho espero que se solucione.
    *¡Ah y haz copi d eseguridad antes de nada!!

    Iniciador del debate mbarrera9

    (@mbarrera9)

    Buenos dias,

    Muchas gracias @almendron y @01danielsantiago por contestar. No he podido probar nada más que lo primero que proponia @almendron, que era activar un tema por defecto de wordpress y desactivar los plugins pero no me solucionó nada, me seguia saltando el mismo error. Probaré a cambiar la version de PHP y si no resulta seguiré con tus consejos @01danielsantiago

    Muchas gracias a los dos por la ayuda. Iré comentando sobre mi progreso coforme avance (espero conseguirlo!).

    Un saludo.

    Iniciador del debate mbarrera9

    (@mbarrera9)

    Lo conseguí!

    Ha sido actualizar la versión de PHP y ya me ha dejado… qué alivio.

    Esto de no tener ni idea, que te caiga la responsabilidad y tener que aprender a la fuerza, encontrándote fallos que en un principio no ves la solución y no saber por donde tirar es cuanto menos estresante.

    Muchas gracias a los dos por vuestra ayuda, se agradece un montón.

    Un saludo!

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.