Soporte » Guías – Resolución de problemas » Problema al clonar sitio web con xampp

  • Resuelto javisan

    (@javisan)


    Hola,

    Estoy intentando hacer una copia de mi sitio web vía xampp (de hosting a local) para trabajar con ella en mi pc. He descargado la base de datos y los archivos de la web mediante FTP. Instalo la base de datos en local con PHPmyadmin y pego los archivos de la web en la carpeta xampp/htdocs/<projecto>. El problema viene al intentar conectarme a través del navegador con localhost/<projecto> ya que me redirecciona al dashboard de xampp, como si no detectase el wordpress.

    Gracias de antemano por ayudar.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Moderador almendron

    (@almendron)

    Tienes que cambiar las URL,s internas para que te funcione en local.

    Lo más fácil es hacer una copia con el plugin Duplicator ya que te las cambiará de forma automática. Hay muchos manuales de ese plugin en la Red.

    https://es.wordpress.org/plugins/duplicator/

    • Esta respuesta fue modificada hace 4 meses por almendron.
    javisan

    (@javisan)

    A cambiar las URL’s internas te refieres a modificar la url de el archivo wp_config de la base de datos? Porque eso si que lo he hecho.

    El plugin Duplicator lo he probado pero me da errores al crear el paquete para exportar y no he sido capaz de solucionarlo

    Moderador almendron

    (@almendron)

    Tienes que cambiar todas las URL,s del dominio por las de localhost.

    ¿Qué errores te da Duplicator? Normalmente, solo da avisos o alertas.

    Si acaso, descarta la carpeta «Uploads» de la copia si tienes muchas imágenes. Luego, por FTP te la bajas.

    javisan

    (@javisan)

    Las URLs las he cambiado todas pero sigue sin detectar el wordpress y me sigue redireccionando al dashboard de xampp.

    Con duplicator he arreglado todos los avisos que daba a la hora de analizar, como la carpeta «Uploads» que decías, pero al crear el paquete me da el error » El servidor ha interrumpido la creación». He probado con las opciones que me sugiere para arreglarlo y lo único puede ser que sea cosa del servidor

    Moderador almendron

    (@almendron)

    Sin plugin, los pasos a seguir son los siguientes:

    1) Crea base de datos en local.

    2) Importa a esa base de datos el fichero sql que has exportado en el servidor.

    3) Tabla wp_options (el prefijo puede variar): localiza «siteurl» y «home». cambia su valor por http://localhost/nombre-carpeta. Sustituye «nombre-carpeta» por el nombre de la carpeta que hayas utilizado.

    4) Copia los archivos a la carpeta que hayas creado.

    5) Haz una copia del archivo wp-config.php y luego lo eliminas.

    6) Intenta entrar. Aparecerá una pantalla para configurar tu sitio y conectar con la base de datos local.

    7) Finalmente, instala y activa el plugin https://es.wordpress.org/plugins/better-search-replace/
    Sustituye el dominio por la dirección en local.

    javisan

    (@javisan)

    Ahí está el problema. Hago todos los pasos hasta el 6, al entrar en localhost/proyecto no me sale ninguna pantalla para configurar el sitio, me sale el dashboard de xampp.
    El resto de pasos los he hecho tal y como dices

    Moderador almendron

    (@almendron)

    Prueba a editar el wp-config.php original en lugar de eliminarlo. Cambia los valores que correspondan.

    javisan

    (@javisan)

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘basededatos’);

    /** MySQL database username */
    define(‘DB_USER’, ‘root’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, »);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    Eso es lo que cambio y sigue igual 🙁

    Moderador almendron

    (@almendron)

    Solo deberías cambiar la primera. Las otras déjalas tal y como están ahora salvo que hayas puesto contraseña.

    javisan

    (@javisan)

    Ahí muestro las 4 ya cambiadas a los valores del local: la base de datos que he creado en local, con usuario root y sin contraseña y el host a local, ya que al descargar el archivo wp_config.php esto cuatro valores estaban configurados con los datos del servidor.

    Moderador almendron

    (@almendron)

    Yo haría una prueba:

    1) Crea una nueva base de datos.

    2) Crea una nueva carpeta e instala un WordPress limpio.

    Otra cosa:

    ¿Con qué URL intentas entrar?

    javisan

    (@javisan)

    Al hacerlo «desde cero», creando una nueva base de datos y un wp limpio sí que me sale el instalador de wp.

    Estoy entrando con localhost/nombre_de_la_carpeta

    Moderador almendron

    (@almendron)

    El problema está por tanto en la importación de tu sitio o, mejor dicho, en la exportación. Algo falla.

    Prueba lo siguiente:

    1) Borra las tablas del WordPress limpio que acabas de instalar. Solo las tablas. La base de datos no la borres.

    2) Importa a esa base de datos el archivo sql que exportaste en tu sitio.

    3) Tabla wp_options (el prefijo puede variar): localiza «siteurl» y «home». cambia su valor por http://localhost/nombre-carpeta. Sustituye «nombre-carpeta» por el nombre de la carpeta que hayas utilizado para crear el WordPress limpio.

    4) Intenta entrar.

    Si puedes entrar, sigue con los pasos siguientes:

    1) Copia la carpeta del tema que estuvieses usando en tu sitio de la copia de seguridad. Pega esa carpeta dentro de «wp-content/themes».

    2) Usa https://es.wordpress.org/plugins/better-search-replace/ para cambiar las URL,s internas.

    3) Instala y activa los plugins que uses en tu sitio.

    javisan

    (@javisan)

    Lo hemos conseguido!!

    Haciendo esto sí que ha funcionado asique te doy las gracias porque llevaba mucho tiempo intentando solucionarlo.

    Con esto cierro el hilo, muchísimas gracias 😉

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Debes estar registrado para responder a este debate.