Soporte » Guías – Resolución de problemas » Problema con Anuncios en AMP

  • Hola, buenas tardes,

    Hace unos días instalé AMP en mi sitio para que vaya más fluido ya que la mayoría de las visitas que recibo son a través de móviles y tablets.

    El problema con el que me encontré es que un bloque de anuncios que se muestra en la web normal también se aplica en el AMP pero aparece en blanco. Utilizo el plugin Quick Adsense para poner los anuncios dentro del post: tengo un bloque cuando empieza el post, otro después de 3 párrafos y uno al final del post. Solo el segundo aparece en la versión AMP y no se como poder eliminarlo ya que utilizo el propio plugin de AMP para establecer esos anuncios en concreto.

    He probado a desactivar el bloque en el plugin y efectivamente en la versión AMP ya no aparece. Lo que quiero es que no salga en la versión AMP sin tener que quitarlo de la versión normal.

    Os dejo los enlaces para que podáis comprobarlo:

    https://famososlove.es/ana-boyer-y-fernando-verdasco-ya-han-sido-padres/amp
    https://famososlove.es/ana-boyer-y-fernando-verdasco-ya-han-sido-padres/

    Espero vuestra ayuda.

    Saludos!!!!

Viendo 1 respuesta (de un total de 1)
  • Hola @daanilb

    Prueba añadiendo este codigo en el functions.php de tu theme.

    
    function daanilb_amp_ads() {
    	if ( function_exists( 'quick_adsense_2_clean_tags' ) ) {
    		add_filter('the_content', 'quick_adsense_2_clean_tags', 1 );
    	}
    }
    add_action( 'pre_amp_render_post', 'daanilb_amp_ads', 1 );
    

    Que conste que no esta probado, yo solo examine el codigo de los dos plugins.
    Y lo que hace es que cuando sea amp elimina todas las tags del plugin usando su propia function.

    Funcione o no, te recomiendo que hables con el author del plugin amp, explicandole tu caso y que añade soporte para eliminarlo.

Viendo 1 respuesta (de un total de 1)
  • El debate ‘Problema con Anuncios en AMP’ está cerrado a nuevas respuestas.