Soporte » Guías – Resolución de problemas » PROBLEMA CON DUPLICADO DE PÁGINA de http: a https

  • Resuelto nitocm

    (@nitocm)



    He hecho un test de duplicado de paginas y solo me ha dado positivo la pagina inicial.
    Me indica como solución esto: ¿donde debo añadirlo?

    – Si desea redireccionar http://example.com a http://www.example.com , puede usar esto:
    RewriteCond% {HTTP_HOST}! ^ http://Www.example.com $ [NC]
    RewriteRule ^ (. *) $ http://www.example.com/$1 [L, R = 301]
    Tenga en cuenta que debe colocar las líneas anteriores en algún lugar después de RewriteEngine On line.

    Esto es lo único que tengo En mi .htaccess: (lo añado antes o despues de esto?
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    AddOutputFilterByType DEFLATE application/x-font
    AddOutputFilterByType DEFLATE application/x-font-opentype
    AddOutputFilterByType DEFLATE application/x-font-otf
    AddOutputFilterByType DEFLATE application/x-font-truetype
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE font/opentype
    AddOutputFilterByType DEFLATE font/otf
    AddOutputFilterByType DEFLATE font/ttf
    AddOutputFilterByType DEFLATE image/svg+xml
    AddOutputFilterByType DEFLATE image/x-icon
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/javascript
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/xml

    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    Header append Vary User-Agent
    </IfModule>

    GRACIAS POR EL APOYO Y AYUDA.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - 16 de 30 (de 36 total)
  • nitocm

    (@nitocm)

    si correcto. lo tengo asi

    RewriteCond %{HTTPS} !on
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,QSA,L]

    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    AddOutputFilterByType DEFLATE application/x-font
    AddOutputFilterByType DEFLATE application/x-font-opentype
    AddOutputFilterByType DEFLATE application/x-font-otf
    AddOutputFilterByType DEFLATE application/x-font-truetype
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE font/opentype
    AddOutputFilterByType DEFLATE font/otf
    AddOutputFilterByType DEFLATE font/ttf
    AddOutputFilterByType DEFLATE image/svg+xml
    AddOutputFilterByType DEFLATE image/x-icon
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/javascript
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/xml

    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    Header append Vary User-Agent
    </IfModule>

    Moderador almendron

    (@almendron)

    Vamos a ver: ya te he explicado que no debes tener ese código y al mismo tiempo el plugin activado. O tienes uno o el otro, pero NO los dos a la vez.
    No tiene ningún sentido tener SSl y luego que no funcione el redireccionamiento.

    El hecho de que no funcione el plugin wp-force indica que hay un problema de fondo.
    Vamos a ir por partes:

    1) Ponte en contacto con el soporte de tu hosting y le preguntas si está activado el módulo mod_rewrite y si hay algo en la configuración del servidor que impida un redireccionamiento de http a https.

    2) Una vez obtengas la respuesta seguimos con el tema.

    nitocm

    (@nitocm)

    Si eso ya lo he confirmado con ellos.
    Mi servidor no tiene soporte para mod_rewrite.
    En todo caso nada seguire intentando buscar alguna solución.
    En elementor si tambien ya solicite el cambio de las direcciones como me indicastes mas arriba.
    En todo caso gracias por tu amabilidad y ayuda.

    Moderador almendron

    (@almendron)

    Mientras te responden, descarga y activa el plugin https://es.wordpress.org/plugins/better-search-replace/

    Después, lo usas para cambiar la dirección vieja (con http) por la nueva (con https). Nota: no pongas “/” al final de la URL.

    Moderador almendron

    (@almendron)

    ¿No tiene soporte para mod_rewrite? Pues podías haberlo dicho antes….

    ¿Qué tipo de servidor tienes?

    Tienes que hablar con el soporte de tu hosting y preguntar si se puede usar el htaccess, web.config o algún otro. También sería conveniente que habilitaran el mod_rewrite. Si no quieren o pueden que te digan ellos como hacer la redirección.

    Por último:
    1) haz lo de reemplazar con el plugin que te he dicho.
    2) Quita lo del htaccess (sin el módulo no hace nada)
    3) Desactiva el plugin simple

    nitocm

    (@nitocm)

    Gracias no tenia ni idea que eso iba a influir en ello el tema del mod_rewrite.
    Acabo de hablar con ellos y me dicen que no se puede activar en el tipo de servidor que tengo.

    Entonces voy a eliminar ese código del .htaccess

    Solo tengo una duda sobre el este plugin último que ma has comentado de utilizar.
    lo único que tengo que añadir es sustituir http por https ¿asi? sin barras ni nada?
    Es correcto?

    El tipo de servidor que tengo es este:
    https://www.interdominios.com/hosting-sin-limites.aspx

    nitocm

    (@nitocm)

    Gracias no tenia ni idea que eso iba a influir en ello el tema del mod_rewrite.
    Acabo de hablar con ellos y me dicen que no se puede activar en el tipo de servidor que tengo.

    Entonces voy a eliminar ese código del .htaccess

    Solo tengo una duda sobre el este plugin último que ma has comentado de utilizar.
    lo único que tengo que añadir es sustituir http por https ¿asi? sin barras ni nada?
    Es correcto?

    El tipo de servidor que tengo es en interdominios el windows sin limite.
    gracias

    Moderador almendron

    (@almendron)

    1) Desactiva también el plugin simple que tampoco hace nada.

    2) Pero habrá un archivo de configuración en el que se pueda poner el código correspondiente. Habla con ellos de nuevo y que te indiquen cómo puedes hacer la redirección (código) y en qué archivo debes ponerlo. Si no te solucionan, directamente te cambias de servidor.

    3) Plugin: Cambias la vieja

    http://www.fotografolaspalmas.eu

    por la nueva

    https://www.fotografolaspalmas.eu

    Tal y como yo te lo he puesto.

    Moderador almendron

    (@almendron)

    Y también cambias

    http://fotografolaspalmas.eu

    por

    https://fotografolaspalmas.eu

    nitocm

    (@nitocm)

    de acuerdo. pero me aparecen las tablas a seleccionar.

    Selecciono todas?
    y la selección de Quieres ejecutar un simulacro? Si activas esta opción, no se realizará ningún cambio en la base de datos, lo cual te permite verificar los resultados de antemano.

    esta marcada. le eliminio?
    Gracias

    Moderador almendron

    (@almendron)

    1) Selecciona todas las tablas

    2) Ejecuta primero el simulacro y así te haces una idea. Igual no necesitas cambiar ninguna.

    nitocm

    (@nitocm)

    Bueno he usado el plugin y tambien he hablado y parece que ahora esta solucionado. verdad?
    gracias

    nitocm

    (@nitocm)

    vaya pues no. solamente funciona para la pagina principal. El resto de enlaces ahora me aparecen sin el https. Que tengo que hacer sustituir todas las paginas con el pluging una por una?

    Moderador almendron

    (@almendron)

    Ahora redirecciona y todo parece correcto.

    Te recuerdo que o bien usas el código o el plugin. las dos a la vez , no.

    nitocm

    (@nitocm)

    Ya no estoy usando ningun plugin. Solo que la pagina segura es la principal. el resto me siguen apareciendo no seguras. Me refiero si debo utilizar el plugin better-search-replace/ para sustituir todas las direcciones de las paginas?
    Gracias

Viendo 15 respuestas - 16 de 30 (de 36 total)
  • El debate ‘PROBLEMA CON DUPLICADO DE PÁGINA de http: a https’ está cerrado a nuevas respuestas.