Soporte » Guías – Resolución de problemas » Problema con Gutenberg y Redirección /

  • Resuelto pabloape5420

    (@pabloape5420)


    Hola! Tengo un error con Gutenberg, que es siguiente:

    He agregado a mi archivo htaccess la siguiente reggla para que todos mis Urls terminen con / al final:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_URI} !(.*)/$
    RewriteRule (.*) https://www.reinvencionweb.com/$1/ [R=301,L,QSA]
    </IfModule>

    Cuando tengo este código en el htaccess, si quiero crear una nueva entrada o página, lo que hace al intentar «solo guardar» es ponerme como título «BORRADOR AUTOMÁTICO» y además me elimina cualquier contenido que hay puesto dentro.

    Necesito tener ese código por un tema de contenido duplicado.

    Muchas gracias por la ayuda

    • Este debate fue modificado hace 4 meses, 1 semana por  almendron.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 12 respuestas - 1 de 12 (de 12 total)
  • Moderador almendron

    (@almendron)

    El código es correcto. Ahora bien, no debería ser necesario.

    ¿Cómo tienes configurados los Enlaces Permanentes?

    Hola, los tengo configurados como nombre de la entrada.

    El tema es que si yo quito el código e introduzco una url de mi web sin la barra final me lo toma como válida con un status 200, en lugar de redirigirme hacia la url con la barra final.

    Gracias

    Moderador almendron

    (@almendron)

    En el .htaccess: ¿dónde has colocado el código? Prueba a ponerlo justo al principio, es decir, antes de las reglas de WordPress.

    pabloape5420

    (@pabloape5420)

    Hola.

    Sí lo tengo arriba de todo en el archivo, pero sigo teniendo el mismo problema.

    No sé por donde tocar ya.

    Gracias

    Moderador almendron

    (@almendron)

    A mi lo que me extraña es que no redireccione de forma automática, es decir, sin necesidad de código.

    ¿Se lo has comentado al soporte de tu hosting?

    Moderador almendron

    (@almendron)

    Me olvidaba: prueba a poner el código después de las líneas que añade WordPress.

    pabloape5420

    (@pabloape5420)

    Hola!

    Si pongo el código debajo del de WordPress no me hace la redirección.

    ¿Qué diferencia hay que lo haga el hosting o yo?

    Gracias

    pabloape5420

    (@pabloape5420)

    Además el problema es Gutenberg, porque si instalo el editor clásico funciona bien, pero me gustaría utilizar Gutenberg.

    Gracias

    Moderador almendron

    (@almendron)

    Lo comento con los compañeros y te decimos algo.

    pabloape5420

    (@pabloape5420)

    OK muchas gracias.

    pabloape5420

    (@pabloape5420)

    Hola, he encontrado el culpable: WP Rocket.

    Si lo desinstalo me redirecciona como debe. ¿Alguna idea de por qué hace eso?

    Gracias

    Moderador almendron

    (@almendron)

    Es un plugin comercial y por tanto no podemos hacer pruebas. Tendrás que ponerte en contacto con su desarrollador: https://wp-rocket.me/es/soporte/

Viendo 12 respuestas - 1 de 12 (de 12 total)
  • Debes estar registrado para responder a este tema.