Soporte » Guías – Resolución de problemas » Problema con la base de datos

  • Resuelto naachobermudez

    (@naachobermudez)


    Hola! Instale una versión nueva de appserv en mi pc, al instalar me hizo un backup de todos los datos anteriores. Cuando voy a iniciar mi web, dice que tengo que ingresar el titulo del sitio y el mail. Ingreso los datos y apreto en «Vamos a ello!», y ahi salta el error en la base de datos:

    Me dice que no existen, pero cuando entro a la carpeta DATA de mysql estan mis archivos con sus respectivos pesos. POR FAVOR AYUDA!

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Moderador almendron

    (@almendron)

    Es muy posible que al cambiar de versión también haya cambiado la versión de mysql y te haya creado dos carpetas. En wampserver, por ejemplo, hay una carpeta con su correspondiente DATA para cada versión. Tienes que comprobar que estás trabajando con la versión correcta.
    En cualquier caso, es más una pregunta para el soporte de appserv que para wordpress.

    Moderador erchache2000

    (@erchache2000)

    ¿Qué nueva versión de appserv? ¿XAMP sobre window$?

    Iniciador del debate naachobermudez

    (@naachobermudez)

    Hola gracias por la respuesta, necesito resolver este problema cuanto antes!!

    Yo estaba usando la versión 8.4 de appserve y ahora instale la 8.5. Cuando la instale me pidió hacer un backup de todos mis datos de la versión 8.4, le puse que sí. Puse los mismos datos de acceso que en la versión anterior pero cuando entre en phpmyadmin la tablas de mi base de datos me aparecen pero cuando entro en una especifica me dice que no existe… No entendí bien lo que me preguntaste erchache pero estoy usando Windows 10. Disculpen mi poco conocimiento en el tema, muchas gracias por su ayuda lo aprecio mucho!

    Moderador almendron

    (@almendron)

    Busca en el directorio de appserver la carpeta que aloja la base de datos.
    Una ruta ejemplo sería: directorio-instlacion\bin\mysql\mysql5.7.11\data y dentro una carpeta por cada base de datos.
    Comprueba si hay varias carpetas tipo «mysqXXXX» y si es así, asegúrate de que appserver está utilizando la versión correcta.

    Por otro lado, ¿tienes alguna copia de seguridad?

    Iniciador del debate naachobermudez

    (@naachobermudez)

    Si… tengo una copia de las carpetas «www» y «MySQL» de mi appserv 8.4, pero intenté pasar la carpeta DATA de mi copia de seguridad a la nueva carpeta DATA de la versión 8.5 y sigue sin funcionar!

    • Esta respuesta fue modificada hace 6 años, 3 meses por naachobermudez.
    Moderador almendron

    (@almendron)

    ¿hay una carpeta llamada «bin»? ¿qué carpetas hay dentro de ella?
    Y otra cosa: el programa que usas, ¿permite elegir entre distintas versiones de php, mysql o apaceh?

    Iniciador del debate naachobermudez

    (@naachobermudez)

    C:\AppServ\MySQL\bin dentro de esa carpeta hay como vos dijiste muchos archivos mysqlXXXX pero no se que hacer con ellos!

    En cuanto al programa no se bien a que te referis… Repito, disculpen por mi escaso conocimiento sobre el tema

    Moderador almendron

    (@almendron)

    De lo que se trata es de localizar la base de datos que tenías. Lo normal es que hay una carpeta con el nombre de la base de datos dentro de una carpeta llamada DATA. Dentro de la carpeta que tiene el nombre de la base de datos que usabas verás que hay archivos con extensiones myd, myi, fm, …
    Por ejemplo, en mi caso tengo
    C:\wamp64\bin\mysql\mysql5.5.50\data\microfono y dentro de microfono las tablas. Por ejemplo «wp_posts.frm»
    Ahí es donde quiero que entres a mirar y me digas la ruta hasta allí.

    Iniciador del debate naachobermudez

    (@naachobermudez)

    C:\AppServ\MySQL\data\pruebatienda y dentro de prueba tengo todas las tablas con sus pesos, que indican que algo tienen. El problema esta cuando entro a localhost/phpmyadmin que es donde estan las bases. Te paso una captura

    Fijate que aca aparece la tabla en la parte izquierda pero cuando hago click en ella me dice que no existe

    Y aca te paso la captura de mi carpeta C:\AppServ\MySQL\data\pruebatienda

    • Esta respuesta fue modificada hace 6 años, 3 meses por naachobermudez.
    • Esta respuesta fue modificada hace 6 años, 3 meses por naachobermudez.
    • Esta respuesta fue modificada hace 6 años, 3 meses por naachobermudez.
    Iniciador del debate naachobermudez

    (@naachobermudez)

    Aca esta la captura dentro de localhost/phpmyadmin

    Moderador almendron

    (@almendron)

    Mira en las opciones a ver si puedes elegir con qué versión de mysql quieres trabajar.
    En última instancia, haz una copia de C:\AppServ\MySQL\data\pruebatienda y prueba a reinstalar el programa.
    Y busca un foro para ese programa porque es posible que allí te puedan ayudar más.

    Iniciador del debate naachobermudez

    (@naachobermudez)

    Muchas gracias por tu tiempo Almendron!! Ojala encuentre la solución

    Moderador almendron

    (@almendron)

    De nada. lamento no haber podido ayudarte más. Espero que lo puedas resolver.

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • El debate ‘Problema con la base de datos’ está cerrado a nuevas respuestas.