Soporte » Guías – Resolución de problemas » Problema con la imagen con enlace al publicar en Facebook

  • Resuelto holatos

    (@holatos)


    Hola, tengo una página web que publico frecuentemente en Facebook, el problema es que hago artículos para mi blog y cada vez que publico en Facebook sale siempre una misma imagen aunque yo cada vez que hago un artículo nuevo le pongo una imagen distinta. Lo depuro en Facebook y esto es lo que me sale:

    <meta charset=»UTF-8″ />
    <meta name=»description» content=»🏡 Servicio integral de Mantenimiento y Limpieza en Valladolid» />
    <meta name=»robots» content=»index, follow» />
    <meta name=»googlebot» content=»index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1″ />
    <meta name=»bingbot» content=»index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1″ />
    <meta property=»og:locale» content=»es_ES» />
    <meta property=»og:type» content=»article» />
    <meta property=»og:title» content=»Mantenimiento de la Piscina» />
    <meta property=»og:description» content=»🏡 Servicio integral de Mantenimiento y Limpieza en Valladolid» />
    <meta property=»og:url» content=»https://www.jesusjyl.com/piscina/» />
    <meta property=»og:site_name» content=»Jesusjyl» />
    <meta property=»article:publisher» content=»https://www.facebook.com/Jes%c3%bas-Jardiner%c3%ada-y-Limpieza-Valladolid-102044901422788/» />
    <meta property=»article:published_time» content=»2020-07-19T09:54:15+00:00″ />
    <meta property=»article:modified_time» content=»2020-07-19T09:58:26+00:00″ />
    <meta property=»og:image» content=»https://www.jesusjyl.com/wp-content/uploads/2020/03/LOGOTIPO.png» />
    <meta name=»twitter:card» content=»summary_large_image» />
    <meta name=»generator» content=»WordPress 5.4.2″ />
    <meta name=»generator» content=»Site Kit by Google 1.12.0″ />
    <meta name=»viewport» content=»width=device-width, initial-scale=1″ />
    <meta name=»viewport» content=»width=device-width, initial-scale=1.0, viewport-fit=cover» />

    He probado a poner en Yoast Seo una imagen predeterminada para forzar que aparezca la nueva imagen pero nada. Si me podéis ayudar os lo agradecería

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Moderador almendron

    (@almendron)

    Ahora mismo, por ejemplo, usando el depurador de facebook para https://www.jesusjyl.com/organica/ aparece la imagen pero da un aviso

    La propiedad "og:image" de la URL https://www.jesusjyl.com/wp-content/uploads/2020/03/LOGOTIPO.png proporcionada no es válida porque no cumple con el tamaño mínimo de 200 x 200 píxeles.

    Y además un código de respuesta 206 en lugar de 200.

    haz lo siguiente:

    1) Lo primero de todo es quitar en Yoast Seo lo de la imagen predeterminada.

    2) Una vez lo hayas hecho, me lo dices y echamos un vistazo al depurador a ver que sale.

    Hola @almendron , acabo de quitar en el Plugin Yoast Seo la imagen predeterminada y la imagen de la organización también. Espero su respuesta y gracias de antemano.

    Moderador almendron

    (@almendron)

    Revisa bien la configuración del plugin porque sigue saliendo

    <meta property="og:image" content="https://www.jesusjyl.com/wp-content/uploads/2020/03/LOGOTIPO.png" />

    Aún así, en el depurador de Facebook sí aparece la imagen correcta aunque da un código 206 en lugar de 200.

    Una duda. En tus páginas y entradas: ¿está establecida una imagen destacada en cada una de ellas?

    holatos

    (@holatos)

    Hay una imagen en cada entrada, pero no se si está destacada.

    holatos

    (@holatos)

    He puesto la imagen destacada en la entrada desde editar la entrada y de momento si que me ha puesto la imagen y no el logo que es lo que me ponía antes. Gracias por la ayuda!

    Moderador almendron

    (@almendron)

    Lo sigues teniendo mal. En el código fuente sigue apareciendo:

    <meta property="og:image" content="https://www.jesusjyl.com/wp-content/uploads/2020/03/LOGOTIPO.png" />

    Y no te la coge porque no cumple con el tamaño mínimo de 200 x 200 píxeles.

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.