Soporte » Multisitio » Problema con las URL luego de habilitar Multisitio

  • Resuelto j_cano

    (@j_cano)


    Hola;

    Hace un par de días he decidido habilitar la función de «Multisitio» con la ayuda de este video-tutorial: https://www.youtube.com/watch?v=0iI5qC7l0Sk

    La razón por la cual decidí hacerlo es porque tengo una plantilla que funciona como una plataforma musical y quería instalar en el subdirectorio /store/ un nuevo WordPress y en este una plantilla amigable con WooCommerce.

    Pensé que todo había quedado perfecto hasta que hoy me di cuenta de lo siguiente:

    1- En «Permalink Settings» ahora todas las entradas de blog tienen la siguiente estructura /blog/2017/10/09/sample-post/, cuando antes era solo /sample-post/

    2- Cuando intento cambiar desde Settings > Permalinks de «Day and name» a » Post name» simplemente no pasa nada después de que presiono el botón de Guardar los cambios.

    3- No se de donde ha salido la estructura /blog/ y quiero que desaparezca porque esta afectando todas las URL de mis posts y categorías.

    A continuación muestro los archivos editados para obtener la función de Multisitio:

    wp-config.php

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.techno-livesets.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    

    Agradezco cualquier ayuda que me puedan brindar.

    Saludos

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Hola,

    sin entrar al detalle de tu caso, que no tengo mucho tiempo ahora, el /blog/ es obligatorio , lo pone automáticamente aunque sólo en el sitio 1 o principal.

    Pero hay un truco que he usado decenas de veces para arreglarlo, porque a mí tampoco me gusta ese slug, a veces no es blog y es noticias, por ejemplo.

    En primer lugar desde la configuración de sitios del panel del multisitio (no de cada sitio individual), edita el sitio principal, entra en ajustes… y ahí buscas el /blog/ en la opción Permalink structure y le pones el que quieres, por ejemplo /%postname%/ , y le das a guardar.

    Y luego entra en el dashboard del sitio 1, el principal… y vas a Ajustes –> Enlaces permanentes y, MUY IMPORTANTE, no guardes ni hagas nada… sólo hay que visitar esa web, no hacer nada más. Si le das a guardar te vuelve a poner en teoría el /blog/ otra vez.

    Si te sigue fallando ya es un tema del .htaccess .

    Iniciador del debate j_cano

    (@j_cano)

    Hola javiguembe;

    Antes que nada muchísimas gracias me ha servido bastante, en un principio hice todo como me indicaste:

    1- Visité desde el Network Admin la sección de sitios así:
    Network admin > Sitios > y luego seleccioné la opción «Editar» del sitio principal que es el que tenía la estructura /blog/

    2- Hice clic en la tab «settings» y allí ubiqué la estructura /blog/%postname%/

    3- Eliminé /blog y presioné guardar

    4- Regresé al administrador del sitio principal > Settings > Permalinks y me di cuenta que en efecto había desaparecido la estructura /blog/ y la opción que aparecía seleccionada era «Post name»

    5- No hice nada, no presione el botón Guardar tal como dijiste pero al navegar y revisar las URL de las entradas y categorías del sitio todas daban Error 404.

    6- Fue así que regrese al admin del sitio principal > Settings > Permalinks y seleccioné la opción «Custom Structure» la cual no cambió luego de presionar el botón guardar ya que esta regreso a «Post name» pero al navegar las entradas y las categorías del sitio todo estaba funcionando perfecto no había rastro de la estructura /blog/ y las URL ya no daban Errores 404.

    Muchas gracias Javi!

    Me alegro… marca como solucionado! 🙂

    Iniciador del debate j_cano

    (@j_cano)

    Muchas gracias Javi

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • El debate ‘Problema con las URL luego de habilitar Multisitio’ está cerrado a nuevas respuestas.