Soporte » Guías – Resolución de problemas » problema con las urls en localhost

  • Resuelto fredericcreusot

    (@fredericcreusot)


    Hola todos,
    primero decir que soy principiante, llevo 2 meses con wordpress, antes mi pagina la había hecho con html y css. El problema es el siguiente:

    desde que intente subir la pagina al servidor ayer, en localhost no funciona bien.
    Veo mi home perfectamente pero cuando le doy a algún enlace del menú, me aparece una página blanca con datos de wamp (tengo una captura de pantalla, no sé como adjuntarla aquí)
    debe de ayer todo iba perfecto en localhost, no he tocado más que la base de datos para subir al servidor (su nombre y la url y la home de wp-options) pero al desistir (había muchos errores en la web visto en el servidor), he vuelto a poner todo como estaba 8por lo menos creo), pero algo debe estar mal, quizás el .htaccess? no tengo ides de lo que pone dentro

Viendo 15 respuestas - 16 de 30 (de 41 total)
  • fredericcreusot

    (@fredericcreusot)

    las imágenes van subiendo, la pagina parece tener buena pinta.
    en el final del proceso al dar a show report, me pone con lo de los errores ese informe
    Queries that error during the deploy step are logged to the install-log.txt file and marked ‘**ERROR**’.

    Common Fixes:
    Query size limits: Update your MySQL server with the max_allowed_packet setting to handle larger payloads.
    Unknown collation: The MySQL Version is too old see: What is Compatibility mode & ‘Unknown collation’ errors?

    que puede ser’ es grave?

    Moderador almendron

    (@almendron)

    La verdad es que no deberían salir esos errores.
    ¿qué versiones de PHP y MySQL tienes en el servidor?
    https://wordpress.org/about/requirements/

    Es posible que en wampserver estuvieras trabajando con versiones de PHP y MySql muy distintas a las que tienes instaladas en el servidor.

    De todas formas, le he echado un vistazo a la página y parece que ha ido todo bien.

    fredericcreusot

    (@fredericcreusot)

    por lo demás, parece que todo funciona. mañana le doy la vuelata a todo, hay que hacer ajustes para la versión mivil, y modulos como el formulario que no va.

    muchas gracias por tu ayuda. estoy muy agradecido. esta mañana pensaba que no lo lograría.

    Moderador almendron

    (@almendron)

    De nada, pero… ¿has mirado lo de las versiones?

    fredericcreusot

    (@fredericcreusot)

    ahora lo miro…
    Lo que veo repasando todo, es que no me ha subido las redirecciones 301. tenía todo preparado con el plugin redirection, pero en linea veo que este está vacio, no esta el grupo de redirecciones

    fredericcreusot

    (@fredericcreusot)

    en cuanto a lo de las versiones
    versión PHP (5.3.3)
    MySQL Versión 5.5.52

    fredericcreusot

    (@fredericcreusot)

    lo de las redirecciones es raro , pues no llego a un error 301 cuando busco las paginas de antes por google, sino a mi web actual poniendo (en aparencia) con la url antigua y poniendo el mensaje
    No se encontraron resultados
    La página solicitada no pudo encontrarse. Trate de perfeccionar su búsqueda o utilice la navegación para localizar la entrada

    raro no?

    Moderador almendron

    (@almendron)

    Desde wordpress aconsejan versiones superiores a las que tú tienes: https://wordpress.org/about/requirements/

    Deberías ponerte en contacto en tu hosting para que te actualizaran tanto PHP como MySQL.
    En cuanto a las redirecciones, no se como funciona el plugin. Prueba a desactivar, borrar y luego volver a instalar el plugin.

    fredericcreusot

    (@fredericcreusot)

    veo que tengo en el servidor un .htaccess y un .htaccess.orig ,no sé si es normal, no dedería haber solo uno?
    es que al leer este ticket, que algo me sonaba que me dijiste anoche de los plugins, me doy cuenta que no he hecho lo que dijiste al subir la pagina con duplicator…de desactivar los lugins, para activarlos una vez subida la página…
    he desactivado y vuelto a activar ahora a ver que pasa. (no parece que cambia nada, sigue sin redireccionar pero tampoco pone error. solo que estas en la pagina y te pide buscar…
    mes dices de borrar? y volver a configurar las 122 redirecciones???? en localhost, veo en el plugin que está mi lista de redirecciones, no sé si podría subir un archivo, pero no sé cual, o todos los archivos de ese plugins?

    Moderador almendron

    (@almendron)

    Tendrías un htaccess que ha sido sustituido por uno nuevo. Por eso te aparece uno pero renombrado.
    Lo primero de todo, entra en Ajustes > enlaces permanentes y dale a guardar.
    Plugin redirecciones: ¿modifica este plugin el htaccess y pone aquí la redirecciones? Si es así, ni siquiera necesitas el plugin. Copia del htaccess la lista de redicciones y luego la copias en el htaccess del servidor (antes haz una copia).
    Lo normal es que esa lista esté en .htaccess.orig: bajatelo al ordenador y editalo con notepad.

    Será algo así como

    ######INICIO CONFIGURACION REDIRECCIONES######
    Redirect 301 /xxxxx/xxxx/ http://www.xxxxx.com/xxxxxx/
    Redirect 301 ....
    ......
    ######FIN DE CONFIGURACION REDIRECCIONES######
    fredericcreusot

    (@fredericcreusot)

    tendré que quitar uno (parece identicos por el contenido) es mejor quitar el htaccess.orig no?

    el plugin no pone las redirecciones en el access, por lo que veo y ví hace dias tambien en localhost, mira el codigo:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    En mi otra pagina web, habia hecho las redirecciones a mano pero como ahora eran muchas y no estaba seguro, he usado ese plugin, puedo volver a hacer todo a mano y pasar del plugin, pero entonces para que sirve el plugin? y ahora estoy por todos lados corrigiendo lo que falla

    Moderador almendron

    (@almendron)

    Puedes quitar sin problemas htaccess.orig
    ¿Has mirado el htaccess de local?

    El plugin viene bien por si no sabes o no quieres tocar el hataccess

    • Esta respuesta fue modificada hace 1 año por  almendron.
    • Esta respuesta fue modificada hace 1 año por  almendron.
    fredericcreusot

    (@fredericcreusot)

    en local, pone esto:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /casasierrasalamanca/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /casasierrasalamanca/index.php [L]
    </IfModule>

    # END WordPress

    o sea, igual
    de momento, como no lleva a error, voy a dejarlo asi y cuando tenga un rato, haré las redirecciones a mano en el htaccess. creo que mientras no haya error, google no me castigará

    fredericcreusot

    (@fredericcreusot)

    ah otra duda? estoy en 10 cosas a la vez,,,los plugins como duplicator, ahora los puedo desactivar no? tengo unos cuantos como unos para importar blogger que ahoora que esta hecho, los puedo desactivar, incluso borrar (no sé si consume recursos tenerlos para nada)

    Moderador almendron

    (@almendron)

    Sí, claro. Desactiva los que puedas utilizar en el futuro y elimina los que ya no vayas a usar.

Viendo 15 respuestas - 16 de 30 (de 41 total)
  • El debate ‘problema con las urls en localhost’ está cerrado a nuevas respuestas.