Soporte » Guías – Resolución de problemas » Problema con load css

  • Buenas,

    Seguimos con un problema en wordpress que no nos deja modificar el estilo de los posts ni de las páginas.

    Nos aparece este error en la consola de javascript:
    Uncaught SyntaxError: Invalid or unexpected token
    http://blog.chelagarto.com/wp-admin/load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,underscore,wp-util,wp-a11y,updates,jquery-ui-core,thickbox,plugin-install,svg-painter,heartbeat,wp-&load%5B%5D=auth-check,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable,jquery-ui-slider,jquery-touch-punch,iris,wp-color-picker,jquery-&load%5B%5D=ui-sortable,shortcode,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-request,media-views,media-editor,medi&load%5B%5D=a-audiovideo,mce-view,imgareaselect,image-edit&ver=4.9.1 line 693

    El código, que estaría con problema es este:

    <?php

    /**
    * Disable error reporting
    *
    * Set this to error_reporting( -1 ) for debugging.
    */
    error_reporting(0);

    /** Set ABSPATH for execution */
    if ( ! defined( ‘ABSPATH’ ) ) {
    define( ‘ABSPATH’, dirname( dirname( __FILE__ ) ) . ‘/’ );
    }

    define( ‘WPINC’, ‘wp-includes’ );

    $load = $_GET[‘load’];
    if ( is_array( $load ) )
    $load = implode( », $load );

    $load = preg_replace( ‘/[^a-z0-9,_-]+/i’, », $load );
    $load = array_unique( explode( ‘,’, $load ) );

    if ( empty($load) )
    exit;

    require( ABSPATH . ‘wp-admin/includes/noop.php’ );
    require( ABSPATH . WPINC . ‘/script-loader.php’ );
    require( ABSPATH . WPINC . ‘/version.php’ );

    $compress = ( isset($_GET[‘c’]) && $_GET[‘c’] );
    $force_gzip = ( $compress && ‘gzip’ == $_GET[‘c’] );
    $expires_offset = 31536000; // 1 year
    $out = »;

    $wp_scripts = new WP_Scripts();
    wp_default_scripts($wp_scripts);

    if ( isset( $_SERVER[‘HTTP_IF_NONE_MATCH’] ) && stripslashes( $_SERVER[‘HTTP_IF_NONE_MATCH’] ) === $wp_version ) {
    $protocol = $_SERVER[‘SERVER_PROTOCOL’];
    if ( ! in_array( $protocol, array( ‘HTTP/1.1’, ‘HTTP/2’, ‘HTTP/2.0’ ) ) ) {
    $protocol = ‘HTTP/1.0’;
    }
    header( «$protocol 304 Not Modified» );
    exit();
    }

    foreach ( $load as $handle ) {
    if ( !array_key_exists($handle, $wp_scripts->registered) )
    continue;

    $path = ABSPATH . $wp_scripts->registered[$handle]->src;
    $out .= get_file($path) . «\n»;
    }

    header(«Etag: $wp_version»);
    header(‘Content-Type: application/javascript; charset=UTF-8’);
    header(‘Expires: ‘ . gmdate( «D, d M Y H:i:s», time() + $expires_offset ) . ‘ GMT’);
    header(«Cache-Control: public, max-age=$expires_offset»);

    if ( $compress && ! ini_get(‘zlib.output_compression’) && ‘ob_gzhandler’ != ini_get(‘output_handler’) && isset($_SERVER[‘HTTP_ACCEPT_ENCODING’]) ) {
    header(‘Vary: Accept-Encoding’); // Handle proxies
    if ( false !== stripos($_SERVER[‘HTTP_ACCEPT_ENCODING’], ‘deflate’) && function_exists(‘gzdeflate’) && ! $force_gzip ) {
    header(‘Content-Encoding: deflate’);
    $out = gzdeflate( $out, 3 );
    } elseif ( false !== stripos($_SERVER[‘HTTP_ACCEPT_ENCODING’], ‘gzip’) && function_exists(‘gzencode’) ) {
    header(‘Content-Encoding: gzip’);
    $out = gzencode( $out, 3 );
    }
    }

    echo $out;
    exit;

    Pero no logró encontrar el error.

    Saludos y gracias

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 2 respuestas - de la 1 a la 2 (de un total de 2)
Viendo 2 respuestas - de la 1 a la 2 (de un total de 2)
  • El debate ‘Problema con load css’ está cerrado a nuevas respuestas.