Soporte » Diseño – Temas y plantillas » Problema con slider GRIDLOCKED theme -Themeforest

  • Resuelto daniel002

    (@daniel002)


    Hola como dice el titulo tengo un problema con el slider de Gridlocked theme cuando la plantilla ‘galeria’ en las entradas, me explico:

    -Al crear el post y poner ‘galeria’ en la pestaña de formatos de post no me aparece el slider dentro del post (sólo aparecen los puntitos de seleccion); sin embargo si aparece el slider en thumbnail en la seccion del blog. A alguien le a pasado esto tambien??? Me falta activa algo???

Viendo 15 respuestas - de la 1 a la 15 (de un total de 25)
  • Hola,
    No se si habrás resuelto tus problemas, pero no se la respuesta al tuyo. Escribo medio desesperado a ver si sabes (o alguien más que pueda ayudarnos) como resolver el mío:

    Cuando creo un nuevo post del portafolio elijo una imagen destacada. Después coloco la primera imagen del proyecto y todo funciona bien. En el momento que coloco la segunda, al acceder a ese proyecto del portfolio las imágenes se ocultan (es como si se quedarán detrás del texto) y solo me muestra los puntos de imágenes grises…

    He probado todo tipo de tamaños. Se que estoy haciéndolo bien en lo que se refiere a tamaños. Indico el width de la primera imagen. Todo eso está bien, pero es como que me falta algo en el slider para que funcione correctamente… alguien que me pueda ayudar? quizá daniel002 ya lo has conseguido resolver?

    Gracias!

    Hola alantxo, pues si resolvi el problema con los sliders; el asunto era que habia un conflicto con algunos atributos css del slider, me costo un poco encontrar el error pero al final lo pude hacer.

    Ok, creo entender tu problema. Los portafolios del gridlocked estan por default preparados para presentar las imagenes a modo de slider por lo que no puedes ingresar imagenes una a una; la pregunta que te planteo para poder ayudarte es la siguiente: Tu quieres mostrar las imagenes dentro del slider o mostrar una detras de otra sin slider, osea desabilitar el slider???

    Hola daniel,

    Gracias por tu respuesta.

    A mi lo que me gustaría es que funcione como en el demo de Themezilla:
    http://demo.themezilla.com/?theme=gridlocked&ref=tf
    Es decir, que pueda mostrar más de una imagen encima del texto.

    Yo, por mi parte, no estoy teniendo ningún problema en subir una imagen de mis proyectos, como puedes ver en este enlace: http://alancarrasco.com/sp/portfolio/plusvalia-cero/

    Pero la cosa cambia cuando agrego una imagen más, pues desaparecen ambas:
    http://alancarrasco.com/sp/portfolio/mi-primer-millon-de-dolares-2/

    Como puedes ver, ambas imágenes están (se ven al cargar la página como un flashazo), pero parece que quedan detrás. Incluso aparecen los dos puntos grises indicando que están ahí, aunque no se muestran.

    Básicamente este es mi problema. Si me puedes echar una mano no sabes el favor que me harás! Saludos!

    Hola Alantxo,
    Que no se vean las imágenes creo que es un problema de estilos.
    Los div que contienen las imágenes y que están dentro del <div class=»slides_control»> tienen position: absolute. Si lo cambias a relative las imágenes se muestran.

    Un saludo

    Hola Alantxo, te iba a contestar ayer pero por el trabajo se me pasó…el asunto es el siguente:

    1. Para poder usar los sliders del portafolio tienes que subir las imagenes todas juntas, es decir en galeria, no una por una. Osea cuando pongas agregar imagenes y se te abra la carpeta contenedora en tu ordenador seleccionas todas las imagenes de una vez; cuando quieras hacer cambios entras como si quisieras agregar una nueva imagen y te vas a galerias.

    2. Es cierto lo que dice olb, quizas no te aparezcan los sliders (a mi me aparecían sólo los puntitos tambien); ahora en este punto lo que yo hice fue esto:

    .format-gallery .slides_container {width: 360px; height: 270px;}
    .format-gallery .slider {width: 360px; height: 270px;}

    3. Ahora al ponerle height con medida en px al div de los sliders todos tendran la misma altura (en el demo creo que se redimensionan), a mi me interesaba eso pero no se a ti; tambien prueba lo de ponerlo en relative como dice olb a ver que pasa 😉

    Yo encontre la solucion probando con el firebug y haciendo los cambios directamente en el navegador, estas haciendo eso?? Cualquier cosa escribes y nos cuentas, nos vemos!

    Olb y Daniel: muchísimas gracias por vuestra ayuda. He conseguido que las imágenes se vean al fin. Ahora estoy preocupado por una menudencia (el triangulito de la esquina inferior derecha de las imágenes queda un poco desplazada hacía arriba) pero lo importante lo he logrado: http://alancarrasco.com/sp/portfolio/primer-millon-de-dolares/

    Si sabéis darme pistas sobre ese problema ya si, os invito a una caña virtual!
    Muchas gracias de nuevo, no habría sabido encontrar el problema yo sólo.

    Abrazos

    creo que aquí se ve mejor: http://alancarrasco.com/sp/portfolio/nacion/

    Hola Alantxo, de nada…en cuanto a los triangulitos lo puedes quitar o mover simplemente entrando a los estilos (hasta donde recuerdo tienen posicion absoluta) yo los quite directamente porque no me gustaban; tienes que buscarlos (es el <div class=»arrow»></div>) y borrarlos o comentarlos.

    Cualquier cosa escribes!

    Hola Alantxo, yo lo que hice fue sustituir los png de las flechitas por uno vacio, soy mejor con Photoshop que con el css me temo.

    Respecto al problema de las imágenes que no se muestran cuando hay varias en la galería a mi me pasa lo mismo, como dice daniel si pones una medida en px el problema se soluciona pero a mi particularmente me interesa mucho que la altura se modifique de modo automático dependiendo del tamaño de la ilustraciones. La solución de olb no la entiendo muy bien, soy dibujante y mis conocimientos de css son pocos tirando a ninguno, pero si me he fijado que el parámetro auto

    .format-gallery .slides_container {
    /*ESTO ES LO QUE DEFINE LA ALTURA DE LA GALERIA*/
    width: 650px;
    height: auto;

    funciona cuando tienes una sola imagen pero las hace desaparecer cuando tienes más de una. Si alguien me puede ayudar estaría muy agradecido.

    Gracias.

    http://www.gatopardo.es/wprs

    Hola, estoy completamente desesperado. He probado a hacer todo lo que se ha dicho en este post y no consigo subir varias imagenes en la plantilla de portfolio. He probado subiéndolas todas a la vez como se indicaba pero nada.

    Cuando sólo subo una si que funciona, pero a la hora de subir otras me desaparecen todas ellas y no hay manera de saber donde se encuentran. Y es muy extraño porque el tema está configurado para que se suban hasta 5 imágenes distintas por trabajo…

    Por favor si pudierais echarme una mano os lo agradecería enormemente

    Hola alvaritoxx, para subir imagenes al portafolio tienes que hacerlo en bloque, es decir coger todas las imagenes al mismo tiempo; pon la url para revisar que esta pasando, nos vemos!

    Hola daniel002. Yo tengo el mismo problema con el slider, solo se ven los puntitos. ¿En qué archivo debo agregar .format-gallery .slides_container (…) ? Soy nuevo en esto pero me doy maña. No logro encontrar el archivo donde agregar lo que mencionas. Acá? ./js/slides.min.jquery.js?

    Gracias!

    Alvaritoxx y pol_,

    probad a incluir esta regla en vuestro archivo css

    .slides_control div {
    	position: relative !important;
    }

    De todas formas, si facilitáis una url como dice daniel002, mejor

    Hola, por lo visto una actualización de js hizo que Gridlocked dejase de funcionar debidamente. La solución es conseguir una versión actualizada de Gridlocked. Yo he instalado la versión 1.3.6 y se arreglaron todos los problemas.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 25)
  • El debate ‘Problema con slider GRIDLOCKED theme -Themeforest’ está cerrado a nuevas respuestas.