Soporte » Diseño – Temas y plantillas » Problema con Testimonios ERROR 404

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • Moderador erchache2000

    (@erchache2000)

    Parece que usas un plugin para gestionar los testimonio, con lo que crea un tipo de post especial que los enlaces permanentes no es capaz de procesar.

    Los enlaces permanentes normalmente funcionan con tags o con categorías, no con tipos personalizados.

    ¿Por que no le asignas una categoría y lo ordenas por categoría?

    Hola, gracias por contestar voy a probar

    Moderador LGrusin

    (@lgrusin)

    Por cierto @neorevolutions prueba vaciar la caché, sobre todo si has estado haciendo cambios.

    Un saludo

    Hola, he creado

    https://clinicasanroman.com/?testimonials-category=testimonios-internacional

    Los Testimonios les he puesto categoría Testimonios Internacional y me sigue pasando lo mismo, he limpiado la cache.

    Entiendo que habría que asignar una categoría como cuando se crea una entrada pero no se como, o que hacer

    Moderador LGrusin

    (@lgrusin)

    El plugin para crear el Custom Post Type llamado Testimonials no crea el permalink de los testimonios, cosa que no entiendo por qué el autor lo hizo así. Es decir, «clinicasanroman.com/?post_type=testimonials» debería ser «clinicasanroman.com/testimonials».

    De todas formas debería funcionar sin permalink, igual hay algún plugin que interfiere con las URLs. Podrías hacer esa prueba, quitar el permalink a ver si hay alguna diferencia.

    Lo de los idiomas, ¿usas algún plugin?

    Un saludo

    • Esta respuesta fue modificada hace 2 años, 2 meses por  LGrusin.

    Hola, sí el plugin idioma es Polylang en su última versión 2.1.6

    a mi también se me hace raro

    Moderador LGrusin

    (@lgrusin)

    Busca entre las opciones de Polylang si existe alguna que impida el uso en Custom Post Types. Es decir, no tienes permalink en Testimonials y además no creo que te interese tenerlos en varios idiomas, mejor es que impidas que Polylang actúe sobre la URL del custom post type.

    A último remedio desactiva Polylang para probar si es el responsable de que no te funcione con Testimonials.

    Por cierto, recuerda ir a Ajustes – Permalink y actualizalo para que WordPress se entere de que has hecho cambios.

    Un saludo

    • Esta respuesta fue modificada hace 2 años, 2 meses por  LGrusin.
Viendo 7 respuestas - 1 de 7 (de 7 total)
  • El debate ‘Problema con Testimonios ERROR 404’ está cerrado a nuevas respuestas.