Soporte » Instalación – Actualizaciones » Problema de contenido Mixto paginas no seguras

  • Resuelto richardruben33

    (@richardruben33)


    Buenas tardes

    Actualmente tengo el certificado SSL estandar de Godaddy en el sitio Web que estoy desarrollando (flowersgaleria.com) con WordPress usando Elementor. Sin embargo, en algunas paginas de mi sitio sigue estando inseguras. Use http://www.whynopadlock.com para hacer un Test y me indica que hay una imagen con contenido mixto. Esa imagen venia con la plantilla que seleccione para desarrollar mi sitio web pero realmente no la estoy usando en mi sitio web e incluso la borre usando CPanel y el Manejador de Archivos. Pero el problema persiste.

    Le agradeceria mucho su apoyo para resolver tal situacion.

    Saludos cordiales.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    El problema es que borraste la imagen pero no la llamada. El contenido no es inseguro de por sí, es la forma en que lo utilizas lo que lo hace inseguro. Si te da un error es porque usas la imagen, aunque no te des cuenta, de hecho si miras con el inspector de elementos verás que ahora tienes un error 404 justamente por la imagen que borraste.

    Tienes que buscar en el código dónde se usa la imagen y eliminarla allí, puede ser en un widget, otra solución es usar un plugin como Better Search Replace para buscar en la base de datos dónde está la llamada y reemplazarla.

    Tendrías que buscar:
    http://www.flowersgaleria.com/wp-content/uploads/2019/09/plant1-free-img.png
    y reemplazarlo por
    https://www.flowersgaleria.com/wp-content/uploads/2019/09/plant1-free-img.png

    De hecho podrías reemplazar

    http://www.flowersgaleria.com/
    por
    https://www.flowersgaleria.com/

    porque si ves el código fuente de la página verás que tiene 24 llamadas a http.

    Recuerda que antes de tocar la base de datos es conveniente hacer una copia de seguridad, por si surge algún problema. De todas formas, el error 404 que te genera la web se mantendrá porque borraste la imagen, deberías restaurarla a menos que elimines el código.

    Si con estas indicaciones solucionas el problema, por favor, háznoslo saber y recuerda cerrar el debate marcándolo como resuelto cuando así sea, de esta forma nos ayudas a mentener el foro al día.

    Moderador Jose Luis

    (@jose64)

    Hola

    Revisa este debate, está relacionado con lo que tu problema:

    Elementor y HTTPS

    usando el plugin Better Search Replace te ahorras instalar los que fuerzan a SSL, aparte de que después de hacer los cambios puedes desinstalarlo y borrarlo, pero es otra opción, aunque según el test que comentas ya está forzado a HTTPS por el servidor (aunque por lo visto falló).

    Buenas tardes @jose64

    Gracias por responder.

    Volvi a cargar la imagen que esta causando el problema en su carpeta original.

    Descargue y active el Plugin *Better Search Replace*. en simulacro, encontro mas de 200 celdas con http. Procedi a realizar la corrida para reemplazar, teoricamente hizo todos los reemplazos de las celdas con http para https; sin embargo, el problema aun persite con:
    http://www.flowersgaleria.com/wp-content/uploads/2019/09/plant1-free-img.png

    te agradeceria mucho la ayuda al respecto

    buenas tardes

    pude resolver utilizando las intrucciones siguientes:

    saludos

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.