Soporte » Guías – Resolución de problemas » Problema desconocido

  • Hola, amigos.

    Estoy trabajando en el proyecto swingersdevenezuela.com

    Y desde unas semanas para acá cuando ingreso a la página principal lo que se observa es sólo códigos, letras, símbolos… parece basura…

    He optimizado bases de datos, revisado con wordfence, revisado con antivirus, limpiado el caché… ¡pero nada!

    No sé por qué este error… es sólo con la página principal… el resto de páginas sí se ven…

    ¿Qué me recomiendan?

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • Moderador josearcos

    (@josearcos)

    Veo que es en la página «Nosotros» dónde aparece eso, te recomiendo que crees una nueva página con otra ruta.

    Gracias, josearcos, por responder!

    Pero ese es el problema… a veces es en inicio, a veces en nosotros, a veces en contacto…

    de verdad que ya ando loco con este error…

    ¿será el servidor?

    Moderador josearcos

    (@josearcos)

    Activa el Debug de WordPress y pega aquí si tienes algún error.
    https://codex.wordpress.org/es:Depurar_en_WordPress

    Ehmmm…

    ¿podrías indicarme cómo hago eso?

    No soy muy ducho con códigos y programación…

    Moderador josearcos

    (@josearcos)

    Viene en la guía, modifica el archivo wp-config.php de tu WordPress, lo encontrarás en la raíz donde lo instalaste, puedes acceder a él mediante FTP o si tu servidor tiene alguna herramienta de administración de archivos.
    Luego copia estas líneas:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Se creará un archivo en wp-content/log con el log de errores, búscalo y copia aquí los errores.

    Ok!!!

    voy a probar y te informo!

    Gracias por tu paciencia!

    Hola, josearcos, hice todo lo que me indicaste:

    1)bajé el archivo wp-config.php
    2)le agregué esas líneas de código sin modificar nada más
    3)subí el archivo modificado al servidor (me preguntó si sobreescribía, le dije que sí)

    Pero no observo que se haya generado ese archivo de log en la carpeta wp-content

    ¿el DEBUG_DISPLAY debe estar en false o true? (yo copié todo tal cual)

    ¿o es que ese archivo log tarda en generarse?

    ¿o es que el problema en mi web se solucionó solo? jajajaja

    No sé…

    ¿Qué hago ahora? Y de verdad, perdona tantas molestias…

    Moderador josearcos

    (@josearcos)

    El archivo del log esté en la carpeta wp-content/
    En el caso de que actives DEBUG_DISPLAY, es decir que pongas «true» después de la coma, aparecerán los errores en tu página.

    Hola, josearcos. Disculpa que no respondiera antes, pero se atravesaron los días de fiesta…

    y los errores volvieron… habían dejado de aparecer…

    tengo todos los parámetros del DEBUG en TRUE, pero no veo ningún archivo de logs en la carpeta que me indicas.

    Pero en el directorio raíz sí hay una carpeta llamada logs, que contiene un archivo comprimido con el nombre de la web y el mes de diciembre. ¿es ese?

    lo bajé de mi servidor, lo descomprimí y es un archivo .txt larguísimo…

    ¿es ese?

    espero tus instrucciones… feliz navidad y feliz año! 🙂

    Hola de nuevo!

    veo que en el tope de la página me aparecen dos líneas de errores con esto:

    Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /home/swingers/public_html/wp-includes/functions.php on line 3787

    Notice: bp_setup_current_user was called incorrectly. El usuario actual se está iniciando sin usar $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 1.7.) in /home/swingers/public_html/wp-includes/functions.php on line 3787

    ¿qué hago ahora?

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • El debate ‘Problema desconocido’ está cerrado a nuevas respuestas.