Soporte » Plugins y Hacks » WooCommerce » Problema en «FINALIZAR COMPRA» de mi sitio

  • Hola que tal, necesito de su gran ayuda porfavor, en mi sitio no he podido lograr comprar, se supone que ya puse toda la información de la tarjeta de crédito y paypal para que se pueda hacer la compra y me sale el mensaje «No hemos podido procesar tu pedido, por favor inténtalo de nuevo.»

    Ya intenté desactivando todos los plugins relacionados con woocommerce, pero nada.
    Le urge mucho a mi cliente tener listo el sitio, necesito de su gran ayuda, muchas gracias de antemano. Les puse el enlace abajo…

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Hola @3lackpencil

    Habilita el WP_DEBUG en el fichero wp-config.php para ver exactamente el error que da al intentar procesar el pedido.

    Sin esa información es muy difícil saber que pasa exactamente. Puede ser un error de configuración o del servidor.

    Salut!

    hola, soy principiante, no sé como hacer eso, ¿me puedes auxiliar por favor?

    ¿Dónde se encuentra el fichero y como te lo comparto para que me ayudes a revisar el error?

    gracias!

    Hola @3lackpencil

    El fichero wp-config.php está en la raiz de tu sitio. Deberías acceder desde FTP o admisnitrador de archivos de tu servidor. Ya verás que en el dichero hay un sitio que pone:
    define( 'WP_DEBUG', false );

    Deberás cambiarlo para que ponga
    define( 'WP_DEBUG', true );

    Salut!

    ah ya recordé, si, entro a mi cpanel y allí hago el cambio.

    Una vez que ya lo haya modificado, que procede? con eso ya funcionaria la tienda para comprar?

    quedo atento. gracias!

    Con eso en el proceso de compra te deberá salir un error más indicativo que lo que indicas:
    «No hemos podido procesar tu pedido, por favor inténtalo de nuevo.»

    Igualmente en la web veo que tiene problemas al añadir al carro mediante AJAX y seguramente vengan por ahí los errores. Da un error 301 al intentar enviar al carro.

    Mi recomendación es que contactes con algún programador para que revise tu caso en particular, ya que parece que el servidor o el woocommerce no lo tienes bien configurado.

    Si no, empieza de 0 activando solo el WooCommerce y probando el método de transferencia bancaria (que es lo mínimo). Además ponte en contacto con el soporte el hosting por si pueden mirar lo del error 301 en el add_to_cart

    Si, eso haré, contactaré al soporte de mi hosting y sigo pendiente en escribir aquí cual fue la solución, te agradezco bastante.

    Gracias.

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.