Soporte » Guías – Resolución de problemas » Problema en la generacion de mis URL Google indexa etiqueta post-

  • Buen dia equipo de WordPress tengo un grave problema con la indexacion de mi sitio y no encuentro respuesta despues de horas de buscar en los foros.

    Actualmente tengo el plugin redirections pero al momento de ver el registro me muestra que un bot de google manda un error 404, observando y analizando el problema, por alguna razon se esta generando de forma automatica al final de la URL la etiqueta post-14790 y asi sucesivamente con cada nota nueva que genero y desde que tengo ese problema mi trafico ha caido dramaticamente, ya actualice los permalinks y el problema persiste en cada nota nueva que creo en el wordpress.

    Agracedere cualquier tipo de ayuda.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Moderador almendron

    (@almendron)

    Lo más normal sería que la generación de esa parte final en las entradas se debiera a algún plugin. Yo haría lo siguiente:

    1) Accede vía FTP, haz una copia del archivo htaccess en tu ordenador y luego lo borras del servidor (para regenerar este archivo después de las pruebas basta que vayas a enlaces permanentes y guardas)
    2) Accede a la administración de tu sitio y desactiva todos los plugins.
    3) Comprueba.

    Iniciador del debate ictboy

    (@ictboy)

    Gracias voy a intentarlo, si alguien tiene alguna otra idea se lo agradecere.

    Iniciador del debate ictboy

    (@ictboy)

    De hecho aqui en en este mismo thread aparece eso mismo, hay alguna manera de quitarlo?

    https://es.wordpress.org/support/topic/problema-en-la-generacion-de-mis-url-google-indexa-etiqueta-post/#post-74043 <—– esto es lo que a mi se me genera al final de mis url ¿alguna idea de que plugin u opcion podria ser?

    Iniciador del debate ictboy

    (@ictboy)

    Es una locura esto, por alguna razón se generan mis permalinks con ese número al final y el bot de google es lo primero que indexa con el ese número pero la realidad es no hay contenido con esa URL que se genera y me ocasiona que tenga que crear una redireccion 301, lo que mas me preocupa es que ese bot es del Google News el cual indexa una url incorrecta creándome una clase de penalización para que mis noticias no aparezcan en el feed de Google News.

    Ayuda por favor en el comentario pasado ya deje que este mismo thread usa ese numero post- y el numero, ¿que opcion tengo que modificar?

    He buscado como loco en google y en el foro de soporte pero no encuentro nada.

    Iniciador del debate ictboy

    (@ictboy)

    Al fin di con el problema es el plugin de Jetpack el cual genera esa etiqueta numerica , desconozco porque lo haga pero ya mejo lo desactive y este problema vino a raiz de la ultima actualizacion, lo uso para compartir de forma automatica en Twitter y Google Plus y las rich cards que genera, pero por alguna razon genera ese plugin y el bot de google news trata de indexarlo de forma automatica al momento de publicar el articulo.

    Moderador almendron

    (@almendron)

    Y ate dije que hicieras las pruebas desactivando los plugisn porque a prioiri es complicado saber cuál es el responsable.

    De todas formas, yo activaría JetPack y luego me iría a https://noticiasacapulco.ga/wp-admin/admin.php?page=jetpack_modules y comprobaría allí qué módulo en concreto es el causante.

    Iniciador del debate ictboy

    (@ictboy)

    Lamento decirte que no fue problema del plugin se volvió a generar el problema aun desactivado, publique mi url de forma manual y aun el bot de google busca la url con ese maldito número que me tiene loco al final, creo que tiene que ver algo de los shortlinks porque no nada mas es el bot de google sino ahora el de grapeshot y el de bing y el de yandex, WordPress genera ese numero y no se porque los buscadores tratan de indexarlo generando el error 404 y toma tu penalización por no encontrar el contenido.

    https://noticiasacapulco.ga/cultura-y-sociedad/ong-inician-proceso-legal-contra-magistrados-de-guerrero-que-absolvieron-a-violador-de-nina-de-2-anos/post-14883 <—- este es el maldito numero, desactive todos los plugins y aun asi lo sigue generando.

    De los modulos de jetpack solo uso dos, las estadisticas y el sharing, es todo.

    Esto volviendome loco porque antes no estaba pasando esto.

    Es obvio que no voy a generar una redireccion 301 por cada enlace que me genera el wordpress, esto es del core y te lo demuestro desactivando todos los plugins.

    • Esta respuesta fue modificada hace 3 años, 7 meses por ictboy.
    • Esta respuesta fue modificada hace 3 años, 7 meses por ictboy.
    Moderador almendron

    (@almendron)

    Lo único seguro es que WordPress no genera ese número. El error podría estar
    1) Plugins
    2) Tema
    3) Interacción plugin con tema
    4) htaccess
    5) Estructura enlaces permanentes.

    Para empezar, yo haría lo siguiente:
    1) Volvería a desactivar todos los plugins
    2) Cambiaría de tema
    3) Luego, accede vía FTP, haz una copia del archivo htaccess en tu ordenador y luego lo borras del servidor (para regenerar este archivo después de las pruebas basta que vayas a enlaces permanentes y guardas)
    4) Ve a Ajustes > Enlaces Permanentes y selecciona «Simple»
    5) Ve a Search Console y comprueba que el robots.txt es accesible para Google y que sea correcto.

    Iniciador del debate ictboy

    (@ictboy)

    Amigo wordpress si lo genera revisa la URL de este mismo thread.

    https://es.wordpress.org/support/topic/problema-en-la-generacion-de-mis-url-google-indexa-etiqueta-post/#post-74065 <—— ese es el numero, ya desactive plugins, cambie de tema regenere el htaccess, salve los permalinks etc…

    Necesito saber la manera de desactivar la generación de ese ID Classs.

    Saludos.

    Moderador Fernando Tellado

    (@fernandot)

    Estoy con @almendron en que lo más normal es que sea un plugin o el mismo tema ¿has probado si desactivando todos y cambiando a un tema por defecto sigue pasando? No vale con desactivar uno, todos.

    Más preguntas. Al publicar una entrada, bajo su título, ¿qué slug se genera?
    Otra: ¿cuál es tu estructura de permalinks?
    Otra: ¿has probado a borrar el archivo .htaccess – previa copia – y crearlo de nuevo guardando los ajustes de enlaces permanentes?

    Hola @ictboy en la pegunta inicial comentas que se añade al final de la misma post-14790 (o el id que corresponda), más adelante dices que es como la url de WordPress del ejemplo que finaliza en #post-74043, son dos temas diferentes…

    La primera es una url diferente y si se entra en la misma da un error 404 al no existir, la segunda es una url correcta y al final lleva un ancla (#) indicando que se desplace hasta la sección con ese id (14790) que en el ejemplo mostrado es el id de la etiqueta article y que contiene los contenidos de la noticia (puedes verlo inspeccionando el código fuente de la página).

    No entiendo totalmente el problema, ya que inspeccionando los sitemaps de las entradas de tu sitio web, todas están correctas y sin post-id al final (https://noticiasacapulco.ga/post-sitemap1.xml y el 2 y 3) y estas urls son las que debe indexar Google si está subido a Google Search Console correctamente…

    Es decir, lo veo todo correcto. Otro tema es que Google intente indexar una url tuya inexistente porque te enlazan desde un sitio web externo con la url incorrecta, en este caso debes investigar la causa de por qué el robot de Google llega a dichas urls erróneas, pero te repito que todas las urls de las entradas de tus sitemaps están correctas.

    Saludos.

    Iniciador del debate ictboy

    (@ictboy)

    Primero que nada muchas gracias por tomarse el tiempo en contestar efectivamente ya modifique en mi archivo fuctions que no se genere el shortlink con un codigo php, creanme que he hecho todas las pruebas validas y en cuanto al theme lo revisare.

    En breve actualizo resultados un abrazo a todos.

    Hola @ictboy,

    ¿Cómo quedaste respecto al problema de las errores 404?
    Utilizo el mismo theme que tú y tengo ese mismo problema, aunque solo desde las URLs compartidas desde Google Plus.

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • El debate ‘Problema en la generacion de mis URL Google indexa etiqueta post-’ está cerrado a nuevas respuestas.