Soporte » Multisitio » Problema en localhost

  • Hola a todos!

    Tengo un problema al crear un Multisite en local. Aparece el siguiente mensaje:

    «ERROR: No puedes instalar una red de sitios con la dirección de tu servidor.
    No puedes usar números de puerto como :8888»

    Tengo declarado ese puerto para ejecutar WordPress con MAMPP, ¿cómo puedo solucionarlo?

    Gracias

Viendo 3 respuestas - 1 de 3 (de 3 total)
  • Moderador LGrusin

    (@lgrusin)

    ¿Has mirado en la documentación?
    https://www.mamp.info/en/documentation/

    Saludos

    Hola LGrusin!

    El problema no está en MAMPP, sino que la opción de Multisite de WordPress, no entiende de los puertos de Localhost.

    En MAMP:

    «On which ports are Apache and MySQL running?

    By default, Apache runs on Port 8888 and MySQL on Port 8889. You can change the ports at any time under Preferences > Ports.

    Can I run Apache on Port 80?

    Yes, you can run Apache on Port 80.»

    Vale!, el problema es que WordPress no entiende de direcciones como Localhost:8888 y Apache hay que configurarlo en el puerto 80 (por lo que se va a pegar con otros servicios, ya abiertos), para que WordPress entienda que Localhost:80/ es igual a Localhost/

    Ahora el tema es que en algún sitio, ni idea de dónde, al activar en PHP el Multisite,
    define(‘WP_ALLOW_MULTISITE’, true);
    se ha almacenado el primer intento y sigue dando el mismo error, haciendo referencia al anterior puerto. ¿Cómo lo soluciono? (ese puerto ya no está activo)

    «Crear una red de sitios de WordPress
    ERROR: No puedes instalar una red de sitios con la dirección de tu servidor.
    No puedes usar números de puerto como :8888.»

Viendo 3 respuestas - 1 de 3 (de 3 total)
  • El debate ‘Problema en localhost’ está cerrado a nuevas respuestas.