Soporte » Guías – Resolución de problemas » Problema etiqueta MRW WordPress

  • Buenas tardes, les escribo porque con la llegada de la nueva versión de wordpress 6.1 la página que administramos de https://carlite.es/ se desconfiguró y, por ello, volvimos a la versión 6.0.3. No sabemos si esa fue la causa, pero nos ha llegado un aviso de error del plugin de MRW, que es la compañía que efectúa el envío de los pedidos, con el título de Tu sitio tiene problemas técnicos.

    De momento el único problema que vemos es que no podemos sacar la etiqueta dentro de un pedido:

    Detalles del error
    ==================
    Se ha producido un error del tipo E_ERROR en la línea 2435 del archivo /srv/vhost/carlite.es/home/html/wp-content/plugins/woocommerce-mrw-carrier/woocommerce-mrw-carrier.php. Mensaje de error: Uncaught TypeError: Unsupported operand types: string * int in /srv/vhost/carlite.es/home/html/wp-content/plugins/woocommerce-mrw-carrier/woocommerce-mrw-carrier.php:2435
    Stack trace:
    #0 /srv/vhost/carlite.es/home/html/wp-content/plugins/woocommerce-mrw-carrier/woocommerce-mrw-carrier.php(851): get_mrw_weight3(Array)
    #1 /srv/vhost/carlite.es/home/html/wp-admin/includes/template.php(1401): order_mrw_nac(Object(WP_Post), Array)
    #2 /srv/vhost/carlite.es/home/html/wp-admin/edit-form-advanced.php(711): do_meta_boxes(Object(WP_Screen), ‘advanced’, Object(WP_Post))
    #3 /srv/vhost/carlite.es/home/html/wp-admin/post.php(206): require(‘/srv/vhost/carl…’)
    #4 {main}
    thrown

    No sabemos si podrían ayudarnos a saber a qué es debido, o si debemos instalar la última versión de WP 6.1. para que se solucione por si algo se hubiera borrado. Si necesitan cualquier dato de acceso o información adicional, no duden en decírnoslo y se los proporcionamos.

    Cuando busques ayuda para este problema, es posible que se te pida la siguiente información:
    WordPress versión 6.0.3
    Tema activo: Uncode Child (versión 1.0.0)
    Plugin actual: MRW (versión 4.3.1)
    PHP versión 8.0.25

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Moderador almendron

    (@almendron)

    Si la página os funciona bien con la versión 6.0.3 de WordPress:

    1) No actualices a la última versión.

    2) Poneros en contacto con el soporte de dicho plugin. Ellos son los que mejor van a valorar el error y quienes deben dar una solución.

    Moderador almendron

    (@almendron)

    Me acabo de dar cuenta de que al volver a la versión 6.0.3 os está dando un problema. Creía que la volver a dicha versión se había solucionado.

    Una pregunta: ¿ya estabais con la versión 8.0.25 de PHP o también la habéis actualizado ahora?

    Por otra parte, usáis productos comerciales a los que los voluntarios del foro no tenemos acceso y por tanto no podemos hacer pruebas.

    Iniciador del debate Raúl Collado

    (@raulcollado)

    Gracias Almendron!. Estábamos en la versión 6.0.3 y actualizamos a la 6.1, pero al ver que se desconfiguró, volvimos de nuevo a la 6.0.3 y a lo mejor al restaurar se perdió algo por el camino. Por la versión 8.0.25 de PHP, ya la teníamos de antes y no la hemos actualizado. Al ser un foro público, no sé cómo indicarle cualquier dato adicional que no sea visible para todo el mundo que necesitasen para tener acceso y hacer pruebas, ya que en este formulario no viene la opción de que sólo lo veas tú, los moderadores o administradores.

    Moderador almendron

    (@almendron)

    Por lógica, la vuelta atrás de WP parece ser la causante del problema. Siempre podíes hace lo siguiente:

    1) Copia de seguridad del sitio (base de datos y archivos)

    2) Desinstalar el plugin y luego borrar.

    3) Volver a instalar el plugin.

    Aunque tuviéramos acceso, poco podríamos hacer. Desde el foro, a lo sumo que se llega es a instalar en un WP limpio los plugins y temas que fallan para determinar si es un error general o bien uno particular de la instalación de quien informa del error.

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.