Soporte » Plugins y Hacks » Problema galería de imágenes

  • Resuelto veredes

    (@veredes)



    (en enlace es un ejemplo ya que el problema se repite en las galerías).
    Buenos días.
    Antes de nada dar la gracias por vuestro tiempo y ayuda, y también pedir disculpas por la más que segura falta de información para que podáis ayudarnos en este caso, debido a la falta de experiencia en estas lides. Esperamos compensarla aportando la información complementaria que nos solicitéis. También disculpas si la pregunta en cuestión no se ajusta al tema del foro, por lo que si así fuese pedimos que nos indiquéis donde sería adecuado realizarla.
    Nuestro problema en esta ocasión, es con la galería de imágenes ya que al pinchar en cualquiera de la imágenes de la parrilla la pantalla se pone en negro y se cuelga, únicamente podemos salir de la gallería refrescando la página. Actualmente utilizamos el pluguin LightGallery (Versión 1.0.3 | Por LightGallery Team). Supuestamente es compatible con la versión 4.9.8 que tenemos de wordpress. También hemos probado a desinstalar el plugin e instalar otro por si fuese esa la solución pero no ha funcionado.
    ¿Alguien puede ayudarnos?
    ¡De nuevo muchas gracias!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • Moderador almendron

    (@almendron)

    Prueba a desactivar Autoptimize.

    Hola Almendron.
    Probado. Sigue sin funcionar…

    Moderador almendron

    (@almendron)

    Desactiva Autoptimize y W3 Total Cache (vacía antes la cache). Luego comprueba. Son los dos candidatos a dar problemas. Es muy importante que las pruebas las hagáis con el plugin de cache desactivado.

    Si sigue sin funcionar, desactiva TODOS los plugins, cambia de tema y comprueba.

    Si se resuelve es ir revirtiendo las desactivaciones y comprobando en cada ocasión hasta halar al responsable.

    Si aún así no se resuelve el problema, prueba a activar https://es.wordpress.org/plugins/easy-fancybox/ en lugar del que tenéis. Te indico éste porque es seguro que funciona bien con la versión actual de WordPress.

    Moderador almendron

    (@almendron)

    Acabo de ver que tienes un error en la cabecera de tu blog. Hay abiertos dos “head”:

    <head>
    <meta name="google-site-verification"......
    
    <head>
    <link rel="shortcut icon" href="https://veredes.es/blog/wp-content/themes/veredes_ske/favicon.ico" />
    <meta charset="UTF-8" />
    .....
    </head>
    veredes

    (@veredes)

    Buenos días ALmendron.
    Ants de nada darte las gracias por la ayuda que no estás prestando.
    Hemos probado a hacer las recomendaciones que no hiciste ayer. Al final medio arreglamos el tema de la galería (al menos ahora se ven las fotografías aunque debe haber algo que entra en conflicto porque son parecen dos galerías a la vez, la del plugin que nos indicas y una por detrás que es la que crea el conflicto). En cuanto al head que comentas, crees que es lo que entra en conflicto o es otro error que no habíamos detectado. Muchas gracias nuevamente.

    Moderador almendron

    (@almendron)

    Ya me he fijado que aparecen dos galerías. Es una pregunta tonta pero… ¿habéis desactivado el otro plugin? Me da la impresión de que están los dos activos.

    Dejad solo uno de los dos y haced las comprobaciones que os dije ayer. Casi seguro que un plugin o el tema son incompatibles con la galería. Eso sí, solucionar antes lo del HEAD.

    Buenas tardes Almendron.
    Muchas gracias por todos los consejos, los hemos vuelto a realizar para asegurarnos y ya hemos conseguido que funcione todo de nuevo correctamente.
    Muchas gracias por tu tiempo y paciencia.

    Moderador almendron

    (@almendron)

    De nada.

    ¿Cuál era el problema? Convendría que indicarais cual fue por si sirve de ayuda a otros usuarios.

    Hola Almendron.
    El problema era una incompatibilidad de plugins actualmente. No sabemos el porqué ya que en principio estaban actualizados, pero al hacer las combinaciones que nos recomendaste el problema desapareció. Suponemos que algún problema con el theme pero no podríamos asegurarlo. Si lo descubrimos lo pondremos para que a otros usuarios lo pueden saber.
    ¡Saludos y muchas gracias!

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • Debes estar registrado para responder a este tema.