Soporte » Instalación – Actualizaciones » Problema para restaurar copia de seguridad (diferente dominio)

  • Resuelto FerOrpinell

    (@ferorpinell)


    Hola,
    Estoy teniendo problemas a la hora de restaurar la copia de seguridad. Antes tenía mi blog en un dominio (pilatesyfitness.com) con el que he tenido problemas con la empresa que lo administra (que también administraba el hosting), por lo que he adquirido un nuevo dominio (ferorpinell.com) y hosting. En el anterior blog, he hecho backup con el plugin BackWPup. Ahora, con el nuevo dominio y el hosting ya funcionando, tengo problemas para restaurar esta copia de seguridad, he probado hacerlo desde la base de datos del hosting y desde wp-admin, pero no lo he conseguido, no aparecen los contenidos ni nada de la copia de seguridad. Me podeis ayudar por favor?
    Gracias.

    http://ferorpinell.com/

Viendo 15 respuestas - de la 1 a la 15 (de un total de 16)
  • He vuelto a subir la copia de seguridad desde ftp, creo que es más fácil, luego he cambiado el wp-config con la info adecuada según mi base de datos actual, pero sigue sin funcionar, supongo que es por el cambio de dominio, pero no encuentro solución. help!

    ¿Que es sigue sin funcionar?

    La web carga bien, la web no carga, la web da un error, la web redirecciona, la web ????????

    me refiero a que la copia de seguridad no se restaura, o sea, el problema que estoy presentando no se resuelve pese a mis intentos. Me da la impresión que la raíz de esta incidencia es que es otro el dominio (como explicaba antes)
    Gracias.

    ¿Pero que es no se restaura?

    El problema aquí es que solo tu sabes como era antes, entonces es imposible saber a que te refieres con restaurar bien sin que lo expliques.

    ¿Falta contenido?
    ¿Esta a la mitad?
    ¿El contenido sale pero las imágenes no?

    Puede ser que la base de datos no sea la indicada.

    ¿Hiciste respaldo de la base de datos y la importaste en la nueva?

    Saludos.

    No se restaura me refiero a que no se carga ni contenido, ni imágenes ni absolutamente nada. Como lo decía antes, hice el back up en su momento (mayo de este año) con el plugin BackWPup.
    Repito, intenté importarla desde ftp y no conseguí resultado (nada cargó, reitero, ni imagenes, ni contenidos ni nada). También intenté instalando el wordpress en la base de datos y hacerlo con un plugin, pero tampoco obtuve resultados positivos.
    No consigo restaurar la copia de seguridad, es el trabajo años, no entiendo por qué no lo puedo restaurar, en su momento creo haber hecho backups de manera correcta, por si alguna vez tenía problemas de algún tipo. Estos problemas se presentaron y ahora no puedo restaurar el back up.
    Si puedes asesorarme en esto te lo agradecería mucho.
    Saludos.

    ¿Hiciste respaldo de la base de datos y la importaste en la nueva?

    si, subo todos los archivos por ftp

    si, subo todos los archivos por ftp

    No, la base de datos no tiene nada que ver con FTP, por eso pregunto:

    ¿Hiciste respaldo de la base de datos y la importaste en la nueva?

    Saludos.

    te refieres al archivo sql? es en ese paso que creo que hay un error, lo intento hacer via phpmyadmin o bien importarlo desde wordpress con el plugin wordpress importer pero sale un error.
    con phpmyadmin el error es el siguiente: SQL query:


    — Table structure for wp_commentmeta

    DROP TABLE IF EXISTS wp_commentmeta ;

    MySQL said: Documentation

    #1046 – No database selected
    con el wordpress importer el error es el siguiente: sorry, there has been an error.
    This does not appear to be a WXR file, missing/invalid WXR version number

    ok, lo intenté otra vez. Te explico mi modo de operación paso por paso:
    subio todos los archivos de la copia de seguridad por ftp.
    Exporto sql por phpmyadmin
    lo paso por un script cambiando la antigua url por la nueva.
    importo este sql ya cambiado por phpmyadmin y sale ese error:

    SQL query:


    — Database: qsn583

    CREATE DATABASE qsn583 DEFAULT CHARACTER SET latin1 COLLATE latin1_spanish_ci;

    MySQL said: Documentation

    #1007 – Can’t create database ‘qsn583’; database exists

    qsn583 es el nombre de la base de datos de mi hosting.

    No se como corregir esto. Creo que es alguna configuración de phpmyadmin

    Ok, dos cosas.

    1- SQL no se puede importar desde WordPress.

    2- Si tienes que exportar e importar desde PHPMyAdmin, pero no lo estas haciendo de forma correcta.

    Por el error que pones estas intentando crear la base de datos de nuevo en lugar de importar las tablas a ella.

    Saludos.

    Hola,

    si, ahora me doy cuenta de que sql no se puede importar desde wordpress.

    El otro error lo pude salvar comentando unas lineas del script de la sql (no tengo muhca idea de programación sql, pero investigando puedo ir avanzando cosas).

    Pero sigo encontrando errores. Ahora, por ejemplo, he logrado cargar cosas de la copia de seguridad, pero no aparece con un formato wordpress si no como un texto plano. Y tampoco puedo crear los links correspondientes, es decir, por ejemplo, si quiero entrar en un post, intenta hacer el link de la url antigua (y esto ya lo he intentado cambiar con un script em la sql)
    La verdad estoy encontrando muchos problemas en este paso y no se como resolverlo!
    Se te ocurre algo?
    Gracias.

    pero no aparece con un formato wordpress si no como un texto plano

    WordPress no tiene un formato, entonces ni idea a que te refieras. ¿Que no aparece con formato WordPress?
    ¿El titulo, el post, la barra lateral, el css, o que?
    ¿Que es formato WordPress?

    tampoco puedo crear los links correspondientes, es decir, por ejemplo, si quiero entrar en un post, intenta hacer el link de la url antigua

    ¿Entrar a un post para leer, desde el administrador o como?

    Saludos.

    lo siento, mi lenguaje técnico no es el mejor.

    Como administrador no me deja entrar, es como si el wordpress no estuviera instalado, no tiene formato wordpress quiero decir que nada, estética ni funcionalmente, luce como wordpress.

    Ha cargado el título, posts, barra lateral, pero al clicar (no como administrador) para leer un post, por ejemplo, intenta abrir ese post con la url antigua.

    Gracias.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 16)
  • El debate ‘Problema para restaurar copia de seguridad (diferente dominio)’ está cerrado a nuevas respuestas.