• Resuelto Iescamez

    (@iescamez)


    Buenas a todos, bueno he contratado OVH para mi web y resulta que no se me conecta a la base de datos.

    He leido algun post de la web y tampoco me solucionan nada y sinceramente estoy mas que desesperado, haber realice una copia de seguridad desde el WP-admin tanto de los archivos como de la base de datos, por si no pudiese funcionar descargue los archivos desde FTP y realice copia de seguridad del MYPHPADMIN, instale todos desde la copia de seguridad, configuro el wp-config.php pongo la base de datos con su nombre, pongo el usuario con su nombre porngo la password y pongo el localhost.

    bueno teoricamente configurado y nada de nada falla.

    Cambio el nombre de localhost por la direccion de la base de datos y el error que me da es;

    No se ha podido encontrar la dirección DNS del servidor de http.
    Prueba a:
    Comprobar la conexión
    Comprobar el proxy, el cortafuegos y la configuración de DNS
    Ejecutar Diagnósticos de red de Windows
    ERR_NAME_NOT_RESOLVED

    Ya me estoy volviendo loco estoy desesperado….. por favor ayudenme!!

    Muchas gracias.

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • Hola @iescamez

    Entiendo que quizás no sea lo más viable dar información de datos de la base de datos a nivel servidor pero seguro que si nos pones por aquí los parámetros que OVH te ha facilitado para tu base de datos y que supongo tendrás configurados en el wp-config.php podremos decirte si estás conectándolos correctamente.

    Seria útil saber que tipo de base de datos tienen contratada con OVH (un servidor de bases de datos o la que por defecto ofrecen con un Hosting básico) y confirma si el usuario de esa base de datos tiene los privilegios correspondientes para usar esa base de datos.

    Con dicha información será posible hacerse una mejor idea del escenario y ver si es un fallo tuyo o del servidor de base de datos de OVH, al que parece que no conectas. Indicar la url de tu sitio web también ayudará a ver que error exacto devuelve.

    Otro detalle importante: Prueba desde un navegador que no sea Google Chrome 😉

    Saludos

    • Esta respuesta fue modificada hace 2 años, 7 meses por Luis Méndez Alejo. Razón: adición de texto
    Moderador almendron

    (@almendron)

    Ponte en contacto con el soporte de tu hosting y comentales el problema porque tiene toda la pinta de ser cosa del servidor.
    A veces, por ejemplo, no se utiliza «localhost» sino otra porque la base de datos la alojan en un servidor distinto al tuyo y entonces cambia ese valor.

    Moderador almendron

    (@almendron)

    Supongo que algún otro moderador habrá borrado tu último comentario porque ese tipo de información no se puede poner. JAMÁS lo vuelvas a hacer porque comprometes tu sitio.

    @gnumax: se que lo haces con buena voluntad pero no vuelvas a pedir ese tipo de datos.

    Moderador almendron

    (@almendron)

    Por lo demás, veo que has activado el «Multisitio». Yo probaría a quitarlo (tanto del wp-config.php como del htaccess).

    vale gracias haber indagando indagando y llevo 6 dias jodidisimo, creo que el problema es de las DNS por lo que se ve el problema que reporta cuando estoy en localhost es que no encuentra base de datos, y cuando le pongo la direccion de la base de datos me da error de DNS puede ser?

    porque si entro con la direccion adpiqueñas.es/license.txt funciona perfectamente pero cuando lo hago a la web si el DB_host: localhost me reporta error de base de datos, si del otro modo modifico el localhost por el nombre de la base de datos en el servidor me reporta error de DNS.

    No se si estoy indagando bien en el tema.

    Bueno el tema esta solucionado ya funciona la web.

    Muchas Gracias.

    Moderador almendron

    (@almendron)

    ¿Cómo lo has solucionado? Tus respuestas podrían ayudar a otros usuarios con problemas parecidos.

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • El debate ‘Problema WEB’ está cerrado a nuevas respuestas.