Foros » Guías – Resolución de problemas » Problemas al agregar script, y cambiar estructura de enlaces permanentes

  • Hola que tal? Buenas tardes.
    Al agregar este script en el «HEADER» de mi sitio, las paginas y posts funcionan correctamente:
    <script type=’text/javascript’ src=’//go.oclaserver.com/apu.php?zoneid=771802′></script>
    Es un script para poner publicidad en mi sitio.
    Pero cuando cambio la estructura de «Enlaces permanentes» de «SIMPLE» a cualquier otra estructura, cualquier post es redirigido a Google a esta pagina:
    https://support.google.com/accounts/answer/61416

    Ya probé desactivando todos los plugin, cambiando el tema, limpiando las cookies, etc. El problema es cuando se cambia la estructura de enlaces permanentes. Ya contacté a la empresa de publicidad y me dicen que es un problema de WordPress. Ya que el problema ocurre cuando cambias la estructura de los enlaces.
    Aqui les pongo un video mostrando el problema: https://youtu.be/BQIdThSQQLM
    Es mejor las otras estructuras de enlaces permanentes, ya que ayudan mejor con el SEO.
    Saludos…

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Moderador LGrusin

    (@lgrusin)

    Depende de dónde estés colocando el script.

    En todo caso el problema sería del script y no de WordPress. No deberías acceder desde dentro del escritorio. Para hacer bien la prueba cierra sesión, elimina temporales del navegador y entras a la página o posts como si fueras un visitante.

    Acude al soporte del mismo.

    Un saludo

    • Esta respuesta fue modificada hace 7 años, 6 meses por LGrusin.
    • Esta respuesta fue modificada hace 7 años, 6 meses por LGrusin.
    Moderador LGrusin

    (@lgrusin)

    Iniciador del debate ironman45

    (@ironman45)

    Hola @lgrusin, gracias por tu apoyo.
    El problema ocurre solo con los posts de WORDPRESS, en las paginas funciona perfecto.
    Ya he probado con todas las combinaciones posibles.
    Hice los pasos tal cual como lo recomienda Propeller, y el problema aparece cuando cambias la estructura de Permalinks.
    Luego del cambio de PERMALINKS, la primera vez que visitas el post, funciona, pero cuando refrescas la pagina aparece la redireccion.
    Hice un nuevo blog y ocurre lo mismo. Desactivé los plugin, cambié de tema, contacté al equipo de soporte de Propeller y me dicen que es WordPress, ya que su publicidad no actúa cuando refrescas la pagina.
    Por casualidad alguien tiene un blog montado con posts de WordPress con Propeller?
    Si dejo la estructura por defecto todo funciona excelente, pero muchos plugin importantes requieren el cambio para funcionar, ademas de que ayuda al SEO.
    Espero tu respuesta, saludos…

    • Esta respuesta fue modificada hace 7 años, 6 meses por ironman45.
    Moderador LGrusin

    (@lgrusin)

    Es que el script tal como está no puedes ponerlo en un post. Lo mejor es que edites el archivo single.php (o el que use tu tema) y añadas el código allí.

    Un saludo

    Iniciador del debate ironman45

    (@ironman45)

    Por fin, alguien que sabe, infinitas gracias @lgrusin, ya he probado de todo, con shortcodes, plugins y nada.
    Te agradecería inmensamente que me digas como editar en WordPress single.php para incluir los códigos en los posts y no me aparezca el error…
    En que parte de single.php iría el código que puse arriba?
    Gracias, gracias y gracias…

    • Esta respuesta fue modificada hace 7 años, 6 meses por ironman45.
    Moderador LGrusin

    (@lgrusin)

    Depende del tema que uses. En los nuevos si añades el script antes del bucle while o después (según dónde quieras ubicar la publicidad) con modificar el archivo index.php es suficiente. Ya saldría en todas las páginas.

    Si no es eso lo que quieres entonces tendrás que modificar más archivos, sin saber qué tema usas es imposible darte más detalles.

    Un saludo

    Iniciador del debate ironman45

    (@ironman45)

    Muy buenos dias @lgrusin, estoy muy agradecido con tu apoyo.
    Estoy usando el tema Newspaper…
    Solo quiero colocar el código para que cuando alguien dé un click en el POST, se abra un pop up. Es lo que hace el script.
    Agregando el código como dice Propellerads solo me funciona en las PAGINAS y no en los POSTS, ya que me aparece el error de redireccion a Google.
    Ademas del tutorial de Propellerads, he probado agregando el script con plugins, shortcodes, etc. Cual es la forma mas eficiente de colocar el código donde me dices?
    Ya he escrito en muchos blogs, (incluyendo al soporte de propellerads) y por fin encuentro a un experto en el tema de WordPress 🙂
    Muchas gracias 🙂

    • Esta respuesta fue modificada hace 7 años, 6 meses por ironman45.
    Moderador LGrusin

    (@lgrusin)

    Pues no vamos a poder ayudarte porque el tema es de pago y no tenemos acceso al código.

    Volvamos al principio:

    – ¿Has seguido las indicaciones del enlace que puse antes?
    Lo más fácil es poner el script en el header.php después de la etiqueta body.
    – Como dice en ese enlace también puedes poner el script en un widget de texto.
    ¿Lo has probado?
    – Comprueba que el código es correcto, sobre todo las comillas que al copiar suelen cambiarse.
    – Comprueba eliminando archivos temporales del navegador
    – Comprueba con otro tema que no sea Newspaper
    – Comprueba con otro navegador

    Luego del cambio de PERMALINKS, la primera vez que visitas el post, funciona, pero cuando refrescas la pagina aparece la redireccion.

    Eso no se hace así.

    Repito:

    …cierra sesión, elimina temporales del navegador y entras a la página o posts como si fueras un visitante…

    Un saludo

    Iniciador del debate ironman45

    (@ironman45)

    Hola @lgrusin voy a cambiar el tema a uno gratuito: Mesocolumn.
    Mi prioridad en el sitio es que funcione el código en los posts.
    Si, he probado todo lo que dices actualmente, ahorita tengo el codigo en el widget de la barra lateral como aparece en el tutorial de propeller.
    Volvi a copiar el código, borré todos los datos de navegacion, y despues de la primera visita al post, al recargar la pagina, aparece el error…
    Si quieres prueba visitando mi página ironman45.cu.cc
    Veras que al hacer click en un post la publicidad funciona solo la primera vez, luego redirecciona a Google.
    Hice un reset al wordpress y lo tengo con el post «Hola mundo», y aun asi aparece el problema…
    Aqui te pongo el código single.php de mesocolumn http://pastebin.com/f30ABgnm
    Aqui el header.php de mesocolumn http://pastebin.com/DWYfnqDw
    En Chrome funciona bien, es en Mozilla y Edge, donde aparece el error.
    Creo que el problema no tiene que ver con el tema, plugins. Tiene que ver con la forma como se agrega el codigo, que veo que lo del widget y tutorial de propeller no funciona con posts de WordPress. He probado con varios temas y desactivando todos los plugin.
    Agradecido por tu apoyo, saludos…

    • Esta respuesta fue modificada hace 7 años, 6 meses por ironman45.
    • Esta respuesta fue modificada hace 7 años, 6 meses por ironman45.
    • Esta respuesta fue modificada hace 7 años, 6 meses por ironman45.
    Moderador LGrusin

    (@lgrusin)

    OK, he podido comprobarlo…

    Si te fijas es Google quien muestra el mensaje no Mozilla. Puede que tenga que ver con un acuerdo que tienen Mozilla y Google para una protección anti-phishing y Software malicioso que viene activada por defecto en el navegador.

    Lo cual lleva a dudar de las garantías de este tipo de publicidad por medio de Popup muy intrusiva e incómoda para el usuario.

    Ya esto se escapa del foro de WordPress. En mi opinión no deberías usar este tipo de publicidad.

    Saludos

    Iniciador del debate ironman45

    (@ironman45)

    @lgrusin lo extraño es que colocando los permalinks de forma simple, cuando los posts terminan en numeros, por ejemplo: /?p=123
    en este caso no ocurre el error de Google…
    Podría dejarlo así, pero lo malo es que varios plugin no funcionan con esta forma de permalinks, y el SEO no trabaja muy bien con este tipo de permalinks.
    Espero tu respuesta @lgrusin, saludos…

    Moderador LGrusin

    (@lgrusin)

    Habrá algo que no le gusta al script cuando se usa permalink. Por eso no es un código limpio y fiable.

    Mi consejo es que no insistas con esa publicidad, busca otra forma de obtener ingresos. Al final te perjudicas a ti y a tus visitantes.

    Además corres el riesgo de que tu sitio sea bloqueado como web atacante y entonces tendrás otros problemas mayores.

    Saludos

    Iniciador del debate ironman45

    (@ironman45)

    Muchas gracias por tu apoyo @lgrusin
    Exitos y bendiciones en tu camino 🙂

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • El debate ‘Problemas al agregar script, y cambiar estructura de enlaces permanentes’ está cerrado a nuevas respuestas.