Soporte » Guías – Resolución de problemas » Problemas al cargar las imágenes

  • Resuelto andreavicedo

    (@andreavicedo)



    Hola, no sé si este tema está resuelto pero no encuentro nada. Cuando cargo las imágenes me las carga y al actualiza la página o la entrada se borran, me dice “Las respuesta no es una respuesta JSON válida.” de las pocas que se cargan luego muchas sale como archivo roto. He probado a desinstalar temas, plugins, diferentes formatos, modificar algunos parámetros, etc. He intentado hacer lo de depurar pero mis conocimientos de programación son 0. Muchas gracias de antemano.

Viendo 11 respuestas - 31 de 41 (de 41 total)
  • Pues entonces no sé cómo he logrado que cargue bien. Siento si mi respuesta puede confundir a alguien. La idea era la contraria.

    Moderador almendron

    (@almendron)

    @chairomaru : tranquilo. No pasa nada.

    Haz una cosa: edita una entrada cualquiera, clic en “Añadir objeto”, pestaña “Subir archivos” y allí verás que pone…

    “Tamaño máximo de archivo: ” y una cantidad. Comprueba en tu caso cuál es ese límite.

    Hola:

    Lamento reabrir este tema, pero tengo un problema parecido y no he encontrado solución con las respuestas anteriores.

    Mi tema es “Hamilton” de Anders Noren, tengo la última versión de wordpress y estaba intentando rediseñar las paginas de mi portfolio cuando me he encontrado con el mismo problema.

    Si subia las fotos que tengo en la biblioteca de medios no hay problema. Puedo trabajar con ellas. Pero si intento subir una foto nueva me da el error. He intentado con un tamaño de 3000×2000 (2.53MB) y con 2000×1333 (1,13MB).

    De los dos tamaños hay fotos en la biblioteca de medios y si se han cargado sin problemas.

    No tengo el modulo JSON de Jetpack activado.

    ¿Hay algo más que pueda hacer?

    Gracias.

    Hola yo aún sigo con problemas, en el ordenador se ven bien pero con el móvil siempre falla.Yo tengo el plugin Smush para recudir el tamaño, mi problema era una carpeta que se había quedado de un plugin entre otras cosas.

    Moderador LGrusin

    (@lgrusin)

    Yo lo que no puedo entender es para qué necesitan esas imágenes tan grandes. Cuanto mayor es la resolución mayor es el tamaño del archivo de la imagen.

    Se pueden conseguir imágenes con relación de aspecto 4:3 o 16:9 (800 x 600, o 1920 x 1080) con un tamaño de archivo de 100 kilobytes o menos. Subir una imagen de 1.33 Megabytes es un disparate. Incluso siendo la de la cabecera se puede comprimir sin perdida de calidad apreciable.

    Además ningún tema muestra las imágenes a esos tamaños. ¿Para qué subir una imagen a 2000×1333 pixeles si el tema la muestra a 800 x 600 o menos?.

    Bueno @lgrusin es una cuestión de aprendizaje. Uno va haciendo las cosas mal hasta que se encuentra con un error, lo arregla y deja de cometerlo.

    Haces una web, como la mía, enfocada a la fotografía y tratas de encontrar un equilibrio entre el tamaño y la calidad mostrada en pantalla. Hasta ahora esos tamaños no me habían generado ningún problema y en los test de velocidad y optimización de google todo estaba ok. Supongo que habrá sido suerte.

    Luego, cuando llegue a casa después del trabajo, probaré los tamaños y pesos que recomiendas y, si como es previsible, se soluciona el problema lo cuento por aquí.

    Muchas gracias por la guía de tamaños y pesos. Prometo no volver a subir un “elefante” a mi web. 😉

    @andreavicedo probare el plugin que recomiendas a ver que tal me funciona y, lo mismo, en cuanto observe resultados cuento por aquí para compartir el máximo de info posible.

    Saludos (y gracias) a los dos.

    Moderador LGrusin

    (@lgrusin)

    Suele ser la forma habitual de proceder de los fotógrafos. No entienden que una web, por su naturaleza, no es lugar para mostrar imágenes a tamaño completo. No hay equilibrio cuando se trata de estos temas. Lo primero que te dice Google en su guía SEO es que optimices las imágenes, da igual el contenido del sitio.

    Si quieres que tus visitantes vean una muestra de tu trabajo, es tan fácil como poner un enlace a una imagen a calidad completa. El resto de imágenes del sitio no tienes por qué subirlas a máxima calidad y tamaño completo.

    Aquí tienes una guía más detallada de Google sobre imágenes
    https://developers.google.com/web/fundamentals/performance/optimizing-content-efficiency/image-optimization?hl=es

    • Esta respuesta fue modificada hace 3 semanas, 1 día por  LGrusin.

    ¡¡Muchas gracias, @lgrusin !!

    Lo cierto es que tienes razón, hay bastantes errores que, sobre la marcha, voy descubriendo que cometo, pero intento arreglarlos lo mas “eficientemente” posible. Así que te agradezco muchísimo la paciencia y la info. Voy a leer esa guía de arriba a abajo.

    Por cierto el problema del que hablabamos aqui, al menos en mi caso, no estaba en el tamaño de las fotos (a pesar de que ya las estoy optimizando todas). El problema estaba en el pluggin “W3 Total Cache”.

    Hice pruebas con fotos de diferentes tamaños. Incluso por debajo de 100K; pero siempre me daba error. Se me ocurrió probar a subirla directamente a biblioteca de medios y ahí fue cuando el mensaje de error de refería a este plugin.

    Lo desactive y ya podía subir las fotos de nuevo. Incluso las “gigantes”.

    Ahora lo que tengo que averiguar es que aspecto del plugin entraba en conflicto con la subida de las fotos.

    No me ha dado tiempo de buscar solución en los foros, pero echo un ojo por ahí y en cuanto lo averigüe, de un modo u otro, lo diré aquí. Que seguro que a alguien más le puede estar pasando esto.

    Saludos.

    Moderador LGrusin

    (@lgrusin)

    Cuando haces cambios en el sitio, sobre todo de aspecto o diseño, es conveniente vaciar primero y desactivar después el plugin de caché. Una vez el sitio esté terminado activas el plugin.

    aloisglogar

    (@aloisglogar)

    Haré esa prueba. Ahora lo tengo desactivado. A ver me da tiempo de acabarlo todo esta noche y reactivo.

    Ya te cuento.

    Muchas gracias, de nuevo, @lgrusin

    Ya he hecho todas las pruebas y todo parece solucionado.

    Efectivamente parecía tener que ver, (gracias @lgrusin ) con el desmesurado tamaño de mis fotos.

    Lo que hice fue: desactivar, como ya conté, el “W3 Total Cache” y actualizar mi “Next gen gallery” a “pro”. AL final es una inversión razonable para mi. Esta versión tiene un optimizador de imágenes y las deja con el tamaño y el peso apropiados para no sobrecargar la web.

    Y debe de funcionar bien. Porque hice una prueba, con el “W3 Total Cache” activado, subiendo una imagen grande, como hacia antes pero con los correctores del Nextgen activados, y no dio ningún problema.

    Así que, de momento, todo solucionado así.

    Gracias a todos.

Viendo 11 respuestas - 31 de 41 (de 41 total)
  • Debes estar registrado para responder a este tema.