Soporte » Seguridad » Problemas al hacer mi pagina segura con https

  • Resuelto micocinavegana

    (@micocinavegana)


    Buenos días, tengo un pequeño problema con mi página web, siempre me sale que no es segura, me puse en contacto con mi servicio del hosting que contrate y me enviaron una guía para solucionarlo, seguí todos los pasos, pero me sigue dando errores. Instale el plugin HTTPS redirection como me indicaron y en los ajustes del plugin me da el siguiente error:

    ¡Importante! Si está utilizando complementos de almacenamiento en caché similares a W3 Total Cache o WP Super Cache, debe borrar su caché después de habilitar o deshabilitar la opción de redireccionamiento automático. Si no lo hace, puede provocar una advertencia de contenido mixto desde el navegador.

    Aviso: es muy importante estar extremadamente atento al hacer cambios en el archivo .htaccess.

    Si después de hacer cambios su sitio deja de funcionar, haga lo siguiente:

    Paso # 1: Abra el archivo .htaccess en el directorio raíz de la instalación de WordPress y elimine todo entre las siguientes dos líneas

    # COMIENZO HTTPS Redirección Plugin
    # END HTTPS Redirection Plugin

    Paso # 2: Guarde el archivo htaccess (esto borrará cualquier cambio que este complemento haya realizado en ese archivo).

    Paso # 3: Desactive el complemento o cambie el nombre de la carpeta de este complemento (que desactivará el complemento).

    Los cambios se aplicarán inmediatamente después de guardar los cambios, si no está seguro, no haga clic en el botón «Guardar cambios»

    Me dijeron en el soporte del hosting que era algo relacionado con la configuración de mi wp.

    Gracias!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Tienes problemas de contenido mixto, en tu web mantienes algunos enlaces http que debes cambiar. Revisa estos debates donde se explica como solucionarlo.

    Problema de contenido Mixto paginas no seguras

    No carga https

    Recuerda cerrar el debate marcándolo como resuelto cuando así lo consideres, de esta forma nos ayudas a mantener el foro al día.

    Hola José Luis, muchas gracias por responder tan pronto, he leído los enlaces que me has enviado, entiendo el problema, pero no se como solucionarlo..
    Me dijeron en el hosting que tenia dos imágenes erróneas, una la bore porque era de internet, pero la otra era mía, hecha con mi cámara reflex. Tengo que cargarla como https para que no me de error? o eso he querido entender.. Perdona pero soy novata en esto y todo me suena a Chino.. 🙂
    Gracias!

    • Esta respuesta fue modificada hace 1 mes, 1 semana por micocinavegana.
    Moderador Jose Luis

    (@jose64)

    Hola @micocinavegana

    Una explicación muy básica sería que el certificado de seguridad y el protocolo https aseguran que el contenido de la web es seguro, pero si una parte de ese contenido no está cubierto por esa capa de seguridad no se puede garantizar que toda la web es segura, por eso se muestra el mensaje de que el contenido es inseguro.

    El problema es ese, si cargas cualquier contenido (en tu caso unas imágenes) como http se produce ese error, todo el contenido tiene que estar cargado como https. La forma de solucionarlo está en esas entradas, bien con un plugin que fuerce la carga o bien modificando directamente los enlaces en la base de datos.

    Si, he entendido el porque me ocurre, pero que me gustaría saber como soluciono que ahora no sea segura, porque no voy a borrar todo para cargarlo de nuevo.. no?
    Y cuando lo cargue como hago para que siempre sea en https?
    Yo he cargado las fotos y demás sin saber con que protocolo lo hacía.. es lo que tiene no saber..
    O al tener el plugin que te comenté antes ya se cargan todos con https de forma segura?

    gracias por tu tiempo!

    Moderador Jose Luis

    (@jose64)

    Por favor, revisa nuevamente los debates que te indiqué, en ellos está no solo la explicación sino la solución en las dos formas posibles.

    No tienes que borrar nada ya que el problema no es el contenido sino la forma en que lo muestras.

    Lo ideal es que hagas los cambios en la base de datos con Better Search Replace, con eso solucionas los enlaces que ya están, los nuevos tienes que añadirlos correctamente.

    Recuerda hacer una copia de seguridad de la base de datos antes de hacer modificaciones por si acaso tienes algún problema.

    Buenas tardes, he seguido todos los pasos indicados, también el video

    Al configurar todo parece que se arregló, ya no me aparecía en ninguna de las páginas No es seguro, habilite mi constructor visual del tema instalado (divi) para seguir tabajando y me volvió a salir de nuevo No es seguro en varias de las páginas de mi web….

    Moderador Jose Luis

    (@jose64)

    ¿Y por qué desactivaste DIVI?, repite el proceso. Yo puestos a hacer el proceso lo hubiese hecho modificando en la base de datos directamente, así no hay fallos nunca.

    NO, yo no he desactivado DIVI, quizá me expresé mal. Hice todas las configuraciones desde mi escritorio, cuando entre en la web para corroborar que ya funcionaba bien todo iba genial.
    Comencé a trabajar de nuevo para terminar el diseño de mi web y me emepezó a dar el error de no es segura otra vez

    Buenas tardes, sigue sin funcionar, he vuelto ha seguir todos los pasos de las dos opciones que me enviaste para solucionar el problema y sigue apareciendo no es seguro, me podría ayudar por favor?
    UN saludo y gracias!

    Moderador Jose Luis

    (@jose64)

    Hola

    Haz una copia de respaldo de la base de datos

    Desactiva los plugins que estés usando para forzar SSL (Ready Simple SSL o cualquier otro)

    Instala Better Search Replace, haz la búsqueda para todas las tablas de http://www.micocinavegana.net y reemplaza por https://www.micocinavegana.net, primero en modo de prueba, si te indica que hay cambios, ejecútalos.

    Te agradezco de verás tu tiempo de corazón, pero no sé porque sigue ocurriéndome lo mismo. He vuelto ha hacer todo lo que me has comentado e incluso ahora me aparece en todas las páginas de mi web (ayer lo último que hice solo aparecía en una).
    Y no he vuelto a tocar nada del diseño ni a modificar ningún contenido de esta.
    Lo siento por la pesadez, pero no se me resuelve

    Moderador Jose Luis

    (@jose64)

    Hola

    Ahora el problema es con el logo (http://micocinavegana.net/wp-content/uploads/2020/05/Logo-redondo-e1590168733733.png), revisa en las opciones de personalización del tema, puedes volver a seleccionarlo para que se actualicen los cambios.

    Por fin!!!!!!! Ahora si que si!! Se solucionó, mil gracias de verdad!! ya estaba desesperada.. Ahora ya todas las imágenes que suba se suben el htpps de forma natural no?

    Moderador Jose Luis

    (@jose64)

    Hola @micocinavegana

    Me alegro de que por fin esté resuelto. El problema será siempre la llamada que hagas, tienes que hacerlas siempre sobre https.

    Si insertas imágenes manualmente (escribiendo tú el código) tienes que asegurarte de que las urls sean https, si se insertan desde WordPress no tienes problema, las llamadas serán todas https.

    Gracias por cerrar el debate.

    Gracias a ti!!!

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Debes estar registrado para responder a este debate.