Foros » Guías – Resolución de problemas » Problemas con contenido OpenGraph

  • Hola ! soy nuevo en el foro y me presento : Estoy a cargo de una página de noticias que utiliza la plataforma de wordpress para subir diariamente las noticias, tengo conocimientos muy básico sobre programación y estoy haciendo lo mejor para sacar a flote la web y aprendiendo de este maravilloso mundo cada día.

    Al grano – Hace un par de semanas eh tenido problemas con el contenido compartido de facebook, coloco el link ,ejem :

    https://laopinion.pe/2019/02/27/hospital-socorro-realiza-campana-de-limpieza-y-recojo-de-inservibles/

    y en el depurador como vista previa me aparece : Comentarios : (OTRO TITULO DIFERENTE AL QUE SE MUESTRA EN EN LINK) algunas veces se muestra la entrada como debéria ser , otras veces solo la web y la información del metadata.

    eh desactivado plugin por plugin (incluso eliminé el ALL IN SEO que tenía por el Yoast) pensando que se solucionaría y sin embargo sigue igual.

    Espero poder ser sido claro, espero atento sus respuestas.
    Saludos

    • Este debate fue modificado hace 5 años, 1 mes por julioher. Razón: Resalte

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Moderador almendron

    (@almendron)

    No te funcionaba bien porque el servidor arroja un código 206. Preguntaré a los compañeros porque no tengo ni idea de por qué hace eso.

    De todas formas, ponte en contacto con el soporte del hosting a ver qué te dicen.

    Moderador Mariano Perez

    (@mpcdigital)

    Iniciador del debate julioher

    (@julioher)

    Hola gracias por responder, me puse en contacto con ellos y al primer contacto me dicen :

    le indico que nosotros no mantenemos bloqueos en cuanto al contenido de los sitios o con grandes sitios, es muy probable que los datos que no estén mostrándose correctamente tengan que ser declarados en el archivo sitemap o robots, dentro de su sitio web.

    Después les envío unos screen de como me aparece en el depurador y están tratando de resolver el problema, pero ya una semana sin respuesta.

    Saludos.

    Iniciador del debate julioher

    (@julioher)

    @mpcdigital No creo que sea un virus de computador, porque me sale lo mismo al compartir por medio de mi celular.

    Moderador Mariano Perez

    (@mpcdigital)

    Hola,

    entonces si no es un virus, tenemos que pensar en qué es lo que está cortando la conexión con el servidor antes de tiempo.
    Prueba a deshabilitar todos los plugins para hacer la prueba de si pasa lo mismo sin plugins activados o revisa si pudiera ser alguna configuración de seguridad que tuviera el servidor.

    David Navia

    (@davidnaviaweb)

    Hola @julioher. Veo que tienes activado un plugin de caché. Puedes probar también a regenerar la caché que tengas almacenada actualmente.

    Iniciador del debate julioher

    (@julioher)

    @mpcdigital Lo haré en un par de horas que el horario de visitas baje y la siguiente pregunta es que utilizo un tema Child, también puede influir?

    @davidnaviaweb hola! gracias por responder, como regenero el caché ? en mi panel superior del wordpress hay un aviso de «Vaciar la Caché» siempre le doy click cada vez que me aparece esos problemas para compartir en faecebook, pero nada. tengo que esperar hasta que cambie el metadata.

    Es muy raro, porque a veces me aparece la etiqueta tal como se muestra en el link , otras veces me aparece otro metadata y después de un tiempo me aparece otra como la que eh indicado en el primer mensaje.

    • Esta respuesta fue modificada hace 5 años, 1 mes por julioher.
    Iniciador del debate julioher

    (@julioher)

    Intenté desactivando los plugins y aún persiste el error.

    Moderador Mariano Perez

    (@mpcdigital)

    Bien ya hemos descartado eso. Si no es problema de la instalación de WordPress ahora habría que verificar si es el servidor.
    Haz una copia de la web con plugin de backup (o Duplicator, All in one WP migrationo el que sea) y restauralá en otro servidor para probar, por ejemplo, aquí: https://demoswp.com/
    A ver si cambiando de servidor se reproduce el problema.

    David Navia

    (@davidnaviaweb)

    Adicionalmente a lo que dice @mpcdigital, puedes usar un plugin de staging (WP Staging en su versión free, por ejemplo), que te permite crear una copia de la web sin mayor complicación en el mismo servidor. En esa copia de staging puedes trastear todo lo que quieras (desactivar todos los plugins, cambiar de tema, etc) e intentar diagnosticar si el problema es realmente del servidor o del software.

    Como dices, estás usando un tema child de Twentyseventeen. Prueba a activar el tema padre o uno más moderno como el Twentynineteen para ver si esto afecta.

    ¡Ánimo!

    Iniciador del debate julioher

    (@julioher)

    Me aparece en el depurador de facebook después de algunos intentos :

    Errores críticos que deben ser solucionados :
    Could Not Connect To Server Check that the webserver is running, and that there are no firewalls blocking Facebook’s crawlers.

    Iniciador del debate julioher

    (@julioher)

    Hola ! aún sigo con el error, intenté:

    1.- Cambiando el tema child – (sigue igual)
    2.- Hize un backup con el « All-in-One WP Migration» pero no lo pude descargar, porque me da error para descargar o el archivo era muy pesado, pero me cortaba la descarga a los segundos de descargarlo, intentaré con el WP Staging

    Estaré informando …

    • Esta respuesta fue modificada hace 5 años, 1 mes por julioher.
    David Navia

    (@davidnaviaweb)

    Fenomenal. Mucho ánimo.

    Iniciador del debate julioher

    (@julioher)

    Hola! ya hice una copia de los archivos en el mismo servidor utilizando : plugin de WP Staging desactivé todos los plugins incluso el tema child, lo cambié a otro y dejó de aparecerme el error en la depuración de facebook.

    Depuro la misma entrada y el resultado es :

    1.- WEB ORIGINAL (Plugins y Tema child) : Sigue apareciendo el error
    2.- COPIA WEB (0 plugins y cambio de tema) : Dejó de aparecer el error.

    Ahora tengo que ir probando Plugin uno por uno a ver cual es el conflicto.

    Descartado el tema del hosting. Es el software.

    Seguiré informando.

    Saludos y gracias por la ayuda.

    • Esta respuesta fue modificada hace 5 años, 1 mes por julioher.
    • Esta respuesta fue modificada hace 5 años, 1 mes por julioher.
    Iniciador del debate julioher

    (@julioher)

    Hola ! me temo que aún sigue el error con el que estoy…

    Hice :

    1.- Desactivé el plugin con el que hacía «conflicto»
    2.- Borre e hice que yoast cree otra vez el archivo robot.txt además de limpiar el plugin anterior que tenía «All SEO one «

    Este es el código que me sale al hacer click en Depurador de Objetos Open Graph de facebook, link de Scraped URL:

    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
    <html><head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    <?xml version="1.0" encoding="UTF-8"?><rss version="2.0" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:sy="http://purl.org/rss/1.0/modules/syndication/" xmlns:georss="http://www.georss.org/georss" xmlns:geo="http://www.w3.org/2003/01/geo/wgs84_pos#"><channel><title>
    	Comentarios en: Anuncian pronta construcción de moderno hospital en Parcona	</title>
    <link href="https://laopinion.pe/2018/07/13/anuncian-pronta-construccion-de-moderno-hospital-en-parcona/feed/" rel="self" type="application/rss+xml">
    <link>https://laopinion.pe/2018/07/13/anuncian-pronta-construccion-de-moderno-hospital-en-parcona/
    	<description>El Diario de Mayor Circulación Regional</description><lastbuilddate>
    	Thu, 21 Feb 2019 19:54:50 +0000	</lastbuilddate><updateperiod>
    	hourly	</updateperiod><updatefrequency>
    	1	</updatefrequency><generator>https://wordpress.org/?v=5.1</generator></channel></rss>
    </head></html>

    Al ingresar a la url : https://laopinion.pe/2018/07/13/anuncian-pronta-construccion-de-moderno-hospital-en-parcona/feed/

    Aparece al inicio :

    This XML file does not appear to have any style information associated with it. The document tree is shown below.

    Espero su respuesta.
    Saludos

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • El debate ‘Problemas con contenido OpenGraph’ está cerrado a nuevas respuestas.