Soporte » Guías – Resolución de problemas » Problemas con Jetpack tras última actualización

  • Muy buenas, pues eso, desde la última actualización de WordPress, Jetpack me ha deshabilitado las actualizaciones automáticas en la sincronización con wordpress.com. Cuando entro al panel de Jetpack me sale lo siguiente:

    SE HAN DESHABILITADO LAS ACTUALIZACIONES AUTOMÁTICAS
    Las actualizaciones automáticas no están disponibles para xxx.com. Un administrador del sitio ha deshabilitado explícitamente todas las actualizaciones automáticas.

    a continuación me indica: ¿Cómo lo puedo solucionar? y me enlaza a esta respuesta de la cual no entiendo nada no porque sea en inglés sino porque no me aclara qué es lo que sucede:

    I can’t install, update, remove, or autoupdate plugins from WordPress.com
    In order to manage plugins on your Jetpack-connected site from WordPress.com, your site needs to be configured properly. Your site cannot be under version control, and you must be able to install plugins and update them without entering a FTP username and password.

    The following constants also need to be set to false or not defined: DISALLOW_FILE_MODS and AUTOMATIC_UPDATER_DISABLED. And any plugin that intentionally disables autoupdates must not be active.

    Me gustaría que alguien pudiese ayudarme con este problema, muchas gracias.

Viendo 15 respuestas - 1 de 15 (de 17 total)
  • Moderador almendron

    (@almendron)

    Una pregunta: ¿dónde tienes alojado tu sitio? ¿en wordpress.com o en un hosting distinto?

    Hola, es wordpress.org, lo que Jetpack se sincroniza con el .com para poder inciar sesión etc, pero lo tengo en un hosting normal y corriente de carga por ftp etc.

    Moderador almendron

    (@almendron)

    En principio, que tengas o no habilitadas las actualizaciones automáticas no debería ser el motivo del error. Yo mismo las tengo deshabilitadas en todos mis sitios y nunca he tenido problemas con ello.

    Yo probaría lo siguiente:
    1) Desactiva el plugin.
    2) Vuelve a activar.
    Esto hará que te pida de nuevo los datos para conectarte a wordpress.com

    • Esta respuesta fue modificada hace 2 años, 7 meses por  almendron.

    Qué va, eso fue lo primero que intenté, lo desinstalé de hecho, pero nada. El caso, es que yo soy webmaster de unas cinco o seis webs y en ninguna me ha pasado salvo en la mía personal, que tiene narices la cosa. Me viene muy bien eso de que Jetpack te actualice los plugins solo porque así no tengo que estar siempre pendiente, pero ahora por culpa de eso tengo que estar siempre pendiente de las nuevas actualizaciones y hacerlo a mano. Además es que fue de la noche al día tras la última actualización de WordPress, me encontré que los plugins ya no se actualizaban solos y salía lo que comento al inicio del hilo.

    • Esta respuesta fue modificada hace 2 años, 7 meses por  WordPress_User.

    Y añado que hasta borré el archivo wp-config y las bases mysql y las hice nuevas y nada, al volver a funcionar, seguía pasando lo mismo 🙁

    Moderador almendron

    (@almendron)

    Me vas a disculpar pero no entiendo eso de que Jetpack se encarga de actualizar los plugins. Hasta donde yo se, dichas actualizaciones nada tienen que ver con el plugin.

    Pues así es, Jetpack se sincroniza con una cuenta de WordPress.com y una de las funciones que tiene es que actualiza los plugins automáticamente cuando hay una nueva versión

    Moderador almendron

    (@almendron)

    Ah! Vale! Te refieres a la opción Jetpack Manage que, una vez activada, te permite gestionar los plugins que tienes instalados en tu sitio. Es que pensaba que te referías a que Jetpack tenía un módulo específico para ello dentro de las opciones que aparecían en WordPress.

    Y supongo que habrás comprobado si los ajustes son los correctos…

    Si, si, efectivamente, todo comprobado, incluso ayer nuevamente volví a desinstalarlo y desincronizarlo del .com y nada, todas las demás webs que llevo tienen esa función intacta y la mía impide esa función

    Moderador LGrusin

    (@lgrusin)

    Hay plugins incompatibles con Jetpack, comprueba que no sea debido a eso.

    Un saludo

    Probaré a desactivar uno a uno y comprobar si es eso, gracias 🙂

    Pues nada, desactivado uno a uno cada plugin y nada, sigue igual… yo creo que el problema radica en el htaccess o alguna línea que haya que añadir a wp-config pero no sé cual

    Moderador almendron

    (@almendron)

    A ver si es que tienes desactivado en config las actualizaciones automáticas.
    https://codex.wordpress.org/Configuring_Automatic_Background_Updates

    Nada, yo me rindo… 🙁 he probado a añadir define ( ‘WP_AUTO_UPDATE_CORE’, true); al wp-config pero nada, he mirado el mismo wp-config de las demás webs que llevo y no tiene ninguna diferencia con el mío, sinceramente no entiendo por qué de repente me pasa esto pero en fin, paciencia y a actualizar a mano, qué remedio. Gracias a todos.

    Respuesta para @jbn_wordpress.
    En lo que se refiere a la actualizacion automatica de los plugins desde wordpress.com revisa el archivo wp-config.php de tu sitio y al final del mismo puede que tengas esta linea de codigo:

    //— disable auto upgrade
    define( ‘AUTOMATIC_UPDATER_DISABLED’, true);

    Si cambias true por false deberia permitirte actualizar los plugins, temas automaticamente si los habilitas en tu pagina de wordpress.com.
    Un saludo de Alfonso.

Viendo 15 respuestas - 1 de 15 (de 17 total)
  • El debate ‘Problemas con Jetpack tras última actualización’ está cerrado a nuevas respuestas.