Soporte » Guías – Resolución de problemas » Problemas con mi menu principal

  • Resuelto tiendaepalmer

    (@tiendaepalmer)


    Hola, estoy teniendo problemas con el menu principal de la pagina, el mismo esta compuesto por cursos – blog – acerca de – mi cuenta – contacto – iniciar sesion. El problema aparece cuando hago click en iniciar sesion o en acerca de mi, desaparece del menu el boton de cursos, con el resto de los botones se muestra todo bien. No creo que sea problema del tema porque me ha pasado con otro tema tambien. Que podra ser?
    Desde ya gracias!

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • Moderador almendron

    (@almendron)

    Indica la URL par ver el problema y también el tema que usas.

    Iniciador del debate tiendaepalmer

    (@tiendaepalmer)

    Perdon la URL es http://tecnoamiga.com/ y el tema es Specia

    Moderador almendron

    (@almendron)

    Ve a Apariencia > Menús y comprueba cuantos menús tienes.
    Prueba a borrarlos todos y luego volver a construirlos.

    Iniciador del debate tiendaepalmer

    (@tiendaepalmer)

    Hice como dijiste pero sigue igual. Un detalle importante que me di cuenta recien, que si estoy logeado ya sea como admin o usuario se muestran bien todos los cambios que realizé y el menu se muestra bien, de otra forma como un invitado probe con mozilla y chrome y en los dos hay partes que actualizé en mi pagina que no se muestran o aparece el problema del menu.

    • Esta respuesta fue modificada hace 5 años, 1 mes por tiendaepalmer.
    Moderador LGrusin

    (@lgrusin)

    Prueba sin el plugin de caché.

    Un saludo

    Moderador almendron

    (@almendron)

    Entonces, como dice @lgrusin, es el plugin del cache. Vacía la cache.

    Iniciador del debate tiendaepalmer

    (@tiendaepalmer)

    Probe instalando WP Super Cache y borrando el cache, pero aun asi no encuentro la solucion. Tendra algo que ver el hosting? Muchas gracias por sus respuestas!

    Moderador almendron

    (@almendron)

    Si accedes al código fuente de cualquiera de tus páginas, verás que al final pone <!--Generated by Hostinger Page Cache-->

    Si estás usando el plugin Hostinger Browser Cache, debo decirte que no lo he encontrado en el repositorio de WordPress y por tanto no es conveniente usarlo.

    Lo primero de todo es desactivar y ver si así se resuelve el problema. Los plugins de cache a veces meten archivos en el directorio «wp-content» del tipo xxxx-cache.php y xxx-cache-xxx.php. Estos archivos también hay que borrarlos.
    También suelen insertar código en el .htacces
    Por último, comprueba que en el archivo wp-config.php no está define (WP_CACHE’, true);

    Iniciador del debate tiendaepalmer

    (@tiendaepalmer)

    Muchas gracias por su ayuda al fin se soluciono!! fui siguiendo los pasos de almendron y encontre una carpeta en el servidor llamada hostinger-page-cache, elimine esa carpeta y funciono todo. Nuevamente muchas gracias!

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • El debate ‘Problemas con mi menu principal’ está cerrado a nuevas respuestas.