Soporte » Guías – Resolución de problemas » Problemas con Sitemap

  • Hola comunidad, soy nuevo aquí pero siempre os he leído desde google, ahora vengo a plantear un problema, seguramente me orientarán y se los agradeceré mucho

    Verán, tengo varias paginas propias y un problema común. No me están generando los sitemaps es decir tengo el «enlace» y cuando entro me aparece una pagina en blanco, sin mas, ya está pagina blanca. Cuando voy al search console y le digo cual es en enlace de mi supuesto mapa del sitio me aparece «Su sitemap no contiene ninguna URL. Valídelo y vuelva a enviarlo» claramente porque están en blanco.

    He mirado en oculto, desde el móvil, desde otro lugar y nada de nada. Lo he tratado de generar a través de Yoast y nada, luego probé otro plugin de google y lo mismo pagina en blanco.

    Tengo WP Rocket y le puse en el apartado de precargar «activar la función de precarga de cache a través del mapa del sitio» y abajo de esa me sale una opción que dice «Hemos detectado automáticamente el mapa del sitio generado por el plugin Yoast SEO. Puedes marcar la opción para precargarlo» la marqué pero nada, pagina en blanco.

    ¿Qué creen que pueda ser?

    Muchas gracias

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte de WordPress. Por lo que dices el problema es que no estás generando el sitemap correctamente, ya que estás usando Yoast SEO te dejo una entrada con información relativa a la configuración:

    Guía completa: cómo crear y personalizar mapas del sitio XML (sitemaps) con Yoast

    Coméntanos si lo resuelves con esa información y, por favor, recuerda cerrar el debate marcándolo como resuelto cuando así lo consideres, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate dape89

    (@dape89)

    Hola muchas gracias por responder Jose

    Leí la información pero no me sirve, es decir en la parte general tengo el sitemap activado, en apariencia del buscador tengo todo para mostrar y en las páginas tengo puesto abajo en la caja de seo todo en si

    ¿Permitir a los motores de búsqueda mostrar esta Página en los resultados? si
    Deberían los motores de búsqueda seguir los enlaces en esta Página si

    Te mandaría pantallazo pero no veo como hacerlo y si entras al enlace de la web sale la pagina vacía.

    Hable con la compañía de hosting y me dicen que todo esta bien que debe ser algo en el wordpress; pero lo extraño es que tengo 3 webs y en las 3 me pasa lo mismo; es decir algo tengo que estas haciendo mal si o si.

    Alguna otra idea?
    Gracias

    Moderador Jose Luis

    (@jose64)

    Hola.

    Te dejo el enlace a la guía para incluir imágenes en los foros.

    es decir en la parte general tengo el sitemap activado

    ¿Has seguido el enlace para verlo?

    Iniciador del debate dape89

    (@dape89)

    Moderador Jose Luis

    (@jose64)

    Hola.

    Podrías empezar por actualizar todo a las últimas versiones, no puedes actualizar WordPress y dejar atrás tema y plugins. Estás usando una versión de Yoast Seo desactualizada y puede ser la causa del problema.

    Iniciador del debate dape89

    (@dape89)

    Hola Jose
    Tienes razón en esta web no tenia el yoast actualizado, ya actualicé pero todo pero sigue igual me muestra una hoja en blanco cuando voy a http://bildestudio.com/sitemap_index.xml

    Hola yo tengo otro problema con el contenido de mi sitemap. En mi caso yo uso Rankmath y cuando voy a los ajustes de sitemap de Rankmath hago incluir los posts de manera que cuando entro en el índice de mi sitemap hay una sección que es dominio/post-sitemap.xml. El problema es que cuando entro en ese elemento del sitemap me lleva a la página de inicio de mi dominio que es la que tienen todos los posts pero no me incluyes los posts individualmente en mi sitemap por lo que no son indexados y no aparecen en los motores de búsqueda. Se le ocurre a alguien una solución?
    PD puede ser que esto me suceda por que en ajustes de lectura me figura la home como la página que recoge los últimos posts en vez de ser una página estática? Siendo así como lo arreglo si solo quiero una web que sea un blog?

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘Problemas con Sitemap’ está cerrado a nuevas respuestas.