Soporte » Seguridad » Problemas con urls de http a https

  • Resuelto tgpindado

    (@tgpindado)


    Hola,
    Estoy intentando pasar mi sitio de http a https y encuentro los siguientes problemas, si podéis ayudarme os lo agradezco porque no encuentro solución.
    No puedo cambiar la url en «ajustes generales» de http a https porque está bloqueado para cambios y no sé como desbloquearlo. He cambiado en Php my Admin (cpanel) las tablas wp_options sin resultado.
    Creo que por este motivo los permalinks siguen siendo http y lo que ocurre es que las imágenes que se guardan en la galería también tienen la url http y ese es el error que me da en la página de test del certificado ssl. No se como cambiar la url de la imagen (en los post las he cambiado con el plugin Better search and replace). No puedo utilizar el plugin Velvet blues porque no es compatible con mi versión.
    Mi tema es Virtue y mi sitio Paris infinito.
    Muchas gracias,

Viendo 6 respuestas - 1 de 6 (de 6 total)
  • Hola, podrías probar a añadir en tu htaccess lo siguiente:

    
    # TODO SSL
    RewriteCond %{HTTPS} !on
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,QSA,L]
    

    Y en wp-config.php:

    
    define( 'FORCE_SSL_ADMIN', true );
    define( 'FORCE_SSL_LOGIN', true );
    

    Si quieres más info: https://davidrd.com/forzar-el-uso-del-ssl-en-todo-nuestro-wordpress/

    Un saludo!

    • Esta respuesta fue modificada hace 1 año, 10 meses por  alcaudon89. Razón: Para que la zona de código salga bien formateada

    Ahhh también puedes probar a modificar el valor de la url de «ajustes generales» desde el wp-config.php

    define( 'WP_HOME', 'https://example.com' );
    define( 'WP_SITEURL', 'https://example.com' );

    Es más, después de probarlo he comprobado que si pones esos valores en tu wp-config.php se bloquean en «ajustes generales».

    https://codex.wordpress.org/Editing_wp-config.php#WP_HOME

    • Esta respuesta fue modificada hace 1 año, 10 meses por  alcaudon89.
    • Esta respuesta fue modificada hace 1 año, 10 meses por  alcaudon89.

    Mil gracias por la rapidez de las respuestas, había olvidado decir que ya había cambiado el htaccess, sin resultado.
    Pruebo y os informo

    Ya está!!! Cambiado y sin problemas. El test ssl pasa bien aun no tengo el candado pero me imagino que en breve podré vero.
    Muchísimas gracias a los dos
    Saludos

    De nada!

    Me alegro que haya funcionado!

    Revisa la pestaña seguridad en las herramientas de desarrollador de Chrome (F12 en Windows) y mira qué te dice.

    Es probable que algún widget o contenido apunte a fuentes no seguras, revisa tu código fuente y mira lo que viene con http en vez de https. Haz los cambios pertinentes y el candado deberá de mostrarse.

    • Esta respuesta fue modificada hace 1 año, 10 meses por  Marco Zink.
Viendo 6 respuestas - 1 de 6 (de 6 total)
  • El debate ‘Problemas con urls de http a https’ está cerrado a nuevas respuestas.